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Conventions

This symbol identifies a hazard or procedure that, if incor-
rectly performed, could cause personal injury or result in 
equipment damage. It is also used to bring the user’s atten-
tion to details that are considered IMPORTANT.

This symbol alerts the user they are about to perform an 
action involving, either a dangerous level of voltage, or to warn 
against an action that could result in damage to devices or 
electrical shock.

This symbol alerts the user they are about to perform an 
action involving possible exposure to laser light radiation.

This symbol identifies a procedure that requires you take 
measures to prevent Electrostatic Discharge (ESD) e.g., use an 
ESD wrist strap. Circuit boards are most at risk. Please follow 
ESD procedures.

This symbol draws attention to details or procedures that may 
be useful in improving, maintaining, or enhancing the perfor-
mance of the hardware or software being discussed.
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Welcome

About this Help system:
This Help System is designed for users who will be using Laser Editor to create 
graphics layouts for laser engraving operations.

Using the Help System:
You might access the whole contents by choosing Help > Help from the Laser 
Editor's menu bar, or pressing F1 in the main screen of the application.
Furthermore, you can take advantage of the context-sensitive Help, that is, you 
can display a Help topic based on what you are doing:

• Pressing F1 (or the ? button in a window's title bar) opens dialog or window 
level Help;

• clicking a properties title in the Properties window (such as, for example, 
Geometry) when working on a document or a graphic object, then pressing 
F1, opens a table with a description of those properties.

Contents of the Help
The Help is organized into the following main topics:

Chapter Contents

Getting Started With Laser Editor Presents an overview of the product in terms of 
scope, architecture, and User Interface.

Preliminary Operations Describes how to register Laser Editor as well as how 
to set the default parameters for the application.

Creating Graphic Layouts
Describes how to create a graphic layout by adding 
objects to a plane or ring document, and how to 
operate on objects.

Performing The Engraving Operation
Provides instructions on how to test your graphic lay-
out and how to complete the laser engraving opera-
tion

Laser Engine User Interface Describes how to use the Laser Engine user interface.
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Chapter 1
Getting Started With Laser Editor

This chapter is organized into the following sections:

Topic What you will learn

About Laser Editor Scope and overview of Laser Editor's features, and 
architecture of the new laser marking units.

“Laser Editor's User Interface quick 
reference”

Quick reference guide in terms of work environment, 
toolbars, and menus of Laser Editor.
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About Laser Editor
Laser Editor is the ultimate laser marking software suite that allows users to 
easily mark, etch, or engrave product identification information such as 2D 
matrix codes, linear barcodes, postal codes, stacked bar codes, text including 
any industry standard font formats, alpha-numeric serial numbers, date codes, 
part numbers, graphics and logos in any production environment.
Laser Editor represents an evolution of the development undertaken with the 
previous program Smartist.
Laser Editor is a complete laser marking system that can be used for:

• graphic layouts editing
• laser devices fine-tuning and control, including an integrated I/O module 

for axis management that allows integration into a production line or 
other marking equipment

• fully customization by creating automated procedures
• easy integration into assembly lines with or without PC
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What's new in Laser Editor
Laser Editor has a new smart and intuitive graphic interface which has been 
localized into several languages. A context-sensitive help system guides you 
through the procedures for creating and marking your layouts.
Furthermore, new powerful and flexible features have been added.

New graphic editing features have been added, including but not lim-
ited to:

• improved vectors editing capabilities
• advanced vectorial processing features for automated editing of nodes
• new import filters
• advanced filling patterns are supported
• a complete “Array” feature specially designed for Integrated Circuits (IC) 

marking
• interactive marking time evaluation function
• marking order optimization feature
• mark preview capability (implemented at scripting editor level too)
• undo/redo capabilities

(For further information, see Creating Graphic Layouts).
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New advanced features have been added:
• 4 axis motor control for rotary indexers, Z axis, Rotor axis, X-Y tables, and 

so forth
• Built-in I/O module for external equipment control
• “On the fly” marking capabilities with a configuration wizard
• Remote control of the marking process over Ethernet
• User control and password management

A fully programmable application:
Project Editor, a new powerful programs editor, has been added. You can create 
your own programs and automation tools:

• update the layout contents at runtime
• load and mark documents
• collect data from external sources or database systems
• build a custom user interface
• use advanced debugging functions
• and much more

Project Editor is supplied with source files samples, reference material, and a 
context-sensitive Help system.

ActiveX interface (licensed feature)
ActiveX interface has been added to Laser Engine. This provides users that are 
familiar with Smartist ActiveX programming a similar way to easily write custom 
graphic interface on top of Laser Engine without dealing with the details of low 
level laser controlling. 

Notes

Related topics:
• “Laser Editor's User Interface quick reference”

Plugins are not available when using ActiveX. For more 
details, please refer to the Project Editor online documenta-
tion, chapter “Language reference”.
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Laser Editor's User Interface quick reference
This section provides an overview of the Laser Editor User Interface to be used 
as a quick reference, and in particular:

• Work environment- How the Laser Editor's environment is organized
• Using toolbars tools- A quick overview of the available toolbars buttons

Work environment
The picture below shows the main window of Laser Editor when you access it:

Work environment components:
Notes

For a more detailed description of how to display, hide, or dock 
the components of the work environment of Laser Editor, 
please refer to Setting your work environment.

Area Description

Menu bar with all the Laser Editor commands.

Toolbars with the tools that allow you to:
• draw and manage the engraving layout (see Using toolbars tools)
• interact with the laser device (see Laser toolbar.)
• manage user rights on the system functions (see Laser Engine chapter, section Manag-

ing users and access rights
You can display a toolbar by selecting the corresponding button in the vertical Select toolbar. 
Furthermore, you can hide/display toolbars by right-clicking a blank area in the upper part of 
the window.
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Select toolbar - The vertical toolbar allows switching between toolbars. Each buttons acti-
vates a subset of horizontal toolbar buttons.
You can hide/display this toolbar by right-clicking a blank area in the toolbars area.

Undo/redo command list - It lists all the actions that you have performed during layout edit-
ing, It allows keeping track of all actions, and undoing or redoing any of these actions. To 
undo/redo an action, select it, then do one of the following:

• click the  buttons on the toolbar

• choose Edit > Undo (or Redo) from the menu bar

The Undo/redo window can float over the work area, or you can dock it at the left-side of the 
window, just below the toolbars, by double-clicking its title bar. Furthermore, you can hide/
display this window by right-clicking a blank area in the toolbars area.

Objects engraving order - It shows the order in which the objects that were added to the doc-
ument will be engraved. To change the marking order, drag the objects to the desired posi-

tion. To optimize the marking order, you can use the  Marking order function that is made 

available after clicking the  Adjust Objects button on the vertical toolbar.
This window can float over the work area, or you can dock it at the left-side of the window, 
just below the toolbars, by double-clicking its title bar. Furthermore, you can hide/display 
this window by right-clicking a blank area in the toolbars area.

Work area - The graphic work area where the engraving layout or the sequence will be repre-
sented. When you select File > New plane (or ring) document, the document is displayed in 
this area. You might work on more documents at the same time; in this case, at the top of the 

work area, the documents tabs will be displayed  to allow 

you to switch between documents. To close an individual document, click the  button at 
the top-right of the area.
Attention: The maximum width of the work area is defined by the focus length set in Laser 
Configuration. (See Setting the work area)

Properties browser - It tells you information (that is, settings) about any selected object in 
the work area. Documents are treated as objects in Laser Editor; so, if no object is selected, 
the document's properties are displayed. The Property browser can float over the work area, 
or you can dock it at the right-side of the window, just below the toolbars, by double-clicking 
its title bar. Furthermore, you can hide/display this window by right-clicking a blank area in 
the toolbars area.
The property browser supports context-sensitive Help: Clicking a properties title (e.g., Geome-
try) and then pressing F1, opens a table with a description of those properties.

Status bar -It shows name and status of the connected laser device. Furthermore, when the 
mouse pointer rests on a toolbar button, a brief descriptions of the button is displayed in this 
area.

Area Description
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Using toolbars tools
In this section:

• Vertical vs. horizontal toolbar
• Standard toolbar
•  Insert Objects toolbar
•  Objects Operation toolbar
•  Adjust Objects toolbar
•  Zoom toolbar
•  Laser toolbar

Vertical vs. horizontal toolbar
Laser Editor has a vertical toolbar (the select toolbar) and a horizontal toolbar.
The horizontal toolbar contains a standard set of buttons (the main toolbar) 
plus a variable set of buttons; this set changes depending on the button that 
you click on the vertical toolbar.
In the example below, the Zoom toolbar has been displayed after pressing the 
Zoom button on the vertical toolbar:

The following tables briefly describes the function of each toolbar buttons. Fol-
low the link in the table to display the Help topic with more function details. 

Notes Buttons are available or unavailable depending on the opera-
tion you are performing.
Toolbars can also be hidden/displayed by right-clicking on a 
blank area in the toolbars area and then deselecting/selecting 
the items from the shortcut menu.
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Standard toolbar
This toolbar is always displayed:

Button Description

Layer - It allows opening a new document in the work area, either Layer, Extended Layer, Ring 
Document or Sequence. Click the button to open a new Plane Document opens; click the down 
arrow. To display the dropdown list that allows you to select the desired document:

(Same as menu command File > New):

Project editor - It launches the Project Editor application which allows creating programs in 
order to automate marking operations. (Same as menu command File > Project editor).

Open - It opens the window that allows choosing an existing layout. (Same as menu com-
mand File > Open).

Save - It opens the window that allows saving a layout. (Same as menu command File > 
Save).

Mark Preview - It allows checking the final result of the marking process of your layouts 
directly in Laser Editor. This button is made available after creating or opening a document in 
the work area. (Same as File > Mark Preview).

Cut - It allows cutting the selected object. (Same as menu command Edit > Cut).

Copy - It allows copying the selected object. (Same as menu command Edit > Copy).

Paste - It allows pasting the object. (Same as menu command Edit > Paste).

Undo - It allows undoing the selected command. (Same as menu command Edit > Undo).

Redo - It allows redoing the previously undone command. (Same as menu command Edit > 
Redo).
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Insert Objects toolbar
This toolbar is displayed after pressing the  Insert Objects button on the ver-
tical toolbar. It allows adding objects to the current document. See About 
graphic objects for more information.

Button Description

Remove object(s) - It allows removing the selected object. (Same as menu command Actions 
> Remove object(s).

Text string - It allows inserting a text string into the current document. (Same as menu com-
mand Actions > Insert > Text string).

Code - It allows inserting a code into the current document. (Same as menu command 
Actions > Insert > Code).

Imported - It displays the window that allows you to insert an imported graphic object into 
the current document. You might import vectorial or raster images, AutoCad/AutoDesk .DXF 
and .DWG files, .HPGL or .PLT files, as well as existing layouts (.XLP files). (Same as menu 
command Actions > Insert > Imported).

Array - It allows inserting an array into the current document. (Same as menu command 
Actions > Insert > Array).

Circle - It allows inserting an ellipse into the current document. (Same as menu command 
Actions > Insert > Circle).

Rectangle - It allows inserting a rectangle into the current document. (Same as menu com-
mand Actions > Insert > Rectangle).

Poly - It allows inserting a polygon into the current document. (Same as menu command 
Actions > Insert > Poly).

Lines - It allows inserting a line into the current document. (Same as menu command Actions 
> Insert > Lines).

Dot - It allows inserting a dot into the current document. (Same as menu command Actions > 
Insert > Dot).
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Evaluator toolbar

Button Description

Marking time - It allows calculating the time for engraving the active document.
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Objects Operation toolbar
This toolbar is displayed after pressing the  Objects Operation button on the 
vertical toolbar. It allows operating on objects, such as, for example, grouping/
ungrouping objects, editing vectors, and so forth. See Grouping, merging, or 
joining objects for more information.

Button Description

Group selection - It allows grouping the selected objects in a single object. Single objects keep 
their properties, but the transformation and movement operations involve all grouped 
objects. (Same as menu command Actions > Group selection).

Merge selection - It allows assembling two or more objects in a single object. Single objects 
keep their properties, with the exception of laser and filling properties. (Same as menu com-
mand Actions > Merge selection).

Ungroup selection - It allows disassembling grouped or merged objects so they can be moved 
or changed individually. (Same as menu command Actions > Ungroup selection):

Union - It allows assembling vectorial objects so that their constituting polygons are merged 
into a single object. This operation can only be reversed using the Undo command. (Same as 
menu command Actions > Union).

Intersection - It allows assembling overlapping objects into a new single vectorial object. Only 
the area that is common to the objects will be considered for the engraving. This operation 
can only be reversed using the Undo command. (Same as menu command Actions > Intersec-
tion).

Difference - It allows assembling overlapping objects into a new single vectorial object. Only 
the outline of the first selected object, minus the common area, will be marked. This opera-
tion can only be reversed using the Undo command. (Same as menu command Actions > Dif-
ference).

Exclusion - It allows assembling overlapping objects into a new single vectorial object. The 
outlines of the two objects will be marked, minus the common area.This operation can only 
be reversed using the Undo command. (Same as menu command Actions > Exclusion).

Make vectorial - It allows converting the selected string or code into a vectorial object for you 
to be able to edit nodes. Note that, when a string is made vectorial, it loses its properties and 
becomes a simple vectorial object. (Same as menu command Actions > Make vectorial). See 
Editing objects vectors for more information.

Advanced processing - This button allows accessing the advanced vectorial processing 
options that provide an automated way to edit vectors. (Same as menu command Actions > 
Advanced processing). See Using Advanced Processing options for further information.

Edit nodes - It allows editing the nodes of a vectorial object. When you press this button, the 

 Edit Nodes toolbar is displayed that allows you to edit the object's 
shape. (Same as menu command Actions > Edit nodes).
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Adjust Objects toolbar
This toolbar is displayed after pressing the  Adjust Objects button on the 
vertical toolbar. It allows aligning, spacing, flipping, or resizing objects, as well 
as fine-tuning the marking order. See Aligning, flipping or spacing objects for 
more information.

Button Description

Align left - It allows aligning the selected objects to the left. (Same as menu command 
Actions > Align > Align left).

Align top - It allows aligning the selected objects to the top. (Same as menu command 
Actions > Align > Align top).

Align right - It allows aligning the selected objects to the right. (Same as menu command 
Actions > Align > Align right).

Align bottom - It allows aligning the selected objects to the bottom. (Same as menu com-
mand Actions > Align > Align bottom).

Align center X - It allows aligning the selected objects along the X axis. (Same as menu com-
mand Actions > Align > Align center X).

Align center Y - It allows aligning the selected objects along the Y axis. (Same as menu com-
mand Actions > Align > Align center Y).

Flip horizontally - It allows flipping the selected object(s) horizontally. (Same as menu com-
mand Actions > Flip > Flip horizontally).

Flip vertically - It allows flipping the selected object(s) vertically. (Same as menu command 
Actions > Flip > Flip vertically).

Space horizontally - It allows spacing the selected objects evenly across. (Same as menu 
command Actions > Spacing > Space horizontally).

Space vertically - It allows spacing the selected objects evenly down. (Same as menu com-
mand Actions > Spacing > Space vertically).

Make same size - It allows making the same size for the selected objects. (Same as menu 
command Actions > Size > Make same size).

Make same width - It allows making the same width for the selected objects. (Same as menu 
command Actions > Size > Make same width).

Make same height - It allows making the same height for the selected objects. (Same as 
menu command Actions > Size > Make same height).

Restore transformations - It allows restoring the selected object(s) to its original size or ori-
entation. (Same as menu command Actions > Size > Restore transformation).

Marking order - It allows optimizing the order in which the objects will be engraved. (Same as 
menu command Actions > Marking order). See Optimizing the objects marking order for more 
information
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Zoom toolbar
This toolbar is displayed after pressing the  Zoom button on the vertical 
toolbar. It allows displaying the whole graphic area on the screen or a greatly 
enlarged detail of a particular part. See Zooming for more information.

Button Description

In - It allows gradually zooming the whole graphic area. (Same as menu command View > In).

Out - It allows gradually reducing the zoom. (Same as menu command View > Out).

Selection - It allows zooming in the selected object(s) so that it fits the entire graphic area. To 
return to the original graphic area, click on Zoom page. (Same as menu command View > 
Selection).

Page - It allows restoring the original graphic area. (Same as menu command View > Page).

Window - It allows zooming a specific area in the drawing. (Same as menu command View > 
Window).
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Laser toolbar
This toolbar is always displayed. It allows interacting with the laser device. For 
further information, see Performing The Engraving Operation for more infor-
mation.

Button Description

Connect to device - This button is only available if you have a Supervisor installation of Laser 
Editor (see Installation types and connection modes).
It displays the window that allows you to connect to a laser device, either locally or remotely. 
(Same as menu command Laser > Connect to device).

Open from device - It allows opening a laser document that you have previously saved to the 
laser device. (Same as File > Open from device).

Save to device - It allows saving a layout to a specific device with a specific name, into a folder 
managed by Laser Engine. (Same as File > Save to device).

Switch to Manual (or Auto) Mode - It allows switching between operating modes. Selecting 
Manual Mode allows you to set laser parameters or send documents to marking. By default, 
Auto Mode is set and layouts are sent to marking via a Project Editor's program. (Same as 
menu command Laser > Select Manual (or Auto) Mode).

Work Mode - This button is only enabled if you are in Manual Mode. It allows marking the 
selected layout using the external Start and Stop commands directly from editor. If you are 
not connected to a device, it activates the simulator. (Same as menu command Laser > Send 
marking).

Send marking - This button is only enabled if you are in Manual Mode. It allows sending the 
layout to the device for marking. If you are not connected to a device, it activates the simula-
tor. (Same as menu command Laser > Send marking).

Send marking on selection - This button is only enabled if you are in Manual Mode. It allows 
sending the selected object to the device for marking. If you are not connected to a device, it 
activates the simulator. (Same as menu command Laser > Send marking on selection).

Stop marking - It allows interrupting the laser marking operation. (Same as menu command 
Laser > Stop marking).

Limits on selection - It allows tracking the engraving limits of the currently selected object(s). 
The area involved in engraving is shown and not the profile of the object to be engraved. 
(Same as menu command Laser > Limits on selection).

Limits all - It allows tracking the engraving limits in the work plain. Margins are displayed 
using a red laser pointer. (Same as menu command Laser > Limits all).

Limits previous/next sector - These buttons allow tracking the engraving limits of the sec-
tors that compose the object(s). This function is suitable when engraving on ring documents. 
(Same as menu commands Laser > Limits previous sector and Limits next sector).

Simulator - It is used to simulate the engraving results when in Manual Mode. A new graphic 
window is displayed where engraving is simulated. The simulation maintains all the speed, 
filling, wobble or other parameters set for the document. (Same as menu command Laser > 
Simulator).

Show Laser Engine - It allows opening Laser Engine window directly from Laser Editor, either 
locally or remotely. See “Laser Engine User Interface”.
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Laser Configuration - It allows opening the Laser Configuration window directly from Laser 
Editor so as to set the laser and axis parameters. (Same as menu command Laser > Laser 
Configuration).

Edit device global variables - It allows managing global variables, so as to share contents 
(counters and strings) between more documents. (Save as menu command Laser > Edit 
device global variables). See “Using global variables”.

Manage Device Users - It allows you to set and manage the users' rights on the system you 
to connect to a laser device, either locally or remotely. See “Managing users and access 
rights”.

System Test - It allows accessing the dialog where you can test the Laser system and check 
your system's connections. In particular you can test all Inputs and Outputs, as well as the 
external Start and Stop signals.

Button Description
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Reader toolbar

Button Description

Photometric Adjustment - It manages image acquisition photometry and focusing. (Same as 
menu command Reader > Photometric Adjustment). See Photometric Adjustment

Quality Grade Training - It manages the quality grade training. (Same as menu command 
Reader > Quality Grade Training). See Quality Grade Training
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Chapter 2
Preliminary Operations

Before you begin working with Laser Editor, you have to complete the following 
procedures:
• Registering your product
• Installation types and connection modes
• Setting the default behavior of Laser Editor
• Automatic conversion Smartist Projects
• Opening the data folders
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Registering your product
While Laser Editor does not need to be licensed, Laser Engine, that is the run-
time component of the marking system, can be installed as a trial version for 30 
days, after which it will no longer engrave. However, Laser Editor will still func-
tioning as a graphic editor.
To register Laser Engine before it expires, complete the following procedures:

• Obtaining the license file
• Sending the activation key to the remote device

Obtaining the license file

To register Laser Editor:
• From the Laser Editor menu bar, choose Help > Get device ID.
• In the Device ID window, select button Copy Device ID to clipboard:

• Copy the identification code and paste it into an e-mail that you will send 
to the address that appears at the bottom of the dialog.

• You will receive a reply with an attached file called License.dat.
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Sending the activation key to the remote device
Warnings

This procedure allows sending the activation key to the remote device to which 
you are connected:

To send the license:
• From the Laser Editor menu bar, choose Help > Send license.
• In the Choose license file window that is displayed, select the 

License.dat file that you have received from the manufacturer (see 
Obtaining the license file).

• Click on Open. This will automatically send the license to the remote 
device.

To perform this operation, you must be connected to the 
device. For further information, see Connecting to the laser 
device.
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Installation types and connection modes
When installing Laser Editor, you can choose between different installation 
types, depending on your needs.
The installation type determines if you are installing either Laser Editor or Laser 
Engine, or both components, as well as whether you can interact to Laser 
Engine remotely.
The following table summarizes the available solutions:

Installation type and description
Laser Editor can connect to 
any Laser Engine available 
on the network

Laser Engine is suitable for 
remote control through the 
network

Interactive
• Installs both Laser Editor and Laser 

Engine.
• Use this option if you are installing 

the software on the PC that will 
control the laser locally (SLAVE 
device).

• This option will install components 
for editing layouts and controlling 
the laser source locally.

• This option allows the laser source 
to be controlled by MASTER device 
via Ethernet.

NO YES

Supervisor
• Use this option if you are installing 

the software on the PC that will 
control the laser source remotely 
(MASTER device).

• This will install components for 
editing layouts and control the 
laser source via Ethernet.

• This option allows the laser source 
to be controlled by MASTER device 
via remote ActiveX control.

YES NO
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Setting the default behavior of Laser Editor
You can use the Configuration dialog box of Laser Editor to set the default con-
figuration parameters for your application.

See the following for further information:
• Setting language, measurement unit and graphical effects (General page)
• Setting documents parameters (Geometry page)
• Click OK to implement your settings.
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Setting language, measurement unit and graphical effects (General 
page)

This window allows you to specify the user interface language, the linear mea-
surement unit and the graphical effect for your application.

To set the General parameters:
• From the Laser Editor menu bar, choose File > Configuration. The Default 

parameters configuration window is displayed.
• In the left pane of the window, leave General selected.
• Set the default parameters using the following table as a reference.

Group box Parameter Description

Language

It lists the available languages for the user interface. Select 
the language you want to use.
Note that by default, the language is set to Autodetect, 
meaning that it depends upon the language of your operat-
ing system.

Units
Linear Sets the linear measurement unit. Available options are mm 

or inches.

Decimals Sets the number of decimals to be used. Admitted values are 
0 to 5.

Logging

Max log space (KB) It specifies the maximum disk space for log files. The log file 
is compiled at the Laser Engine level and lists all actions that 
have occurred allowing you to correct any problem that might 
occur.For further information on how to use and manage the 
log file, please see Understanding the log file.

Max log file number

Graphical ettects Text dimension It allows increasing the font dimensions. This is particularly 
useful when using Asiatic fonts

Tools Evaluator updates

It allows managing the evaluator for the marking time in 
order to speed up the layouts editing. Two settings are avail-
able:

• every change - the evaluator is calculated whenever 
the contents of a document are changed. This settings 
slows down the editing operations.

• on click - the evaluator is calculated at the user's 
request. This is the recommended setting, especially in 
case of layouts with many graphics.

Restore window settings Choose this button to restore the default parameters. 
A restart of the application is required

Reset to factory settings
Choose this button to clear the lists of laser sources 
and lenses got from several engines. A restart of the 
application is required.

• Click OK to implement your settings.
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Setting documents parameters (Geometry page)
This window allows setting dimension, orientation, and grid settings for docu-
ments. 

Notes

To set the documents parameters:
• From the Laser Editor menu bar, choose File > Configuration. The Default 

parameters configuration window is displayed.
• In the left pane of the window, select Geometry. The parameters in this 

window allow setting the default parameters for the documents that you 
will create.

• Make the desired changes using the following table:

Group box Parameter Description

Plane

Width Sets the width of the work area for a plane document.

Height Sets the height of the work area for a plane document.

Margin X Sets the width of the margins in the work area for a plane document.

Margin Y Sets the height of the margins in the work area for a plane document.

Ring

Diameter Sets the size of the external or internal diameter for a ring document.

Thickness Sets the height of the ring or cylinder for a ring document.

Margin Y Sets the width of the margins in the work area for a ring document.

Grid settings

Enable grid If selected, displays the grid in the work area (Default: selected).

Snap to grid If selected, enables the objects snap to the grid. (Default: deselected).

Grid step It allows setting the grid spacing.

Origin and 
orientation

Origin posi-
tion

The default origin for the Cartesian coordinates (x y) that are used as the 
reference point. Their origin is set by default to 0.0 (Center).
The dropdown list allows you to select an origin other than Center, such 
as Left Top or Right Bottom.
Furthermore, you can set a Custom origin: in this case, enter new values 
for the X,Y coordinates.

Origin X Sets the X coordinate (horizontal) of the new origin, in relation to the 
default position, that is the Center of the document.

Origin Y Sets the Y coordinate (vertical) of the new origin, in relation to the default 
position, that is the Center of the document.

Invert X If selected, inverts the X axis so as to change the field orientation. 
(Default: deselected)

Invert Y If selected, inverts the Y axis, so as to change the field orientation. 
(Default: deselected)

All measurement units in this page depend on the units that 
were selected in the General page. See Setting language, mea-
surement unit and graphical effects (General page).
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• Click OK to implement your settings.

You will then be able to change the settings at a document 
level by editing the Properties window for the active docu-
ment. See Setting language, measurement unit and graphical 
effects (General page)
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Importing Materials Database
This function is used to import into Laser Editor database materials that you 
have created using Smartist. You can import:

• Materials Database (.ini, .DB files)

To import a materials database from Smartist:
• From the Laser Editor menu bar, choose File > Import Materials Database 

to display the Choose a materials database to open window.
• From the Type of file dropdown list, select the proper type of file. There 

are two available options:
• .ini files
• .DB files

• Browse to locate the desired file and click Open.
• After completing the import operation, a number of information messages 

will be displayed providing information on imported file(s).
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Open Smartist Projects
Is possible to open into Laser Editor any project or document that you have cre-
ated using Smartist. You can open:

• Smartist projects (.prj files)
• Smartist documents (.LDX, .LDC files)

To open a Smartist project or document:
• From the Laser Editor menu bar, choose File > Open to display the Choose 

a document to open window.
• From the Type of file dropdown list, select the proper type of file. There 

are two available options:
• Smartist projects (.prj files) - It allows importing a Smartist project, 

which can be composed by one or more graphic layouts.
• Smartist documents (.LDX, .LDC files) - It allows importing a specific 

document that you have created using Smartist.
• Browse to locate the desired file and click Open.
• After completing the import operation, a number of information messages 

will be displayed providing information on imported file(s), Smartist ver-
sion, and so forth. Any opened document will be displayed in a tab within 
the Laser Editor window, for you to manage or edit as any other Laser Edi-
tor document.

Notes Note that, if any script or formatter file was included in the 
project, a message tells you in which folder on your PC it has 
been saved during the import operation. You can use Project 
Editor to open or edit it. Project Editor is a tool that allows cre-
ating custom programs, which includes his own Help system. 
To access it, choose File > Project Editor from the Laser Editor 
menu bar.
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Automatic conversion Smartist Projects
Is possible to convert automatically a list of Smartist Projects from input direc-
tory and subdirectories.
Usage: LaserEditor.exe --convert-files <from directory> <to directory> <file 
pattern> [--convert-subdirs] [--convert-log <log file name>]

• --conver-files - It allows to specify the Input and Output directories.
• <from directory> - Input directory
• <to directory> - Output directory
• <file pattern> - You can specify a file name pattern

• --convert-subdirs - It allows to specify to convert files from subdirecto-
ries.

• --convert-log - It allows to specify the log file name created in the Output 
directory. The default file name is 'convert.log'.

• <log file name> - Log file name

Example:
LaserEditor.exe --convert-files c:\temp\prj_from c:\temp\prj_to *.prj
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Opening the data folders
The Open data folder function allows retrieving informations that you might 
need for support purposes, as well as to check the data or the device's configu-
ration.

To view the folders contents:
• From the Help menu, select Open data folder.

• In the window that is displayed, select the desired folder. Use the following 
table as a reference:

Folder Contents

Config Configuration files, laser configuration, and license.

Corrections Files for lenses correction.

Database Databases of passwords, materials, and global variables.

Fonts List of the fonts that can be used in Laser Engine.

Formatters List of the script available in the drop-down menu of the custom formatters (see 
“Custom Formatters” on page 76)

History
Database history files (see “Statistic, that shows statistic relating to marking pro-
cesses and marking & verification processes (feature available with Marvis enabled; 
see the Marvis Application Note for more details).” on page 183)

Logs Log files that were generated from Laser Engine and Laser Engine Service Controller.

Docs/Layouts Documents laser engine tab

Docs/Temp List of the temporary documents that are sent to the marking in Manual mode, 
directly from the Laser Editor.

Minidumps Files for technical support team.

OEM Files for Lighter personalization.

Plugins Plugins that are registered when launching Laser Engine.

Projects Folders containing the projects that are saved to the device. The “default” folder 
must always include the default project.

ReaderConfig Reader’s configuration files.

Recovered Automatic backup file generated in case of a crash of the Laser Editor

Upgrade Reserved for laser engine applications.
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Chapter 3
Creating Graphic Layouts

This chapter is divided into the following sections: 

Topic What you will learn

Setting your work environment How to set your work environment in terms of panes 
and toolbars.

Graphics editing overview An overview of how graphic layouts are managed in 
Laser Editor.

About documents
How to create and manage documents as objects 
containers, for plane or ring laser engraving, and how 
to set their properties.

About sequences
How to create and manage sequences that allow 
defining a sequence of actions to be executed at the 
Laser Engine level.

About graphic objects

What objects properties are intended for. How to add 
and manage graphic objects that compose the layout 
(simple vectorial objects, strings, codes, arrays, 
imported raster or vectorial images).

Using global variables
How to set and manage global variables, so as to 
share contents (counters and strings) between more 
documents.

Common operations on objects The meaning of the objects colours in the work area.

Common operations on objects

How to perform common operations on objects, such 
as aligning, adjusting, resizing, spacing or flipping 
objects, by using the mouse, toolbars, or by setting the 
object properties.
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Setting your work environment
By default all child windows are displayed in the Laser Editor window, that is, 
the Properties, the Undo/Redo commands list, and the Objects engraving order 
windows.

Furthermore, several toolbar buttons are displayed, to allow you a quick access 
to the main functions of Laser Editor.

However, you can customize your work environment by displaying or hiding 
both windows and toolbars.

Hiding/Displaying windows or toolbars

To hide/display an element:
• Right-click in a blank area next to the toolbars to display a shortcut menu 

that lists all the elements that compose the work environment (panes and 
toolbars)

• Deselect/select the corresponding checkbox to hide/display an element, 
respectively.

Docking/Undocking panes
By default, the three panes Undo/redo commands list, Objects engraving order, 
and Properties, are displayed at the left and the right side of the Laser Editor's 
window, respectively. You can move or resize them. For example, you might 
want the Properties window to float over the work area.

To dock/undock a pane:
• To undock a pane, click on its title bar, for example on Properties, and 

then drag it to the desired position.
• To resize a pane, undock it, and then use the mouse to change its dimen-

sions.
• To dock a pane in its original position, double-click the title bar.
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Graphics editing overview
In order to create and manage layouts for laser engraving, you will do the fol-
lowing:

• Create a document, that is the “container” for the graphic objects that 
compose the layout. (See About documents)

• Add and edit the graphic objects to be engraved (see About graphic 
objects)

The Property browser, which is available for documents and objects, allows you 
to edit the properties so as to suit your engraving needs. You can customize the 
parameters that define how the objects will be engraved: this includes sizes, 
origins, filling, laser parameters, and so forth.

Furthermore, you can operate on objects by using toolbars, mouse, and menu 
bar.

While editing, you can use the F1 key to access the context Help that relates to 
what you are doing, as well as to display information on each properties group, 
as illustrated in the following example where a String object has been added to 
a plane document:
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About documents
In Laser Editor, a document can be referred to as a container for graphic objects 
that compose the layout to be engraved. The document's area corresponds to 
the engraving laser work area.

Laser Editor provides two types of documents that you can use depending on 
your engraving needs:

• Layer documents, are used for vectorial or raster engraving on flat sur-
faces.

• Ring documents, are used for vectorial or raster engraving on cylindrical 
surfaces.

When you install Laser Editor, it is necessary to be connected to the Laser 
Engine, that is, to a laser source in order to be able to create new documents. If 
you are operating in a standalone station, the Laser Engine is launched auto-
matically; while, if you are operating on a network, you need to manually con-
nect to the Laser Engine at least once. Otherwise, you will only be able to edit 
existing documents.

When creating e new document, default parameters are used to set the laser 
source, the dimensions of the graphic work area, and so forth; these are the 
parameters that have been set for the application (See Setting the default 
behaviour of Laser Editor). However, you can use the documents Property 
browser to change these settings, as it is described in the sections that follow.

When adding an object to a document, the laser parameters that have been set 
for the document are used. You can still setting different laser parameters for 
each object; in this case, the object will appear blue. (See Understanding 
objects colour in the work area).

The following sections describe how to work with documents in Laser Editor:
• Common documents properties
• Creating a document for plane engraving
• Creating a document for ring engraving
• Opening existing layouts
• Saving layouts

You can also use the Sequence feature to create programs that allows automat-
ing documents' marking operations (see About sequences).

Common documents properties 
Notes

The following tables describe the Target and Laser properties, which are com-
mon to plane and ring documents.
These properties are available when a document is being created and no 
objects are selected.

The properties that are described in this section apply to both 
plane and ring documents. Properties that are specific to 
either plane or ring documents, are described in the relevant 
section.
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Target properties for documents
Warnings

• you are operating on a network and you are not yet connected 
to a laser source; or

• you are connected to more laser sources.

When creating a new document, the default parameters that have been set in 
the Default configuration parameters window for Laser Editor are used. For fur-
ther information, see Click OK to implement your settings..
The following properties are available when you first install Laser Editor and are 
not yet connected to a Laser Engine. Once you are connected to a Laser Engine, 
these properties are not longer available. They become available if you connect 
to a Laser Engine which is connected to another laser source or a lens; in this 
case, you can select from the lists the desired source or lens.

Group Property Description

Laser source
It lists the available laser sources (stand-alone installation), or the 
laser source(s) to which you might remotely connect (supervisor 
installation).

Objective lens

It contains a list of available optical lens that you can install on the 
scanner head of the laser device.
The dimensions of the Work Area depends on this parameter (see 
Setting the work area).

This set of properties is only visible if:
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Laser properties for documents
The following properties will be used as the default laser parameters when 
adding new objects to the document. However, you can still set different 
parameters for a specific object. (See Custom Laser parameters for Objects).

Group Property Description

Passages

It allows setting the number of runs of the laser light on the object to engrave. You 
might set up to 3 passages, each with different laser parameters (see Passage 
properties group). This option may be particularly useful to make several engraving 
runs to clean the work piece after a more incisive engraving process. (See Using 
more engraving runs).

Passage (#)

Power This indicates the laser output power. The value is expressed as a percentage of 
the maximum power of the laser source.

Frequency

Light emitted by the laser is pulsed. Use this parameter to adjust the frequency of 
the emitted light.
All other parameters being equal, a lower frequency causes a higher per pulse. Not 
all combinations of power and frequency are allowed. Depending on the laser 
source type, low frequencies require correspondingly low powers.

Scan Speed
This indicates the engraving speed. The value is expressed in millimeters per sec-
ond. (Note: A slower speed implies engraving a deeper engraving. Set a very slow 
speed (50-100 mm/s) for special processes, such as burnishing or deep engraving.

Dot Delay Sets the engraving time for each dot, that is, the time required for laser emission 
on the dot.

Shot Time Sets the duration of the laser shot pulse i.e. the time the Q-switch is open (or, bet-
ter, transparent).

Pulse Profile Set the duration of the laser pulse (available only for MOPA laser source)

Repetitions Sets the number of times objects are marked. Increasing the number of passes will 
increase depth of engraving, consequently affecting the cycle time.

Wobble

If it is set to True, this property allows engraving thicker lines through a spiral movement instead of 
a linear movement. (See Using the Wobble function to engrave with thicker lines).

Radius Represents the radius of the spiral curve.

Speed Represents the frequency of spiral repetition.

X Axis If it is set to True, it allows setting the desired position for the X Axis.

Y Axis If it is set to True, it allows setting the desired position for the Y Axis.

Z Axis

If it is set to True, it allows setting the desired position for the Z Axis.
If the distance sensor is enabled, the Origin property is available.
The Origin property has the following values:

• Logical Zero: the Height value is related to the Z Axis logical zero value
• Reference Position: the Height value is related to the position that the Z axis 

has, before the layout is processed

R Axis If it is set to True, it allows setting the desired position for the R Axis.

You can set the parameters for the objects in the document, based on a specific 
material (e.g. plastic) and its reactions to the marking operation. For further 
information on how to save and recover a materials database, see Saving a 
Materials database for a later re-use.
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Creating a document for plane engraving
A plane document is used for vectorial or raster graphic engraving on flat sur-
faces.

The document's area corresponds to the engraving laser work area. It is where 
you create the layout by drawing and editing graphics objects, or importing 
raster or vectorial image files, such as a logo (see About graphic objects).

When you create a new document, the default parameters that have been set in 
the Default configuration parameters window for Laser Editor are used. (See 
Setting the default behavior of Laser Editor). You can use the Property browser 
to set other parameters.

For further information, see:
• Creating the document
• Saving a Materials database for a later re-use
• Setting the work area
• Common documents properties
• Geometry properties - Layer
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Creating the document

To create the layer:
• Do one of the following:

• From the Laser Editor menu bar, choose File > New > Layer.

• From the Laser Editor standard toolbar, click the  button.
• The document appears in the Laser Editor's window, where the engraving 

layout is represented.

Note that the Properties window contains the default parameters, that is the 
parameters the have been set for Laser Editor.

• To create the engraving layout, complete the following operations:
• Set the properties for the document that best fit your engraving require-

ments. Refer to sections Common documents properties, Geometry 
properties - Layer, and Saving a Materials database for a later re-use for 
further information.

In particular, when setting the document's work area, refer to Setting the 
work area.

• Add the graphic objects for engraving, either by drawing or importing 
them (see About graphic objects)

• When you are finished, you might save the document in the following 
ways:
• Choose File > Save or click the  button to save the document on your 

PC, as a graphic layout (.xlp file).
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• Choose File > Save as to save a copy of the document.

• Choose File > Save to Device or press the  button to save the layout 
remotely, directly to the laser device for marking. You can select the 
device and enter a name for the document.

The document(s) will be actually sent to the laser engraver through an 
automated procedure written with Project Editor.

(For further information, see Saving a layout to a device). 

Notes

• To close a document, click the  button at the top right of the work area

Notes

The Project Editor is a programs editor that is used to auto-
mate marking procedures or to update the layout contents at 
runtime. It has its own context-sensitive Help and it is inte-
grated into Laser Editor. To access it, choose File > Project Edi-
tor.

You can work on more documents simultaneously. Each docu-
ment will be displayed in a tab in the Laser Editor's window.
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To create the Extended Layer:
• Do one of the following:

• From the Laser Editor menu bar, choose File > New > Extended Layer.

• From the Laser Editor standard toolbar, click the  button.
• The document appears in the Laser Editor's window, where the engraving 

layout is represented.
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Saving a Materials database for a later re-use
The Materials property, allows saving specific laser settings and filling parame-
ters in a database that you can then import in a new layout. After setting your 
parameters according to a specific material and its reactions to the marking 
procedure, and once your layout is ready, you can store it for a later re-use.
The same operation can be done for each individual object in the document.

To save a materials database:

• Click Materials properties:

• Click the Save button to display the following dialog:

• Enter a meaningful Material name (e.g., plastic) and click OK to save the 
database. Note that the dropdown list contains the materials databases 
that you have created previously.

• Use the Delete button to delete existing databases.

To re-open a previously saved database:
• From the Laser Editor menu, select File > Import Materials Database.
• In the windows that is displayed, navigate to Data_Lighter > Database and 

then select the desired file: .ini file, if the layout was created in Smartist, 
.db if it was created in Laser Editor.
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Setting the work area
The size of the work area is a fundamental setting. The maximum size that can 
be used is based on several elements, including the focus height installed on 
the engraving laser and the quality of the lens. As a general rule, increasing the 
focal length will result in the work area increasing, but the model and the qual-
ity of the lens can also affect the size of the work area.
The lens can have different focal lengths: this determines the size of the mark-
ing area.
The focal lengths also determine other properties of the laser marking system, 
such as the working distance and the laser spot.
When you set the work area parameters, keep in mind that its width cannot 
exceed the focus length set for the laser. The figure below shows an example:

The focal length for the objective lens are set both at laser device's level and at 
the level of the document:

To set the focal length at the laser device level:
• Right-click the Laser Engine icon on the Windows taskbar and select Laser 

Configuration. (For more information on how the Laser Engine works, see 
Laser Engine User Interface).

• Select the Correction page.
• Under Lens, choose from the Focal Length [mm] dropdown list the focal 

length used by the laser device.

To set the focal length at the document level:
• In the Properties window of the active document, under Target, choose 

from the Lens dropdown list the optical lens to be used.
• When setting the work area for the document, remember not to exceed the 

dimensions that the installed optical lens determine.
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Geometry properties - Layer
When creating a new document, the default parameters that have been set in 
the Default configuration parameters window for Laser Editor are used. For fur-
ther information, see Setting documents parameters (Geometry page).

You can use the document's Property browser to set parameters other than the 
default ones.

Notes

Group Property Description

Work Area

It corresponds to the surface to engrave. The size of the work area is a fundamental 
parameter. The maximum size that can be used is based on several parameters, includ-
ing the focus height installed on the engraving laser and the model of lens. (See Setting 
the work area).

Width Sets the width of the work area.

Height Sets the height of the work area.

Margins
X Sets the distance between left and right margins of the work area.

Y Sets the distance between top and bottom margins of the work area.

Grid

If it is set to True (default), the grid is displayed and the relevant properties are available. 
The grid is a series of traced lines which intersect. They can be used to precisely align and 
position objects in the drawing window. (See Using the document's grid).

Step Sets the dimension of the cells on the grid.

Snap to grid
If it is set to True, enables the snap to the objects in the grid, that is, when 
you move objects on the grid, they will be aligned to the closest grid line. 
(Default: False).

Origin

The default origin for the Cartesian coordinates (x y) that are used as the reference point. 
Their origin is set by default to 0.0 (Center). The position of the objects refers to this point.
The dropdown list allows you to select an origin other than Center, such as Left Top or 
Right Bottom.
Furthermore, you can set a Custom origin: in this case, you should enter new values for 
the X,Y coordinates.

X Position Sets the X coordinate (horizontal) of the new origin, in relation to the 
default position, that is the Center of the document.

Y Position Sets the Y coordinate (vertical) of the new origin, in relation to the default 
position, that is the Center of the document.

Invert X Axis If it is set to True, inverts the X axis so as to change the field orientation. 
(Default: False)

Invert Y Axis If it is set to True, inverts the Y axis, so as to change the field orientation. 
(Default: False)

All measurement units that are used in this page depend 
upon the units that you have selected at the application level. 
See Setting language, measurement unit and graphical effects 
(General page).
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Geometry properties - Extended layer

Group Property Description

Work Area

It corresponds to the surface to engrave. The size of the work area is a fundamental 
parameter. The maximum size that can be used is based on several parameters, includ-
ing the focus height installed on the engraving laser, the model of lens, and the X-Y axis 
configuration. (See Setting the work area and Setting the X, Y, Z, and Rotor Axes parame-
ters).

Width Width of the extended work area.

Height Height of the extended work area.

Enabled Area 
Reference

The default origin for the Cartesian coordinates (x y) that are used as the reference point. 
Their origin is set by default to 0.0 (Center). The position of the enabled extended area 
refers to this point.

Frame Size
X Set the length in mm of the single marking area

Y Set the height in mm of the single marking area

Enable Area 
Position

X X position of the enabled extended area in relation to the Enabled Area 
Reference parameter

Y Y position of the enabled extended area in relation to the Enabled Area 
Reference parameter

Number of 
the Enabled 
Frame

Sets the number of frames in X and Y coordinates

Grid see Grid

Origin see Origin
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Creating a document for ring engraving
Notes

Ring documents are used when you need to engrave a cylindrical surface. The 
document's work area represents the whole linear development of the surface 
to be engraved (360°).
The document's area corresponds to the engraving laser work area. It is where 
you create the layout by drawing and editing graphics objects, or importing 
raster or vectorial image files, such as a logo (see About graphic objects).
When you create a new document, the default parameters that have been set in 
the Default configuration parameters window for Laser Editor are used. (See 
Setting the default behavior of Laser Editor). You can use the document's Prop-
erty browser to set other parameters.

For further information, see:
• Creating the document
• Common documents properties
• Geometry properties - Ring document

In order to mark a ring document, you must install and config-
ure on your device a rings separator.
Furthermore, the Rotor axis must be enabled (Enable axis 
property) in your Laser Configuration settings. (See Setting the 
X, Y, Z, and Rotor Axes parameters).



44 Lighter™ Suite

Creating the document

To create the document:
• Do one of the following:

• From the Laser Editor menu bar, choose File > New > Ring Document.
• From the Laser Editor standard toolbar, click the down arrow next to the 

 button and then select Ring Document:

Note that the displayed work area represents the linear development of the sur-
face to be engraved and the Properties window contains the default parameters 
that have been set for Laser Editor.

• To create the ring engraving layout, complete the following operations:
• Set the properties at the document level, so as to fit your engraving 

requirements. Refer to sections Common documents properties, Geom-
etry properties - Ring document, and Saving a Materials database for a 
later re-use

• Add the graphic objects, either drawing or importing them (see About 
graphic objects)

• When you are finished, you might save the document in the following 
ways:
• Choose File > Save or click the  button to save the document on your 

PC, as a graphic layout (.xlp file).
• Choose File > Save as to save a copy of the document.

• Choose File > Save to Device or press the  button to save the layout 
remotely, directly to the laser device for marking. You can select the 
device and enter a name for the document.
The document(s) will be actually sent to the laser engraver through an 
automated procedure written with Project Editor.
(For further information, see Saving a layout to a device).
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Notes

• To close a document, click the  button at the top right of the work area.

Notes

The Project Editor is a programs editor that is used to auto-
mate marking procedures or to update the layout contents at 
runtime. It has its own context-sensitive Help and it is inte-
grated into Laser Editor. To access it, choose File > Project Edi-
tor.

You can work on more documents simultaneously. Each docu-
ment will be displayed in a tab in the Laser Editor's window.r.
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 Geometry properties - Ring document
When creating a new document, the default parameters that have been set in 
the Default configuration parameters window for Laser Editor are used. For fur-
ther information, see Setting documents parameters (Geometry page).
You can use the document's Property browser to set parameters other than the 
default ones.

Notes All measurement units that are used in this page depend 
upon the units that you have selected at the application level. 
See Setting language, measurement unit and graphical effects 
(General page).

Group Property Description

Ring

Diameter The size of the external or internal diameter.

Height The height of the ring or cylinder.

Mark Sets engraving inside or outside the ring.

Margin Sets the width of the vertical margins.

Grid

If it is set to True (default), the grid is displayed and the following properties are available:

Step Sets the dimension of the cells on the grid.

Snap to grid
If it is set to True, enables the snap to the objects in the grid, that is, when 
you move objects on the grid, they will be aligned to the closest grid line. 
(Default: False).

Origin

The default origin for the Cartesian coordinates (x y) that are used as the reference point. 
Their origin is set by default to 0.0 (Center). The position of the objects refers to this point.
The dropdown list allows you to select an origin other than Center, such as Left Top or 
Right Bottom. Furthermore, you can set a Custom origin: in this case, you should enter 
new values for the X,Y coordinates.

X Position Sets the X coordinate (horizontal) of the new origin, in relation to the 
default position, that is the Center of the document.

Y Position Sets the Y coordinate (vertical) of the new origin, in relation to the default 
position, that is the Center of the document.

Invert X Axis If it is set to True, inverts the X axis so as to change the field orientation. 
(Default: False)

Invert Y Axis If it is set to True, inverts the Y axis, so as to change the field orientation. 
(Default: False)
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Advanced

Sector Size

Sector SizeDefines the width of the sector. The sector represents a portion of 
the working area to be engraved within a single movement of the rotating 
axis.
The 0 value (default) provides the highest level of quality: to each polygon is 
associated a movement of the rotating axis, so that the portion being 
marked is always placed on the center of the marking area. Greater value 
results in a shorter total marking time, but might impact quality.
Note that the sector size can't exceed the portion of the area which is in 
focus; this is based on the laser's depth of focus. If you set a greater value, 
the application ignores it and uses the maximum allowed value instead, 
based on the depth of focus of your laser.

Sector Gap

It is used in association with the Sector Size property and the Tilable property 
for vectorial objects. It allows fine tuning the marking results.
When you apply the Tillable property to an object, the following occur:

• The object is separated into its constituting polygons.
• If a polygon is larger than the sector and it is closed (algorithm won't 

work if the figure is open), Laser Engine will try to “slice” it in portions 
whose dimension is equal to the ring's sector to be marked.

If it is set to 0, only one cut line is used between the two sectors (left and 
right borders), while if it is < 0, two cut lines are used, allowing you to overlap 
or separate the borders, as needed.
For a detailed description of how the Tillable property works, see Using the 
tiling function.

Angle The slant angle of the rotating axis, expressed in degrees. (Possible values: 0 
to 60).

Reset axis at 
the end of 
execution

If it is set to True, it brings the rotor to its initial position at the end of engrav-
ing.

Use ring 
radius as Z 
axis position

If it is set to True, allows setting the focus as ring radius-independent. This 
means that (being the rings separator fixed), if the ring radius changes, the Z 
axis must change accordingly in order to focus the area to be engraved. 
Enabling this function, you only need to focus the revolution centre; then, the 
system will automatically control the Z axis so as to set the focus accordingly 
to the ring dimensions.

For correct operation, set the logic zero of axis Z in the revolution center. 
Logic zero is the focus position on the item to be engraved. he logical zero 
also depends on the 'Ring Offset' parameter in Laser Configuration settings, 
see Setting the X, Y, Z, and Rotor Axes parameters.

Group Property Description
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Opening existing layouts
You can open layouts (that is, .xlp Laser documents) that you have previously 
saved for further editing, or for sending them to the engraver.
You can open a layout that was saved locally, or a layout that was saved to a 
device.
For further information, see:

• Opening a layout on your PC
• Opening a layout from a device

Opening a layout on your PC
• Do one of the following:

• From the Laser Editor menu bar, choose File > Open.

• From the Laser Editor standard toolbar, click the  Open button.
• In the Choose a document to open window that is displayed, browse to 

locate the .xlp Laser document you want to open.
• Click on Open. The selected document is displayed in the work area of 

Laser Editor.

Opening a layout from a device
This function allows you to open a laser document that you have previously 
saved to the laser device for further editing.

• Do one of the following:
• From the Laser Editor toolbar, click the  Open from device button.
• From the Laser Editor menu bar, choose File > Open from device.

• In the Choose a document to open window that is displayed, select from 
the Devices dropdown list the device to which the document was saved. 
(Here are listed all the available devices on the network).

• The File area shows the layouts that have been saved to the selected 
device. Choose the file you want.

• Click OK. The selected document is displayed in the work area of Laser 
Editor.
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Saving layouts
When you are finished creating a laser layout, you can save it either locally, or 
to a device so that it is then sent to the engraver through an automated proce-
dure.

Saving a layout on your PC
The following procedure allows saving a layout as a .xlp file on your disk, for 
later use or editing.

To save the layout:
• To save a new, unnamed layout:

• Choose File > Save (or click the  button on the toolbar).
• In the Save document as window that is displayed, go to any location 

available from your computer (or create a new folder).
• In the File name box, type a name for the document and click Save. The 

document will be saved with the .xlp extension.
• To save a copy of an existing document:

• Choose File > Save as.
• In the Save document as window that is displayed, go to any location 

available from your computer (or create a new folder).
• In the File name box, type a new name for the document and click Save.
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Saving a layout to a device
The following procedure allows saving a layout to a specific device with a spe-
cific name, into a folder that the Laser Engine manages.

You can then use Project Editor to write a program for documents uploading, so 
that the saved documents are sent to the engraver in an automated way. 

Notes

To save the layout to a device:
• Do one of the following:

• From the Laser Editor toolbar, click the  Save to device button
• From the Laser Editor menu bar, choose File > Save to device.

• In the Save document as window that is displayed, select from the Devices 
dropdown list the device you are sending the layout to. (All the available 
devices on the network are listed).
The File area shows the layouts that have been saved to the selected 
device.

• Enter a name for the document and click OK. This is the name that will be 
used in the Project Editor's program.

The Project Editor is a programs editor that is used to auto-
mate marking procedures or to update the layout contents at 
runtime. It has its own context-sensitive Help and it is inte-
grated into Laser Editor. To access it, choose File > Project Edi-
tor. Default programs and easy-to-use examples are provided 
with the tool.
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About sequences
A sequence is a program containing actions that Laser Engine will automatically 
execute.
It allows automating marking operations in simple scenarios and provides a 
user with an easy-to-use interface for programs design using Laser Editor.
A typical scenario where this feature can be used, is a production line with a 
PLC (Programmable Logic Controller) that manages automations and that is 
connected to the I/O PCI card: The sequence feature allows interacting with the 
PLC in order to execute a specific order of marking operations.
Using a sequence you can:

• define a specific order of marking operations that will be automatically 
executed;

• create or import plane or ring documents to be marked;
• interacting with the PLC by setting outputs or reading inputs;
• moving axis, if enabled.

Notes In addition to creating sequences, in order to automate mark-
ing procedures, you might also use Project Editor, which is a 
programs editor integrated into Laser Editor. To access it, 
choose File > Project Editor. Default programs and easy-to-
use examples are provided with the tool, as well as a context-
sensitive Help.
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Creating and executing a sequence

To create a sequence:
• Do one of the following:

• From the Laser Editor menu bar, choose File > New > Sequence.
• From the Laser Editor standard toolbar, click the down arrow next to the 

button and then select Sequence:

• The following appears in the Laser Editor's work area:

Note that the Sequence items toolbar is displayed next to the Standard toolbar 
of Laser Editor and a sequence with the default item is displayed in the work 
area.

• Click the buttons on the toolbar to add items to your sequence, using the 
following as a reference (see also the Example below).

Button Description

If-Else-End IF - is a control structure that allows you to perform a block of items based on 
the Boolean condition

Counter - It allows to set a local counter to the sequence or select a counter in the global vari-
able database. Is required to use the Condition property with the If-Else-End if item
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Input - It allows setting inputs on the I/O PCI card, which can be connected to a PLC (16 input 
bits are available). This allows you to interact with the PLC that manages operations and tell 
it how to behave when executing the program.
Properties: Bit 0 to Bit 15 are the input bits that you can set. Possible options are:

• Don't care - Ignores the bit, that is, leaves the bit how it was
• If reset - if bit = o then process item If, otherwise process item Else-End If
• If set - if bit = 1 then process item If, otherwise process item Else-End If

Break - Stop the sequence in any condition

Label - It is a placeholder. It is required in order to use the Get and Go item. The Label tells the 
Get and Go item where it must jump after verifying the specified condition.
Properties: The Label property is an editable field where you can enter a text for the label. The 
typed text will then be displayed in brackets next to the Label item

Move Axis - This item is only enabled if at least one axis is enabled on the laser. Execution of 
this item result in one or more axes being moved; execution is completed when all axes target 
positions have been reached. (See also Setting the X, Y, Z, and Rotor Axes parameters).
Properties: Set to True to enable one or more axis.
The Home Search parameter is used to move the axis in home position.
The Position parameter is then displayed for you to specify the axis position.
The Origin parameter define the reference for the Position Z value:

• Logical Zero: the Position Z value is related to the Z Axis logical zero value
• Reference position: the Postion Z value is related to the position that the Z axis has, 

before the Move Axis item is processed
If the distance sensor is enabled and the Z axis is enabled, the Autofocus Search parameter is 
available. If the Autofocus Search is set to True a Focus Distance Search is performed.

Document - It allows creating or importing a layout, extended layout or ring document into 
the sequence. Do one of the following:

• To create a new document, double-click the Document item that you have add to the 

sequence. If ring documents management is enabled, a window is displayed prompting 

you to specify which type of document you want to create. (See About documents for 

information on how to work with documents).

• To import an existing document, click the Import property in the Properties pane and 

then use the  browse button to select the document.

Properties: The Import property allows importing an existing document. The Name property is 
an editable field for you to enter the document's name

Set Out - It allows setting outputs on the I/O PCI card, which can be connected to a PLC (16 
output bits are available). This allows you to interact with the PLC that manages operations 
and tell it how to behave when executing the program.
Properties: Bit 0 to Bit 15 are the output bits that you can set. Possible options are:

• Don't care - Ignores the bit, that is, leaves the bit how it was
• Set - It sets the bit to True
• Reset - It sets the bit to False

Button Description
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The example here below shows a sequence where Get and Go is used to repeat-
edly mark two documents. The figure also shows how properties was set for the 
Get and Goes items:

Example

Delay - It allows setting a delay that you might need to complete a pending operation.
Properties: The Delay [ms] property allows you to specify the delay in milliseconds

Wait Start - It is the default item that is displayed when creating a sequence. In order to exe-
cute or to continue processing a sequence, Laser Engine waits for the user pressing Start

Get and Go - To enable this item, you must first select at least one Label. A Get and Go item is 
associated to a specific Label to which it might jump or not, depending on the condition to be 
verified (if any). To do this, the Get and Go item verifies the input bits as they are set by the 
PLC and then uses this information to proceed (jump to label or continue).
If the If Set option is selected, it verifies that the input bit is activated before jumping to the 
associated label. Otherwise, ignores the jump and executes the next operation that follows. 
(See the example below).
Properties: The Jump to property is an editable field for you to enter the associated label's 
name, which will then be displayed in brackets next to the Get and Go item. Bit 0 to Bit 15 
properties allows setting the conditions that the Get and Go item must verify before proceed-
ing into the execution. Possible options are:

• Don't care - Ignores the bit. It indicates an unconditional jump, that is, the jump will be 
executed in any case

• If Set - Verifies that the bit has been activated (True)
• If Reset - Verifies that the bit has been deactivated (False)

Clone document - It allows cloning a document that is already into the sequence, that is, add-
ing one or more copies of an existing document
Properties: The Name property allows you entering a new name for the cloned document

Delete sequence item - It allows deleting from the sequence an item that you have previously 
added. To delete an item, select it and then press this button

Notes

Button Description

You can drag and drop items in order to move them to a new 
location into the sequence.
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The following diagram shows how the program will be executed based on this 
sequence:

To execute a sequence:
Sequences are executed as projects, that is, after you save a sequence to the 
device, it will be executed at the Laser Engine level by activating the Auto Mode 
(see Auto/Manual working mode).

For further information on saving a sequence, follow the instructions as 
described in section Saving layouts.
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About graphic objects
Once you have created a document, you can compose the layout for laser 
engraving by:

• adding shapes (circles, rectangles, or polygons);
• importing the following raster or vectorial graphics:

• vectorial: .PLT, .HPGL, .DXF, .DWG
• raster: .BMP, .JPEG, .GIF, .PNG, .TIF

• creating text strings, matrix codes, bar codes, or arrays.

For further information:
The following sections describe how to work with objects in Laser Editor:

• Common objects properties
• Working with simple vectorial objects
• Using Text strings
• Using Codes
• Using Arrays
• Importing graphic objects
• Using the tiling function
• Understanding objects colour in the work area
• Common operations on objects
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Common objects properties
 

Notes

The tables that follow describe the Geometry, Laser, Filling and Clone proper-
ties which are common among graphic objects.

Geometry properties for Objects
The following table describes the Geometry properties that allow enabling/dis-
abling objects, resizing, rotating, and skewing them, as well as changing the 
objects position. These properties are displayed when an object is selected in 
the work area. 

Notes

The Properties window supports context-sensitive Help: 
During layout editing, selecting a properties title (for example, 
Geometry), and then pressing F1, opens the context Help for 
those properties.
For further information on how to operate on objects using 
properties, see Common operations on objects.
Properties that are specific to each object or to documents, are 
described in the relevant section.

For a quick, rough sizing, rotating, and positioning of an object, 
you might use your mouse (See Using the mouse to select and 
manipulate objects).The Property browser allows more pre-
cise operations.

Geometry
properties Description

ID To each object loaded in the graphic area can be assigned an unique alphanumeric ID 
that identifies the object in the layout.

Enable
If it set to True (default), it enables engraving of the selected object. If the object is not 
enabled (False), it will not be engraved and the object's colour in the work area 
changes to gray.

Locked
If it set to True, it locks the object preventing any editing. The selection handles 

around the object disappear and the  handle appears: Click it to unlock the object. 
(Default: False.)

Keep Aspect If it set to True (default), keeps the proportions between width and height. It does not 
apply to the Code object.

Contour

If it set to True, it allows merging the vectors that compose an object. In the case of a 
string, this property is particularly useful when working with languages whose alpha-
bets have ligatures, such as the Arabian language. (See Working with ligatures). 
(Default: False.)
It does not apply to the Array, Imported Bitmap objects and About two-dimensional 
(2D) codes.
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Pocketing
It allows fine-tuning the object's dimensions by adjusting the contour.
It does not apply to Array, Bitmap objects and About two-dimensional (2D) codes.

Tillable

It only applies to vectorial objects on ring documents, that is, on cylindrical surfaces. It 
is suitable for high precision markings, typically in jewellery.
It allows cutting the object's polygons having dimensions that exceed the sector size, 
into tiles whose dimension is equal to the ring's sectors. For a detailed description, see 
Using the tiling function.
This property is used in association with the ring document's Sector Gap and Sector 
Size properties that define the sector's dimensions.

Origin

This is the point of origin of the object. The origin is identified by the cross symbol 
which, by default, is placed in the center. If you select a value other than Center 
(default), this symbol moves accordingly. The following example shows an object 
whose origin has been set to Center Top in a document whose point of origin is set to 
Center:

You can specify the object's position in relation to the document's origin by setting the 
X and Y coordinates.

Position (X)
Sets the horizontal position of the object in relation to the origin that has been set for 
the document. You may increase X value to move the object to the right, decrease it to 
move the object to the left.

Position (Y)
Sets the vertical position of the object in relation to the origin that has been set for the 
document. You may increase Y value to move the object to the top, decrease it to 
move the object to the bottom.

Dimensions (W) Sets the width of the object.

Dimensions (H) Sets the height of the object.

Angle Sets the rotation angle (in degrees) of the object on the engraving area. It does not 
apply to the Array object.

Scale (X) By default, is set to 1,00. Increasing/decreasing this value results in the object's width 
changing. It does not apply to the Array object.

Scale (Y) By default, is set to 1,00. Increasing/decreasing this value results in the object's height 
changing. It does not apply to the Array object.

Skew
Sets a skewing for the object: if you set a positive value, the object is skewed to the 
right, while, with a negative value is skewed to the left. (Default: 0). It does not apply to 
the Array or Code objects.

Geometry
properties Description
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Custom Laser parameters for Objects
The following properties are displayed when you select an object in the work 
area, and then set to True the Custom Laser parameter in the Properties win-
dow.
By default, this parameter is set to False because, when you add a graphic 
object to a document, the object inherits the laser parameters that have been 
set for that document. You can still set different laser parameters for each 
object; in this case, the object's colour changes to blue.

Group Property Description

Passages

It allows setting the number of runs of the laser light on the object to 
engrave. You might set up to 3 passages, each with different laser 
parameters (see Passage properties group). This option may be particu-
larly useful to make several light engraving runs to clean the workpiece 
after a more incisive engraving process. (See Using more engraving runs)

Passage (#)

Power This indicates the laser output power. The value is expressed as a per-
centage of to the maximum power of the laser source.

Frequency

Light emitted by the laser is pulsed. Use this parameter to adjust the fre-
quency of the emitted light. All other parameters being equal, a lower fre-
quency causes a longer pulse. Not all combinations of power and 
frequency are allowed. Depending on the laser source type, low frequen-
cies require correspondingly low powers.

Scan Speed

This indicates the engraving speed. The value is expressed in millimeters 
per second. (Note: A slower speed implies engraving a deeper engraving. 
Set a very slow speed (50-100 mm/s) for special processes, such as bur-
nishing or deep engraving.

Dot Delay Sets the engraving time for each dot, that is, the length of time for the 
laser emission on the dot.

Shot Time Sets the duration of the laser shot pulse i.e. the time the Q-switch is 
open (or, better, transparent).

Repetitions
Sets the number of runs required by the laser for engraving the imported 
objects. Increasing the number of passes will increase depth of engrav-
ing, consequently affecting the cycle time.

Wobble

If it is set to True, this property allows engraving thicker lines through a spiral movement 
instead of a linear movement. (See Using the Wobble function to engrave with thicker 
lines)

Radius Represents the diameter of the spiral curve

Speed Represents the frequency of spiral repetition

X Axis If it is set to True, it allows setting the desired position for the X Axis.

Y Axis If it is set to True, it allows setting the desired position for the Y Axis.
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You can set the parameters for a specific object, based on a specific material 
(e.g. plastic) and its reactions to the marking operation. For further information 
on how to save and recover a materials database, see Saving a Materials data-
base for a later re-use.

Z Axis

If it is set to True, it allows setting the desired position for the Y Axis. If 
the distance sensor is enabled, the Origin property is available.
The Origin property has the following values:
•Logical Zero: the Height value is related to the Z Axis logical zero value
•Reference Position: the Height value is related to the position that the Z 
axis has, before the layout is processed.

R Axis If it is set to True, it allows setting the desired position for the R Axis.

Group Property Description
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Filling properties for Objects
The following properties are displayed when you select an object in the work 
area, and then set a value other than None (default) for the Filling property.

Notes The Filling properties do not apply to the Array object or the 
imported bitmaps.
See also Specifying the filling patterns to see examples of fill-
ing.

Filling
properties Description

Filling

This property is used to set the filling for the object. The engraving is mostly done with 
exact parallel lines. In particular, filling can be done with:

• Single line
• Cross lines - Inclination of the lines will be 0 and 90 degrees
• Triple lines - Inclination of the lines will be 0, 60, and 120 degrees.
• Islands - It allows deep engraving by executing a series of concentric markings, 

starting from the object's outline, so as to obtain countersunk shapes. The 
Islands allows to avoid crossed path, so each etched surface is exposed to the 
laser only once, which is particularly useful when engraving on delicate materi-
als.

• Dot - It only applies to About two-dimensional (2D) codes. It allows treating a 
square as a dot. This filling type is tailored for marking microelements, such as, 
for example, objects whose size is as big as the laser spot on the surface. In this 
case, the Dot filling allows marking directly a dot rather than filling a square.

• Raster - It allows marking a vectorial object as if it were a raster object, that is, 
using the raster engraving technique (for more information, see Raster graphics 
vs. Vectorial graphics). This setting is particularly suitable for plastic cards 
because constant scanning speed allows for better quality.

Interline Sets the distance between filling lines.

Angle
The angle (0-360°) that defines the direction of the engraving parallel lines. Setting an 
angle results in the engraving lines changing direction (0 = horizontal, left to right 
(default) - 90 = vertical, bottom to top - 180 = horizontal, right to left).

Advanced

Direction

This property is used to specify how the laser performs the filling operation:
• Bidirectional - The laser marks parallel lines, first lines from left to right, then 

right to left (or vice versa, according to the value that has been set for the Angle), 
and so forth. This allows reducing the markingtime. (Default).

• Unidirectional - The engraving is done only in one direction, increasing the mark-
ing time.

Outline option

This property is used to specify how the outline is to be marked relative to the filling:
• No outline - The outline of the object will not be marked.
• Filling first - The filling of the object will be marked first. (Default).
• Outline first - The outline of the object will be marked first.



62 Lighter™ Suite

Clone properties for Objects
The following properties are displayed when you select an object in the work 
area. 

Notes

Filling
properties Description

Clones

This property is used to repeat graphic object to a different position. Inparticular, the 
clone can be done with:

• Number of clones
• Offset

Clones number Sets the number of clone objects in X and Y coordinates.

Offset Sets the distance between objects in X and Y position.

Tolerance Sets the distance between object's outline and filling lines

Fill by

This property is used to specify how the laser marks the filling of objects that are 
composed by more polygons (such as strings):

• Object - The laser marks horizontally, using parallel lines across all the vectorial 
data that compose the object (for example, a string will be marked from bottom 
to top, scanning all letters with a single run). This filling option results in longer 
marking times, but it is recommended when marking on plastic cards because it 
ensures a uniform result.

• Polygon - The laser marks polygon by polygon (for example, letter by letter in a 
string, or bar by bar in a code). This filling option results in faster marking times 
and it is recommended in industrial environments.

Filling
properties Description

The Clone properties do not apply to the Array object or the 
imported graphics.
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Working with simple vectorial objects

The Circle, Rectangle, Poly, Lines and Dot toolbar buttons (as well as the 
Actions menu), allow inserting in your layout simple vectorial shapes that can 
be easily manipulated by editing the vectors. (See Starting nodes editing).

A vectorial object like this uses lines and curves, called vectors, to describe the 
image. In laser engraving a vectorial graphic is faster in engraving and more 
defined in terms of outline lines and filling.

Furthermore, you can use the Properties window, the toolbars, or the mouse to 
resize, adjust, group, space, shear, tile, fill the shapes, and so forth.

Notes

The following sections describe how to work with vectorial shapes:
• Adding a shape
• Starting nodes editing
• Using the tiling function
• Geometry properties for Objects
• Custom Laser parameters for Objects
• Filling properties for Objects

For information on mouse operations, see Using the mouse to 
select and manipulate objects.
For information on how to operate on graphics, please refer to 
Common operations on objects.
Clicking a properties title in the Properties browser and then 
pressing F1, opens a table with a description of those proper-
ties.
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Adding a shape

To add a shape:
First, create or open a document to enable the insertion of objects (see Creating 
Graphic Layouts and Opening existing layouts).

To add a circle or a rectangle, do one of the following:
• On the vertical toolbar click on the  Insert objects button and then, in 

the horizontal toolbar that is displayed, click on  Circle or  Rectangle.
• From the Laser Editor menu bar, choose Actions > Insert > Circle or Rect-

angle.
The shape (a circle or a square) appears in the work area, surrounded by 
the selection handles: Drag to make the shape the size you want (see 
Using the mouse to select and manipulate objects).

To add a poly, do one of the following:
• On the vertical toolbar click on the  Insert objects button and then, in 

the horizontal toolbar that is displayed, click on  Poly.
• From the Laser Editor menu bar, choose Actions > Insert > Poly.
• Position the mouse pointer at the required start point for the polygon and 

left click.
• To create a curve: Left-click and hold down while dragging to the desired 

position:

(For further information on nodes, see Starting nodes editing).
• Once the pointer is in the desired location, left-click to draw a green-

coloured line.
• Repeat the previous step as many times as required to add subsequent 

corners of the polygon.
• To close the polygon click on the first click point. The selection handles 

appear around the object. To exit the Poly creation mode, press Esc.
(For further information, see Using the mouse to select and manipulate 
objects).
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To add a Line, do one of the following:
• On the vertical toolbar click on the  Insert objects button and then, in 

the horizontal toolbar that is displayed, click on  Lines.
• From the Laser Editor menu bar, choose Actions > Insert > Lines.
• Click and drag to draw the desired line.
• To close the line click on the first click point. The selection handles appear 

around the object. To exit the Lines creation mode, press Esc.
(For further information, see Using the mouse to select and manipulate 
objects).

To operate on shapes:
• Use the Properties window, the toolbars or the mouse to customize the 

look of the shape, in terms of size, position, rotation, filling, and so forth, 
as well as for setting custom laser parameters.

• Select the shape, then double-click it: This will result in the shape's seg-
ments changing to the green colour and in the Edit nodes function being 
enabled. See Starting nodes editing.
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Using Text strings

By using the toolbar button or the Actions menu, Laser Editor allows you to 
insert text strings in a layout.

You can then use the Properties browser, the toolbars tools, or the mouse to set 
dimensions, printing character, font style, spacing, shear and filling. (Click a 
properties title, then press F1 to open a table with a description of the proper-
ties.)

Laser Editor allows you to:
• dynamically display updated texts;
• use special character s to create variable texts (date, time, auto-incremen-

tal counter);
• place the text inside or outside of a circumference arc;
• import any kind of font;
• set the font, dimensions, style, printing characters, spacing, and filling;
• edit strings as pure vectorial objects;
• rotate, shear, or resize strings using the mouse (see Using the mouse to 

select and manipulate objects);
• set custom laser parameters that differ from those that have been set for 

the document.

The following sections describe how to work with Text Strings:
• Adding a Text string
• Changing the characters style (see Text String properties)
• Aligning the text to a circle (see Text String properties)
• Importing fonts
• Using special character sequences
• Making a text string to include an incremental counter
• Editing a string as a pure vectorial object
• Dynamically managing strings that share contents
• Working with ligatures
• Using the tiling function
• Text String properties
• Common operations on objects
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Adding a Text string

To add a string:
• Create or open a document to enable the insertion of objects (see Creating 

Graphic Layouts and Opening existing layouts).
• Do one of the following:

• On the vertical toolbar click on the  Insert objects button and then, in 
the horizontal toolbar that is displayed, click on  Text string.

• From the Laser Editor menu bar, choose Actions > Insert > Text string.
• The String object is displayed in the work area, surrounded by the selec-

tion handles: for quick, rough sizing, rotating, or positioning, use your 
mouse (see Using the mouse to select and manipulate objects).

• Use the Properties window and the toolbars buttons for formatting and 
customizing the string. (See below). 

Notes

Importing fonts
Warnings

By default, Laser Editor uses standard fonts but you can use this function to 
import any kind of fonts. You will then be able to select the fonts from the Font 
property list under the Style property group.
Furthermore, two non-standard, single line fonts are provided (namely, 
Roman-s and Standard) that allow optimizing the marking time. You might also 
import One Line single line commercial fonts ("www.onelinefonts.com").

To import fonts:
• Choose File > Import fonts from the menu bar. The Font import dialog box 

is displayed.
The System font area on the left lists all the fonts that are currently 
installed on your system; by selecting a font, a preview is displayed on the 
left pane.

• Select the font(s) you want to import in Laser Editor, and then click  to 
enter the font in the Laser fonts list on the right.

• Click  to import all existing fonts.

For a quick-reference on using toolbars in Laser Editor, see 
Using toolbars tools.
Clicking a properties title in the Properties window and then 
pressing F1, opens a table with a description of those proper-
ties.

In order to enable this function, all documents have to be 
closed.
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Using special character sequences
You can use the Text string tool to create variable texts that include dates and/
or times. To do so, you will use special character sequences.

To create dates and times by using special character sequences:
• Add a text string to the document (see Adding a Text string.
• In the Properties browser, under String select the Text box, and then enter 

the desired special character sequence, depending on the date and/or 
time format you want to use. Use the following table as a reference:

Table 1 Special character sequences for dates and times

Special charac-
ter sequence Result

%a, %A Day of the week, abbreviated (a) or full (A)

%b, %B Month of the year abbreviated (b) or full (B)

%c Date and time according to current location

%d Day of the month, decimal number (01 -31)

%H Time 24 hour clock format (00 - 23)

%I Time 12 hour clock format (01 - 12)

%j Day of the year, decimal number (001 - 366)

%m Month of the year, decimal number (01 - 12)

%M Minutes, decimal number (00 - 59)

%p A.M. / P.M. indicator

%S Seconds, decimal number (00-59)

%U Week of the year, decimal number (00 - 51, Sunday is the first day of the week)

%w Day of the week, decimal number (1 - 7, Sunday = 1)

%W Week of the year, decimal number (01 - 52, Monday is the first day of the week)

%x Date according to current location

%X Time according to current location

%y Year, two digit decimal number (00 - 99)

%Y Year, four digit decimal number

%z, %Z Time zone, name (Z) or abbreviation (z)

%% Percentage sign%

%[ID]
Percentage sign followed by an ID string that allows copying the content of a string 
into another string for dynamic update. (See Dynamically managing strings that share 
contents, for further information).
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• After entering the selected sequence, press Enter. The string changes to 
the selected date and/or time format. Set the required parameters for the 
string by setting the Text String properties, or using the toolbars buttons.

Example:
• Entering the sequence %d/%m/%Y in the text box will result in a text string 

with the following format: 01/04/2008.
• Entering the sequence %d/%m/%y in the text box will result in a text string 

with the following format: 01/04/08.

Notes

%#c Long date and time representation, appropriate for current locale. (For example: Tues-
day, April 1, 2008, 12:41:29)

%#x Long date representation, appropriate for current locale. (For example: Tuesday, April 
1, 2008).

%v[], %V[] These sequences allow using global variables. V forces the capitalization. (For further 
information, see Using global variables).

%f

It allows encoding the FNC1 character for symbologies supporting the GS1 standard. 
(For further information, see section Using Codes, GS1-128 standard, and GS1 Site).
Example: providing a text value %f00350123451234567894 to a 128 code, encodes a 
GS1-128 having AI 00 and code 350123451234567894.

%T[]
Inserts the ASCII character corresponding to the number between square brackets. It 
is useful for adding string ASCII char that do not have a graphical representation. (For 
example: %T[21] will encode the NAK ASCII code.

Special charac-
ter sequence Result

To enter the character % into the string, type it twice %% into 
the Text box.
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Making a text string to include an incremental counter
You can use the Text string tool to create a variable text that includes an incre-
mental counter. To do so, you can:

• Use special character sequences to associate a counter to a specific string. 

Warnings

• Create a global variable so as to save the counter at the device level, and 
then use proper special character sequences to associate it to more strings 
and/or documents. (See section Using global variables).

To use special character sequences to create a counter:
This procedure describes how to use special character sequences to associate a 
counter to a specific string, into a specific document. (To create a variable that 
you can share between more strings and/or document, as well save at a device 
level, please refer to section Using global variables.)

• Add a text string to the document (see Adding a Text string).
• In the Properties window, under String select the Text box, and then enter 

the desired special character sequence, depending on the type of counter 
you want to create. Use the following table as a reference:

Table 2 Special character sequences for counters

Special charac-
ter sequence Result

%n Counter, decimal format. It can be associated to a specific string.

%o Counter, octave format. It can be associated to a specific string.

%e, %E Counter, hexadecimal format, lower case (e) or upper case (E). It can be associated to a 
specific string.

%v, %V It allows using a global variable (see Using global variables).

Use of this type of counter is maintained for legacy software 
support only. You should avoid using it in new projects. This 
counter is deprecated in favour of global variables. Using such 
counters from the Editor may result in a value presentation 
not aligned with the one in use from the Engine.
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• Press Enter. The string changes to the specified counter format. Set the 
required Counter properties.

• Use the following table as a reference:

Counter property Description

Start The minimum value for the counter.

Stop The maximum value for the counter.

Current The current value of the counter as it appears in the string.

Step Increment value (positive or negative).

Cycles The number of times the counter will be marked before it is incremented by one step.

Digits The minimum number of digits to be displayed.

Example
• Entering %n in the text box and then setting the parameters as follows

Current = 1 - Start = 1 - Stop = 10 - Steps = 2 - Cycles = 2 - Digits = 3
would result in the format 001 to become 003 ... 005 ... 007 ... 009 ... 002 
... 004 ... 006 ... 008 ... 010 ... 001.
An increment would occur every two engraving jobs.
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Editing a string as a pure vectorial object
This procedure involves making the string a pure vectorial object.

This way, the string loses its specific properties and changes to a vectorial 
object that you can edit by using the Edit nodes function of Laser Editor. (See 
Editing objects vectors).

To edit the vectors:
• Select the string you want to make vectorial.
• Do one of the following:

• From the Laser Editor menu bar, choose Actions > Make vectorial.

• On the vertical toolbar, click  and then click  Make vectorial in the 
horizontal toolbar.

• To enable the edit nodes function, click the . Edit nodes button. This 
will result in the Edit nodes horizontal toolbar being displayed and in the 
colour of the outline changing to green.

• Click the string to display nodes and control points that you can use to 
edit the characters:

For detailed information on how to edit nodes, please refer to section Editing 
objects vectors.

• To exit the Edit nodes operating mode, click the  Insert objects button.
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Dynamically managing strings that share contents
Laser Editor allows for dynamically managing strings contents.

Suppose that you have two strings that share the same content and that you 
want to keep their content aligned if a change occurs. To do this, you can con-
nect the strings content to each other by means of their ID, which is a unique 
alphanumeric string that identifies the object into the layout.

Notes

To use IDs to connect and dynamically update text strings:
• Select the string whose content you want to enter in another string.
• Associate an ID to the string: In the Properties window, under Geometry, 

click the text box beside ID and then enter the desired alphanumeric 
string. Note that the ID appears below the string:

• Add to the document the string that must share the same content as the 
above string. (See Adding a Text string).

• In the Properties window, under String, click the text box beside Text and 
enter %[St1] followed by the text of the new string, as it is illustrated 
below:

In this way, when the string IDTest changes, the second string will be also 
dynamically updated.

Circular references are not allowed. If a circular reference is 
being introduced, an error message will be displayed.
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Working with ligatures

What is a ligature?
A ligature occurs where two or more letter-forms are joined as a single glyph. 
Ligatures usually replace consecutive characters sharing common components.

For example, in the Arabic alphabet, historically a cursive, most letters take a 
variant shape depending on which they are followed (word-initial), preceded 
(word-final) or both (medial) by other letters.

From the point of view of an engraving layout, the ligatures would appear as 
letters (that is, vectorial data) overlapping each other; as a result, the over-
lapped areas would not be filled as expected.

To fix the problem, the Contour property is used, which allows merging the let-
ters, while keeping the string from becoming a vectorial object.

Using the Contour property to merge the letters:
• Select the text with ligatures (letters that overlap each other).
• From the Properties window, select Filling and then, from the dropdown 

list, choose the desired filling value. (For further information, see Filling 
properties for Objects). The overlapped areas will appear as follows:

• Under Geometry, select the Contour checkbox to set the True value. As a 
result, the overlapped areas will be filled and the object will be kept as a 
String:
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Text String properties
The Properties window supports context-sensitive Help: During layout editing, 
selecting a properties title (for example, Geometry), and then pressing F1, 
opens the context Help for those properties.

The following properties appear when a Text string object is selected in the 
work area (see Using Text strings).

Notes For a quick, rough sizing, rotating, and positioning of a string, 
you might use your mouse (See Using the mouse to select and 
manipulate objects).The Property browser allows more pre-
cise operations.
Refer to section Common operations on objects for further 
information on how to use properties to perform specific 
operations on the object.

Property Subproperty Description

Text

The text string to be engraved. Select the Text box, enter the string or the 
value of the variable which represents it and press Enter. (For informa-
tion on how to use special characters sequences, refer to Using special 
character sequences).

Style

Font
The converted font that the text must use. The dropdown list contains 
the available fonts. You might also import new fonts (See Importing 
fonts)

Style The font style to be applied to the string. The dropdown list contains the 
available options.

Height The height of characters.

Shear Represents the shear of the selected string on the X axis.

Angle

Represents the angle of rotation that a single letter uses in relation to its 
origin. The example below shows a string with a character angle of 15 
degrees:

Displace-
ment

Spacing
Represents the distance between the string's characters (default value is 
0). Negative values decrease the default spacing, whereas positive values 
increase it.

Compression Represents the compression of each character of the string (default 
value is 100).
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See also:
• Geometry properties for Objects
• Custom Laser parameters for Objects
• Filling properties for Objects

Circle

If enabled (True), the Circle property enables placing the text on a circumference arc 
(default value is False). Setting the value to True, will result in making the following prop-
erties visible for you to specify the appropriate parameters:

Radius

Represents the diameter of the circumference arc to align the string on. 
Set a value other than 0 to create a circle. The figure shows a circle with a 
radius value of 8:
Displacement

Counter 
clockwise

Sets the direction of text on the circumference arc. By default, is set to 
clockwise.

Inside If enabled (True), it allows placing the string within the circle.

Autostart 
angle

If enabled (True), it allows setting the start point of the string on the arc. 
You can then set the start point in degrees in the Start Angle field below. 
The figure shows an Automatic start angle (when this option is set to 
False):

Start angle Represents in degrees the start point of the string on the arc.

Counter

The Counter group enables creating a variable text that includes an incremental counter 
(see Making a text string to include an incremental counter).

Start The minimum value for the counter.

Stop The maximum value for the counter.

Current The current value of the counter as it appears in the string.

Step Increment value (positive or negative).

Cycles The number of times the counter will be marked before it is incremented 
by one step.

Digit The minimum number of digits to be displayed.

Custom For-
matters

Formatters are source files that are supplied with Project Editor. These files can be used 
as functions libraries. Their purpose is to make it easier for developers to create custom 
applications. For example, as an integrator, you might need specific functions that these 
libraries provide. Formatters have a .qs extension and are stored in the folder 
...\Data\Formatters.

True or False Enable or Disable the use of a Custom Formatter file

Script Visible only if Custom Formatters is set to True. Use to select the Custom 
Formatters from a list of available files.

Property Subproperty Description
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Using Codes

Codes are representations of text data that is formatted and displayed espe-
cially for automatic acquisition by dedicated optical devices (code scanners or 
readers).

There are several codes symbologies, which are provided in Laser Editor:
• Linear
• Postal
• Stacked
• Two-dimensional (2D)

By using the Code toolbar button or the Actions menu, you can insert codes in a 
layout.

You might then use the Properties browser or the toolbars tools to set dimen-
sions, the type of standard, the size, the error levels, a checksum, the filling 
and so forth. (Clicking a properties title in the Properties window and then 
pressing F1, opens a table with a description of those properties).

The code is treated by Laser Editor in the same way as a text string, therefore it 
is possible to associate the functions of special character sequences as 
described for the string object. (See Using special character sequences).

Furthermore, you can:
• set dimensions, black and white ratio, and filling;
• rotate or resize the code;
• set custom laser parameters that differ from those that have been set for 

the document.

The following sections describe how to work with Codes
• Usual Codes terminology
• About linear bar codes
• About stacked bar codes
• About two-dimensional (2D) codes
• Adding a code
• Setting the data restoring capability
• Balancing the black and white ratio
• Codes properties
• Using the tiling function
• Common operations on objects
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Usual Codes terminology
Bar code symbol
A complete bar code, made of a blank area before the code, a start character, 
one or more characters containing the information, a stop character and a final 
blank area (quiet zone).

Black/White ratio
The ratio between white and black modules. You can fine-tune this ratio when 
marking very small elements.

Codewords
Group of bars and spaces representing one or more numbers, letters, or other 
symbols.

Element
Name of a space or a bar.

GS1-128 standard
The GS1-128 standard is an application standard (visit the GSI Site for further 
information) within the Code 128 barcode. It allows using a series of Applica-
tion Identifiers to include additional data such as best before dates, batch num-
bers, quantities, weights and many other attributes that a user might need. It's 
supported in our software by Using special character sequences.

Inter-character space
A space which separates two adjacent characters, in some codes (code 39, bar 
code) the spaces inside a character contain information, inter-character spaces 
do not.

Linear bar code
A linear bar code symbol (also known as 1D barcode) is made up of a series of 
bars and spaces which contain information and check elements.

Module
The smallest thickness in a code element. In the case of linear bar codes, it 
constitutes the measurement unit of the thickness of wide elements. In the case 
of 2d codes, it is a single cell, which represents a bit in the code representation. 
It is represented by a square.

Quiet Zone
The blank spaces immediately preceding the start character and following the 
stop character.

Print ratio
In two thickness codes, it is the ratio between the thickness of the wide element 
and that of the narrow one.

Stacked code
A symbol that is broken into sections and "stacked" one upon another similar to 
sentences in a paragraph. Extremely compact codes.

Two-dimensional codes (2D codes)
A two-dimensional code (also known as matrix code) is built on a true 2-D 
matrix. It is a two-dimensional way of representing information and contains 
information in both the vertical and horizontal directions.
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About linear bar codes
A linear bar code symbol (also known as 1D barcode) is made up of a series of 
bars and spaces which contain information and check elements. Bars can be all 
same length or have some of them longer protruding the bottom part as in EAN 
codes.
In Linear symbologies there are also the Postal Codes can be distinguished by 
bars disposed always the same interval, same width but different bar heights 
(up to 4) like the Royal Mail code shown here below.
The following shows the EAN 8 linear bar code and the Royal Mail code:

The following represents the structure of a bar code symbol:

Where:
• Y: Thickness of the wide element
• X: Thickness of the narrow element
• Q: Thickness of the blank overflow zones at the end of the label (quiet 

zones)

Available linear bar codes in Laser Editor
The Encoding Type property of the Code allows selecting the desired code from 
the dropdown list:

Notes

Bar codes with two thickness
Bars and spaces of code 2of5 or 39 can just assume two thicknesses, in a print 
ratio between 2 and 3, which is the standard-compliant ratio. To set this 
parameter use the Advanced > Print ratio property in the code's Property. (See 
Codes properties).
There are other codes in this category (Codabar, code 32, etc.), but their print 
ratio is fixed.

Bar codes with multiple thickness
There are many code symbologies whose bars and spaces can assume more 
than two different thickness. Some examples of them are EAN, UPC, code 128, 
code 93, DPD code, etc..

For further information on properties, and for a description of 
the available codes, select the Encoding properties title and 
press F1 to display the relevant Help topic.
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Postal codes
This kind of symbologies is built with same bars having same width but varying 
height. Bars are regularly interspersed since also the the distance of consecu-
tive bars equals the bar width.
Where bars have two different heights (short and long bar), they share the same 
base line, growing bottom up. Examples are US Postal, CEPNet, Planet.
Where codes uses three different heights consist of long bars and short bars 
either growing bottom up or to down, and short bars. One example is the Phar-
macode 2-Track.
Barcodes with four different heights consist of long bars, medium sized bars 
either growing bottom up or to down, and short bars, drawn vertically centered. 
Examples are Australian Postal, Royal Mail 4 State, KIX, Intelligent Mail® Bar-
code, DAFT, Japanese Postal.

Related topics:
• Usual Codes terminology
• About stacked bar codes
• About two-dimensional (2D) codes
• Adding a code
• Setting the data restoring capability
• Balancing the black and white ratio
• Codes properties
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About stacked bar codes
Stacked bar codes are a compromise between true 2D barcodes and linear 
codes and are constructed like a layer cake of barcodes stacked on top of the 
other. These are extremely compact codes.
Codablock-F and PDF 417 are examples of stacked bar code, where a long 
symbol is broken into sections and "stacked" one upon another similar to sen-
tences in a paragraph. See picture below:

In particular, PDF 417 has error correction capability that allows restoring data 
if the code is dirty or damaged. For further information, see Setting the error 
correction level.

Available stacked bar codes in Laser Editor
The Encoding Type property of the Code allows selecting the desired 2D Code 
from the dropdown list:

Notes

• PDF417
• MicroPDF417
• Codablock F
• GS1 Databar Omni
• GS1 Databar Stacked
• GS1 Databar Expanded

For further information on properties, and for a description of 
the available codes, select the Encoding properties title and 
press F1 to display the relevant Help topic.
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About two-dimensional (2D) codes
A two-dimensional (2D) code (also known as matrix code) is built on a true 2-D 
matrix. It is a two-dimensional way of representing information whose primary 
advantage is the ability to encode a lot of information in a small space.

A 2D code contains information in both the vertical and horizontal directions, 
whereas a bar code contains data in one direction only.

Information encoded in a 2D matrix code symbol, can be recovered even if the 
mark is damaged and missing a portion. This capability depends on how much 
redundant information your code contains and on the error correction level (see 
Setting the data restoring capability).

Matrix codes are made up of a pattern of cells that can be dot, square (as in the 
Datamatrix 2D code here below), hexagonal or circular in shape, like the Maxi-
Code code shown here below:

Available 2D codes in Laser Editor
The Encoding Type property of the Code allows selecting the desired 2D Code 
from the dropdown list:

Notes

• Datamatrix
• QRcode
• MicroQRcode

For further information on properties, and for a description of 
the available codes, select the Encoding properties title and 
press F1 to display the relevant Help topic.
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Adding a code
To add a code:

• Create or open a document to enable the insertion of objects (see Creating 
Graphic Layouts or Opening existing layouts).

• Do one of the following:
• On the vertical toolbar click on the  Insert objects button and then, in 

the horizontal toolbar that is displayed, click on  Code.
• From the Laser Editor menu bar, choose Actions > Insert > Code.

• The Code is displayed in the work area. By default, the last code type is 
used but at first installation the linear bar code type 128 is displayed. To 
change the symbol, in the Property browser: under Code symbol, select 
Encoding > Type, then choose from the dropdown list the option that best 
fit your requirements. (See Codes properties for more information on the 
available codes).

• Use the Properties window to set other code parameters, and the mouse 
and toolbars buttons to operate on it. 

Notes Or a quick-reference on using toolbars in Laser Editor, see 
Using toolbars tools.
Clicking a properties title in the Properties window and then 
pressing F1, opens a table with a description of those proper-
ties.
For further information on how to operate on objects, see 
Common operations on objects.
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Setting the data restoring capability
Information encoded on 2D codes can be recovered, even if the mark is dam-
aged and missing a portion.

This capability depends on how much redundant information your code con-
tains and on the error correction level that you set. Greater redundancy and 
higher error correction level result in a greater recovering ability, but impact 
code dimensions and, consequently, the marking time.

Note that PDF 417, which is a stacked codebar, has error correction capabilities.

For further information:
• Setting the level of redundancy for 2D Codes
• Setting the error correction level
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Setting the level of redundancy for 2D Codes
Notes

In the case of 2D Codes you can set different codes dimensions, that is, you can 
specify how much redundant data your code can contain.

2D Codes range from smaller to larger versions. Each version has a different 
number of modules. Note that, as the amount of data increases, more modules 
are required to comprise the code, resulting in larger code symbols.

You can use the Size property in the code's Property browser to determine the 
dimensions of the symbol so as to suit your redundancy needs. (See Codes 
properties).

To set codes dimensions:
• Select the code in the document. The Property browser is displayed for the 

code.
• Under Encoding, in the Code properties group, select from the Size drop-

down list the desired value. Note that the Best Fit options correspond to 
the minimum size for the information to be encoded.

The following figure shows a range of sizes in the case of a QRCode:

Please consult the "Barcode Reference.pdf" for specific infor-
mation about each simbology supporting this feature.



86 Lighter™ Suite

Setting the error correction level 
Notes

The error correction capability allows restoring data if the code is dirty, dam-
aged or partially unavailable. Many codes allow setting different error correc-
tion levels.

Different error correction levels are available for users to choose according to 
the operating environment (the amount of data that needs to be encoded, the 
size and the amount of symbol damage that could occur), each corresponding 
to a different data restoration rate for total codewords. Raising this level 
improves error correction capability but also increases the amount of data and 
QR Code size.

You can use the Error Level properties in the Property browser to set the error 
correction. (See Codes properties).

To set the error correction level:
• Select the code in the document. The Property browser is displayed for the 

code.
• Under Encoding, in the Code properties group, select from the Error Level 

dropdown list the desired value.

This option applies to Two-dimensional codes (2D codes) and 
some others. Please consult the "Barcode Reference.pdf" for 
specific information about each simbology supporting this 
feature.
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Balancing the black and white ratio
This capability allows adjusting the ratio between white and black elements 
when marking very small elements.
This feature is also referred as "Bar Width Reduction" (BWR), "Bar Width Correc-
tion" (BWC), "Pixel Shaving".

In this case, the dimensions of the spot might have an effect on the black and 
white dimensional ratio and you might need to balance the ratio. The engraving 
elements (black) must be identical to the empty ones.

To balance the ratio:
• Select the code in the document. The Property browser is displayed for the 

code.
• Under Encoding, in the Code > Advanced properties group, set the Black/

White ratio value to the desired percentage. The default is 100%, meaning 
that black and white elements are identical.

• Set a lower percentage to compensate the dimension of the spot laser.
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Codes properties
The Properties window supports context-sensitive Help: During layout editing, 
selecting a properties title (for example, Geometry), and then pressing F1, 
opens the context Help for those properties.

The following properties appear when a Code is selected in the work area.

Notes Refer to section Common operations on objects for further 
information on how to use properties to perform specific 
operations on the object.
Refer to Usual Codes terminology for a description of the 
technical terms.

Group Property Values Description

Text
The string to be engraved in the TEXT field of 
the code, or the value which represents it. 
(See Using special character sequences).

Encoding Type Represents the encoding type.

128

Linear bar code with multiple thickness. It is 
used for alphanumeric or numeric-only bar-
codes, variable length. It is the default value. 
It can host GS1-128 standard. It is a modern 
high-density symbology and was invented 
1981 by Computer Identics. The software 
analyzes input data and chooses the best 
suitable barcode representation with the 
highest data density. This is done by so-
called "subset switching". 3 different internal 
characters (=subsets) sets are used:

• Code128A = Upper Case + Non-
Printable Characters (ASCII 0-31)

• Code128B = Upper / Lower Case + 
All Printable Characters

• Code128C = Numeric with dou-
bled density

Code128 uses a built-in check digit (Modulo 
103). This check digit is part of the code and 
cannot be omitted. It is never printed in the 
human readable text. Scanners are checking 
it when reading a code but do not deliver the 
check digit to connected systems.
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2/5 Linear bar code with two thickness. It is a 
numeric-only barcode.

Subtype

Standard
This is a self-checking code. It is used for 
industrial applications, article numbering, 
photo development, ticketing.

Industrial As above, but with a different Start/Stop 
character encoding.

Interleaved

Code 2 of 5 Interleaved is in wide-spread use 
(article-numbering, industrial applications). 
This self-checking code offers high data 
capacity due to encoding pairs of numbers 
(the first digit is encoded in the bars, the sec-
ond in the spaces). Thus, this symbology can 
encode only an even number of digits. If the 
number of digits is odd a leading zero will be 
inserted automatically.

IATA

This is a self-checking code. Start/stop-
characters are identical to Code 2 of 5 Indus-
try. It supports distance reading (>1m) and 
can be printed with very simple printing 
techniques. It is used for baggage handling in 
air-transport applications (International Air 
Transport Agency = IATA).

Datalogic This symbology is proprietary variant of Code 
2 of 5 Standard.

Checksum True or False If it is set to True, enables a terminating 
checksum code-words.

Group Property Values Description
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3/9

Subtype

Standard Encodes 43 characters: A-Z, 0-9, space, and -
.$/+%.

Full

This version is rarely used because Code 128 
offers much better compression. It uses the 
same symbology as Code 39 but encodes 
also lower-case letters and special charac-
ters ("+A" results in a lower case "a" when 
scanned). Scanner must be configured cor-
rectly for decoding Code39 Full/Extended.

LogMars

This is a special variant of Code 39 used by 
the U.S. Department of Defense. This stan-
dard defines acceptable ranges for a number 
of variables, include density, ratio, bar height, 
and size of the human-readable interpreta-
tion line. The modulo-43 check digit, which is 
optional for Code 39, is defined and recom-
mended in the specification.

Checksum True or False If it is set to True, enables a terminating 
checksum codewords.

93

Code 93 was invented 1982 by INTERMEC to 
achieve better information densities (com-
pared to Code 39). Code concatenation is 
possible (if the first encoded character is a 
space subsequent barcodes are concate-
nated by the scanner).

Subtype

Standard Encodes 43 characters: A-Z, 0-9, space, and -
.$/+%.

Extended

Based upon Code 93 but encodes the com-
plete ASCII character set. One of the four 
available control characters is used to shift 
into the ASCII-character table.

Group Property Values Description
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Australian Post

This barcode is used by the Australian Post 
for marking shipments. Special code variants 
are available for redirections, replies and so 
on.

Subtype

Customer

The barcode height is between 4.2 mm and 
5.8 mm. The module width should be 
adjusted to 0.47 mms. Usual no readable text 
is displayed. The length will depend on the 
use of additional bars (code variants Cus-
tomer 2 and Customer 3).

Customer 2

This is the same barcode as the Australian 
Post Standard Customer, but with additional 
5 characters for customer specific data. The 
first 8 characters must be digits. This sym-
bology is also called Australia Post 52-CUST 
(Due to its 52 bars).

Customer 3

This is the same barcode as the Australian 
Post Standard Customer, but with additional 
10 characters for customer specific data. The 
first 8 characters must be digits. This sym-
bology is also called Australia Post 67-CUST 
(Due to its 67 bars).

Redirect If selected, the code can contain up to 8 digit.

Reply Paid If selected, the code can contain up to 8 digit.

Routing If selected, the code can contain up to 8 digit.

Aztec Code

Aztec Code can encode from small to large 
amounts of data with user-selected percent-
ages of error correction. The symbol size 
adjusts automatically depending on the 
amount of input data.The input data is 
always analyzed and the appropriate encod-
ing mode is chosen automatically. Mode 
switching is done as required to produce the 
most efficient encoding.

Brazilian CEPNet / Brazilian Postal Code

This code is used by the Brazilian Postal Ser-
vices. An 8 digit ZIP-code is encoded.The 
check digit is calculated automatically. It can-
not be specified in the input data. The bar-
code height should be adjusted to 3.2 mms; 
the module width to 0.423 mms; usually no 
plain text is displayed. The encoding is based 
on US Postal codes.

Group Property Values Description
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Codabar

The characters "A", "B", "C", and "D" are use-
able as start or stop characters only. The 
barcode uses 2 element-widths and 4 differ-
ent start/stop-characters (A, B, C, and D). 
These start/stop characters can be utilized 
for additional information - e.g. "B1234B". 
The print ratio should be in the following 
range: 1:2 -1:3 (Pr >= 2.25:1). Since the sym-
bology is "self-checking" there is no estab-
lished check sum method.

Codablock F

Is de facto a "stacked" Code128 symbology. It 
is based upon Code 128 - each row is a single 
Code 128 symbol extended with row indica-
tor information and additional check digits. 
The UCC/EAN/GS1 format indicator is sup-
ported.

Code 11

This symbology is mainly used in telecom-
munications for marking equipment and 
components. It was invented in 1977 by 
INTERMEC. It is similar to Code 2 of 5 Matrix. 
The symbology is not self-checking therefore 
2 check digits are recommended. Code 11 is a 
high-density code, but requires also a high-
density output device (mainly because of the 
print ratio utilized).

Code 32

It is used by the Italian Pharma Industry. The 
code is also called Italian Pharmacode. The 
Code 32 number, consisting of 9 digits, is 
converted to an equivalent Code 39 Barcode 
of 6 characters. The letter the human read-
able text is prepended by "A" which is not 
encoded.

DAFT code

DAFT Code is no symbology. It is a technique 
to generate arbitrary postal codes (like for 
instance the Australian Postal Codes or the 
Royal Mail 4 State code).

Deutsche Post This symbology is used by Deutsche Post.

Subtype

Leitcode

The code is basically a Code 2 of 5 Interleaved 
enhanced with a special check digit calcula-
tion. It is used for encoding the ZIP-Code, 
Street and number of the shipment.

Identcode
The code is basically a Code 2 of 5 interleaved 
enhanced with a special check digit calcula-
tion.

Group Property Values Description
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Dotcode

DotCode is 2D dot code symbology designed 
to be reliably readable when printed by high-
speed inkjet or laser dot technologies. The 
encoding modes of DotCode are based on the 
Code128 data encoding (with modes A, B, and 
C) extended by a so called Binary Mode. The 
default interpretation for DotCode data is ECI 
000003 representing the Latin-I character 
set. The DotCode symbology does not have 
absolute capacity limits, but a maximum 
symbol size of 124x124 dots is recom-
mended

Subtype

Auto Discriminate If the data starts with 2 digits, barcode has 
GS1 format, otherwise generic format is used

Generic Format Barcode data does not fulfill any special for-
mat, if it starts with 2 digits, FNC1 is inserted

UCC/EAN/GS1
The internal data must start with 2 digits and 
has to apply to a format of an so-called 
application identifier

Industry A peculiar industry format, which adds FNC1 
at 2nd position

Macro 05 The data is prefixed with "[)>" + RS + "05" + GS 
and suffixed with RS + EOT

Macro 06 The data is prefixed with "[)>" + RS + "06" + GS 
and suffixed with RS + EOT

Macro 12 The data is prefixed with "[)>" + RS + "12" + GS 
and suffixed with RS + EOT

Custom Macro
The data is prefixed with "[)>" + RS and suf-
fixed with RS + EOT; the rest of the format 
specifier has to be encoded by the user

Reader Programming The barcode data is used to program the bar-
code reader

DPD

DPD Code is used by Deutscher Paket Dienst. 
It is based on Code 128 and is limited to 28 
encoded characters. The encoded data and 
the human readable text differ slightly

Group Property Values Description
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EAN

Linear bar code with multiple thickness. It is 
a self checking, numeric code.
This symbology is reserved for the European 
Article Numbering (EAN).
The number is maintained by EAN and 
encodes manufacturer and product.
The check digit is calculated automatically if 
not specified in the input data (that is when 
only 7 digits are used for creating the code)

Subtype

8

If selected, the code can contain up to 8 digit 
numeric.
It's used for marking small articles with 
restricted space.

8+2

This symbology extends EAN-8 with 2 add-
on digits which are mainly used for encoding 
the price or the weight.
This symbology is also used for bar-coding 
paperbacks or newspapers. In this case a 2(3) 
digits country code and a 4(5) article code are 
encoded.

8+5
This symbology extends EAN-8 with 5 add-
on digits which are mainly used for encoding 
the price or the weight.

13 If selected, the code can contain up to 13 digit 
numeric.

13+2 This symbology extends EAN-13 with 2 add-
on digits.

13+5 This symbology extends EAN-13 with 5 add-
on digits.

128

The EAN-128 code is based upon Code-128. 
It has an FNC1 character at the 1st position 
(after the start code). This allows scanners 
and data processing software to differenti-
ate EAN-128 from other symbologies.
The EAN-128 code is in wide spread use 
(retail, logistics, food and beverage, etc.). It is 
used for marking transport-units in supply 
chains. Besides the article-number it 
encodes quantities, weights, prices, dates, 
and other information in a structured way. 
This is supported by the use of so-called 
Application Identifiers (AIs) - see chapter 5.

Text String True or False If it is set to True, displays and marks the 
human readable string.

Group Property Values Description
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Flattermarken
This is a special "barcode" used for recogniz-
ing the correct sequence of pages in print-
shops.

GS1 DataBar (RSS-14)

GS1 DataBar is used to encode the GTIN 
(Global Trade Item Number) with Application 
identifier (AI) "01". The GTIN consists of a 
packaging indicator (0..9) followed by a 12 
digit number (taken from the EAN-13 article 
number system) followed by a check digit. 
The check digit on the 14th position is com-
puted automatically if not provided in the 
input data

Subtype

Standard

The height of the symbol should be at least 
33X in order to support omnidirectional 
scanning (X = module width). TEC-IT software 
prefixes the barcode data with the AI "01" 
automatically - do not provide the AI 01 with 
your input data.

Truncated
This symbology is similar to GS1 DataBar but 
the height should be at least 13X. Omni-
directional scanning may not be possible.

Omni Directional
This symbology is similar to the GS1 DataBar 
Stacked and supports omnidirectional scan-
ning.

Stacked

This symbology is similar to GS1 DataBar, but 
it is split into 2 rows to make the symbol 
smaller. It is used for pharmaceutical pack-
aging. Omni-directional scanning is not pos-
sible.

GS1 DataBar Limited
This symbology is similar to GS1 DataBar, but 
it is smaller in size and limited to a packaging 
indicator (first digit) 0 or 1.

GS1 DataBar Expanded

This is a variable length symbology. It 
encodes up to 74 numeric or 41 alphabetic 
characters. Data should be encoded with 
Application Identifiers (AIs). Omni-direc-
tional scanning is possible.

Han Xin Code

Han Xin Code is a 2D matrix symbology which 
is used for encoding large amounts of data 
and provides a special support for encoding 
Chinese characters (character set GB18030)

Group Property Values Description
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HIBC

HIBC bar codes are commonly used by the 
health industry. HIBC standards do not really 
describe unique symbologies, but a family of 
data structures. These data structures may 
be represented by several symbologies.
There are two categories of HIBC:
"Label Identification Code (LIC) - specified by 
the Supplier Labeling Standard
"Provider Applications Standard (PAS)

ISBN

ISBN is the abbreviation of International 
Standard Book Number. It uses the symbol-
ogy EAN-13 and can be optionally extended 
with 5 Add-On Digits. The add-on is used for 
additional pricing information. For more 
information, please refer to http://
www.isbn.org

ISMN

ISMN stands for International Standard 
Music Number. The ISMN is a standardized 
international code, which identifies printed 
music.
The ISMN is preceded by the digits 9790. The 
ISMN (=EAN-13) check digit is calculated and 
appended automatically!
For more information, please refer http://
www.ismn-international.org/.

ISSN

ISSN stands for International Standard Serial 
Number. The ISSN is a standardized interna-
tional code, which identifies any serial publi-
cation independently of its country of origin, 
its language or alphabet, or its frequency, 
medium, etc.
The ISSN is preceded by the digits 977. The 
check digit of an 8-digit ISSN code (the last of 
the 8 digits) must be omitted! A two digit 
price code, almost always "00", is added to 
the end. Finally the EAN-13 check digit is 
added.
Optionally the issue number can be 
appended as 2-digit add-on.For more infor-
mation, please refer to http://www.issn.org

Italian Postal
Italian Postal Code 2 of 5 is based upon Code 
2 of 5 Interleaved, but it is limited to 12 digits 
(11 usable digits + 1 modulo 10 check digit).

Group Property Values Description
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Japanese Postal

This code is used by the Japanese Postal sys-
tem. You can encode 7 digits followed by 
block and street number (uppercase alpha-
numeric). The special compaction mode of 
Japanese characters can be enabled on 
demand (Format parameter "J"). This barcode 
symbology supports two methods to provide 
the barcode data (with and without data-
extraction from the Japanese Address B 
Field).

KIX This code is used by the Dutch Postal system

Korean Postal Authority
This code is used by the Korean Postal sys-
tem. Encoded are a 6-digit ZIP and 1 check 
digit.

MaxiCode

MaxiCode is in use (and was invented) by 
UPS®.
MaxiCode represents data by drawing hexag-
onal items, which are arranged around a cir-
cular center (a so called "Bull's Eye"). Different 
encoding modes for including postal infor-
mation (SCM) can be adjusted: UPS Modes 
are Mode 2 (US Carrier) and Mode 3 (Interna-
tional Carrier).
The printing size is usually set to a fixed 
value. If you want to change the size of the 
symbol, adjust a custom module width 
(default is 0.870 mm).

Subtype

Mode 4 - SEC / Standard 
Error Correction

The internal data structure is regulated by 
different "modes". For standard purposes, 
data can be encoded with two different error 
correction levels.

Mode 5 - EEC = 
Enhanced E.C.

Mode 2 - SCM numeric The modes for "Structured Carrier Message" 
(SCM) were defined by the parcel transport 
service UPS®. If you want to use MaxiCode 
for UPS, please use these SCM modes.

Mode 3 - SCM alphanu-
meric

MicroPDF417

This stacked 2D symbology is used to encode 
large quantities of data. The input data is 
always analyzed and the appropriate encod-
ing mode is chosen automatically. Mode 
switching is done as required to produce the 
most efficient encoding.

MSI

The MSI-Code is a variant of the Plessey-
Code. MSI uses various check digit calcula-
tion methods - Lighter implemented the 2 
most common used.

Group Property Values Description
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NVE-18

NVE stands for "Nummer der Versandein-
heit" (a German term for tracking number). 
This code uses an EAN-128 symbology with a 
prefixed Application Identifier (AI) 00. The AI 
"00" is inserted automatically and must not 
be included in the input data. It is similar to 
SSCC-18.

Pharmacode This code was invented by Laetus®. It is used 
in pharmaceutical areas.

Subtype

One-Track

The data for the bars/spaces is encoded 
directly in the property Text:

• “0" is used for a narrow bar (the 
width of these bars are enlarged 
after a color change, according to 
ratio 1C)

• "1" is used for a wide bar (the 
width of these bars are enlarged 
after a color change, according to 
ratio 2C)

• "b" is used for a narrow bar
• "c" is used for a wide bar

Two-Track

Pharmacode assigns numeric values to the 
bars. It is used for medicine packing in phar-
maceutically area; for small labels. Usually 
Pharmacode is printed without a human 
readable text.

Placet This code was developed for the United 
States Postal Services

Subtype
12 It is a 3-of-5 variant of the Postnet barcode.

14 It is a 3-of-5 variant of the Postnet barcode.

Plessey

Plessey code is in use primarily in libraries. It 
is a pulse-width modulated code and was 
developed by Plessey Company Limited in 
UK. The basic encoding principle in Plessey 
Code was used by MSE Data Corporation to 
construct its MSI barcode. The check digit is 
calculated with a polynomial CRC algorithm 
and is always part of the symbology.

PZN Germany

PZN uses Code 39 as the base symbology. It 
uses a special check digit and the human 
readable text always contains the prefix 
"PZN-" (which is not encoded in the barcode 
data).

Group Property Values Description
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Royal Mail

This code is a height modulated code using 4 
different vertical bars. It is used in mass-
mailing applications (Cleanmail, Mailsort) of 
the Royal Mail, United Kingdom and Singa-
pore (also called SinPost barcode). Encoded 
are ZIPs.

SSCC

SSCC-18 is used for encoding the Serial Ship-
ping Container Code. It is used for the unique 
identification of trade items world-wide. 
SSCC-18 is based on the GS1-128 symbology 
with Application Identifier (AI) 00. The check 
digit is encoded automatically if 17 digits are 
used for the input data.

Telepen
Telepen can encode pairs of characters only. 
A pair must consist of 2 digits or of one digit 
and the letter 'X'.

Group Property Values Description
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USPS United States Postal Services

Subtype

Intelligent Mail®

This symbology is also known as
• OneCode 4CB
• USPS 4CB
• 4-CB
• 4-State Customer Barcode
• USPS OneCode Solution Barcode.

Intelligent Mail® Package

The barcode data consists of Routing Infor-
mation and Tracking Information. The Rout-
ing Information is optional. It is not printed in 
the human visible text and consists of:

• Postal Code Application Identifier (AI): 
always 420

• Destination ZIP Code (5 or 9 digits)

Postnet 5

Encoded are a 5 digit ZIP-code. The check 
digit is calculated automatically. It cannot be 
specified in the input data.
The barcode height should be adjusted to 3.2 
mms; the module width to 0.423 mms; usu-
ally no plain text is displayed.
The newer USPS Intelligent Mail®Barcode or 
IM® Barcode (4-State Customer Barcode) 
additionally includes a 20 digits tracking 
code.

Postnet 6

Same as Postnet 5, but the check digit can be 
specified freely (the 6th digit). To be used 
only if the check digit is already part of the 
input data.

Postnet 9

Encoded are a 5 digit ZIP-code and 4 addi-
tional digits.The check digit is computed 
automatically, it cannot be specified in the 
input data.
The barcode height should be adjusted to 3.2 
mms; the module width to 0.423 mms; usu-
ally no plain text is displayed.
The newer USPS Intelligent Mail®Barcode or 
IM® Barcode (4-State Customer Barcode) 
additionally includes a 20 digits tracking 
code.

Group Property Values Description
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Postnet 10

Encoded are a 5 digit ZIP-code and 4 addi-
tional digits.The check digit is computed 
automatically, it cannot be specified in the 
input data.
The barcode height should be adjusted to 3.2 
mms; the module width to 0.423 mms; usu-
ally no plain text is displayed.
The newer USPS Intelligent Mail®Barcode or 
IM® Barcode (4-State Customer Barcode) 
additionally includes a 20 digits tracking 
code.

Postnet 11

Encoded are a 5 digit ZIP-code and 4 to 9 
additional digits. The check digit is calculated 
automatically. It cannot be specified in the 
input data.
The barcode height should be adjusted to 3.2 
mms; the module width to 0.423 mms; usu-
ally no plain text is displayed.
The newer USPS Intelligent Mail®Barcode or 
IM® Barcode (4-State Customer Barcode) 
additionally includes a 20 digits tracking 
code.

Postnet 12

Same as Postnet 11, but the check digit can 
be specified freely (the 12th digit). To be used 
only if the check digit is already part of the 
input data.

VIN/FIN

VIN/FIN Code is used for vehicle identifica-
tion. It is based on Code 39, but does not con-
tain start and stop characters. The set of 
valid characters consists of digits and upper 
case letters. The letters "I", "O", and "Q" are 
not allowed because they could be easily 
mixed up with the digits "0", and "1".
VIN/FIN Code is implemented differently in 
Europe and North America. Both kinds are 
compatible but the North American version 
is defined more strictly. So the check digit 
calculation method is only valid for the North 
American implementation of the code.

Group Property Values Description
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UPC
Linear bar code with multiple thickness. It is 
a self-checking, numeric code. Checksum 
required.

Subtype
A If selected, the code can contain up to 10 digit 

numeric.

E If selected, the code can contain up to 6 digit 
numeric.

Text String True or False If it is set to True, displays and marks the 
human readable string.

Datamatrix

Two-dimensional matrix code consisting of 
black and white square modules arranged in 
either a square or rectangular pattern.It can 
encode up to 3,116 characters from the 
entire ASCII character set (with extensions).

Subtype

t mode The standard format of Data Matrix without 
a special header.

UCC/EAN/GS1 mode

Special format defined by UCC and EAN/GS1 
for encoding Application Identifiers. This for-
mat adds the function character FNC1 at 1st 
position in the symbol.

Industry mode Supports peculiar industry formats (adds 
FNC1 at 2nd position)

Macro 05 mode [)>Rs05Gs is encoded at the beginning of the 
code, RS + EOT is added as trailer

Macro 06 mode [)>Rs06Gs is encoded at the beginning of the 
code, RS + EOT is added as trailer

Reader Programming Activate the Reader Programming Mode.

DP Postmatrix Special format defined by "Deutsche Post".

Size

This property allows setting the Datamatrix 
size to fix the code dimension. (For further 
information, see Setting the data restoring 
capability).

Square Best Fit Sets the smaller squared dimension accord-
ing the information to be encoded.

Rectangular Best Fit Sets the smaller rectangular dimension 
according the information to be encoded.

10x10 to 48x16

Allows specifying a dimension that ranges 
from 10x10 to 48x48 modules for the 
squared size, and from 18x8 to 48x16 mod-
ules for the rectangular size.

Group Property Values Description
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QRcode
Quick-Response (QR) code is a two-dimen-
sional matrix code. Large capacity, small 
printout size, high speed scan.

Size

This property allows setting the QRCode size 
for redundancy purposes. Each version has a 
different number of modules. (For further 
information, see Setting the data restoring 
capability).

Best Fit Sets the smaller dimension (21x21) for the 
information to be encoded.

Version 1 to 40 Allows specifying a dimension that ranges 
from 21x21 to 177x177 modules.

Error level

Level L 7% of codewords can be restored

Level M 15% of codewords can be restored

Level Q 25% of codewords can be restored

Level H 30% of codewords can be restored

Group Property Values Description
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PDF 417

Portable Data File 417 (PDF417) is a multi-
row, variable length, stacked linear bar code. 
It has high data capacity and high density 
and is widely used in the automotive indus-
try.
A data density of up to 900 characters per 
square inch is possible.
The input data is always analyzed and the 
appropriate encoding mode is chosen auto-
matically.
Mode switching is done as required to pro-
duce the most efficient encoding.

Subtype Standard It has control bars on both left and right 
sides.

Truncated It omits the right-hand portion in order to 
save space.

Size 1 to 30 columns Sets the number of data columns for the 
symbol.

Error level

This property allows setting the error correc-
tion level for the code, which allows restoring 
data if the code is dirty or damaged. To each 
level corresponds a higher data redundancy 
and a different restoration rate. PDF 417 
uses Red Solomon error correction. (Default: 
Recommended). For further information, see 
Setting the error correction level.

Recommended This value varies depending both on the 
specification and the code size.

0 to 8 Allows specifying a level that ranges from 0 
to 8. The recommended minimum level is 2.

Group Property Values Description
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RSS 14(GS1 DataBar) Stacked linear barcode. RSS 14 (Reduce 
Space Symbology) is a linear symbology that 
facilitates omnidirectional scanning. It 
encodes 14 digits of numerical data

Subtype

Standard

Omnidirectional It allows the full height RSS-14 (see above) to 
be printed in two rows.

Truncated The height is reduced to a 13X minimum.

Stacked This is a RSS-14 Truncated two-row format.

RSS Limited(GS1 DataBar)
Stacked linear barcode. It encodes a 14-digit 
EAN.UCC item identification with Indicator 
digits of 0 or 1 in a small symbol.

RSS Expanded(GS1 DataBar)
Stacked linear barcode. Can carry up to 74 
numeric or 41 alphanumeric data characters 
in a single row.

Size 1 to 11 lines Sets the number of lines for the symbol.

MicroQRcode

Two-dimensional barcode. This is a smaller 
version of the QR Code standard that fits 
applications that require a smaller space and 
use smaller amounts of data.

Size

This property allows setting the MicroQR-
Code size for redundancy purposes. Each 
version has a different number of modules 
and a higher data redundancy. (Default: M2) 
For further information, see Setting the data 
restoring capability.

Best Fit Sets the smaller dimension (11x11) for the 
information to be encoded.

Version M1 to M4 Allows specifying a dimension that ranges 
from 11x11 to 17x17 modules.

Error level

This property allows setting the error correc-
tion level for the code, which allows restoring 
data if the code is dirty or damaged. To each 
level corresponds a higher data redundancy 
and a different restoration rate. (Default: M).

O Only for M1. Only error detection.

L 15% of codewords can be restored.

M 25% of codewords can be restored.

Q 30% of codewords can be restored.

Group Property Values Description
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Module
Width Sets the width of the module (in a linear bar code this is the smallest 

thickness; in a 2D code, is the smallest square).

Height Sets the height of the module for linear bar codes. (Not available for 
Datamatrix, QRcode and MicroQRcode).

Advanced

Black/White 
ratio

It allows adjusting the ratio between white and black elements when 
marking very small elements. In this case, the spot laser might affect the 
dimensional ratio. The default value is 100%. For further information, see 
Balancing the black and white ratio.

Print ratio

Only available for 2/5 and 3/9 Codes. In two thickness codes, it is the 
ratio between the thickness of the wide element and that of the narrow 
one. The higher the ratio, the bigger the symbol, which impacts on the 
scanner's reading capabilities. Default: 200.

Reverse True or False

If it is set to True, enables the bar code 
engraving in reverse. Reverse bar code 
engraving should only be done on those 
materials where the laser marks white or 
black. The bar code standard does not 
include reverse coding.

Quiet zone

Visible only if Reverse is set to True. Immediately preceding the start 
character and following the stop character is an area of no markings 
called the quiet zone. The quiet zone helps the scanner find the leading 
edge of the bar code so reading can begin.

Bytes Enco-
dation

This option allows the interpretation of the text property as a bytes 
stream, wherever the text is Unicode only the lower bytes are used.

Counter

The Counter group enables creating a variable text that includes an incremental counter 
(see Making a text string to include an incremental counter).

Start The minimum value for the counter.

Stop The maximum value for the counter.

Current The current value of the counter as it appears in the string.

Step Increment value (positive or negative).

Cycles The number of times the counter will be marked before it is incremented 
by one step.

Digit The minimum number of digits to be displayed.

Custom For-
matters

Formatters are source files that are supplied with Project Editor. These files can be used 
as functions libraries. Their purpose is to make it easier for developers to create custom 
applications. For example, as an integrator, you might need specific functions that these 
libraries provide. Formatters have a .qs extension and are stored in the folder 
...\Data\Formatters.

True or False Enable or Disable the use of a Custom Formatter file

Script Visible only if Custom Formatters is set to True. Use to select the Custom 
Formatters from a list of available files.

Group Property Values Description
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Verification

Accordingly with ISO /IEC TR 29158 that includes the AIM DPM-1-2006, seven quality 
parameters or Metrics have been defined. The knowledge of the meaning of each quality 
parameter may be helpful in laser marking process tuning. Each quality parameter is 
classified into grades from A to F, and OVERALL is defined as the lowest result among all 
the parameters or metrics.

True or false Enable or disable the use of the Verification.

Overall 
Grade

Allow to selects an overall grade to apply to all metrics or choose the cus-
tom metrics.

Custom Met-
rics

Cell Contrast This parameter measures the differences 
between the mean brightest and the mean 
darkest values of the symbol.
'In laser DPM the creation of background of 
the code (quiet zone) with low power settings 
is extremely effective to boost the contrast.

Cell Modulation

Cell modulation analyzes the uniformity of 
the contrast inside the code extension.
'In laser DPM this defect is usually refers to 
local non-uniformity of the material surface 
(i.e. finishing quality, dust, oil...) incorrect 
marking distance or tilted/curved marking 
surfaces.

Axial Non-Uniformity
This parameter measures and grades the 
modules' squareness in the direction of each 
of the symbol's major axes (X-axis and Y-
axis).
'In laser DPM applications this metric is typi-
cally affected by off-axis marking (tilted sur-
faces vs laser marking axis) but also off- axis 
reading (skewed reader vs target surface).

Unused Error Correction
Data Matrix incorporates an error correction 
mechanism and data redundancy .This 
parameter tests and grades how much 
redundant data had to be used during read-
ing to decode the data content. A perfect 
mark that requires no error correction would 
achieve a UEC score of 100% that results in 
grade A.

Print Growth
Measures the deviation of actual elements 
dimension from the expected element 
dimension due to printing problems (i.e. 
overprint or underprint).

Group Property Values Description
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Minimum Reflectance

Determines the degree to which the object 
reflects light.
Accurate tuning of laser parameters like 
power, speed and repetition rate dramatically 
influence this quality parameter.

Fixed Pattern Damage

This metric checks the fundamental charac-
teristics of the code (quiet zone around the 
code, "L" finder and clocking patterns, and 
reference dots).
Poor results on this metric may reduce the 
capability to locate and read the code.
As for "Cell Contrast", the use of a smooth 
uniform background as a quite zone reduces 
the risk of low grade FPD.

Grid Non-Uniformity This parameter measure and grades the 
module placement by comparing to a nomi-
nal evenly spaced grid. Assuming a grid on 
which the ideal angle of intersection is 90°, 
any angle deviation from 90° constitutes 
Grid Non-Uniformity

Group Property Values Description
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Using Arrays

The array object is used to mark repetitively an object (or a group of objects) in 
different positions, allowing you to customize both the layout and the elements 
arrangement.

Graphic objects are included in cells that you can customize to suit your needs.

The array object is especially tailored to Integrated Circuits (IC) chips marking.

By using the Array toolbar button or the Actions menu, Laser Editor allows you 
to create an array.

You might use the mouse to resize and move the array, or to select/deselect 
cells; you can use the Properties window to set dimensions and number of cells 
and to define their content, as well as misalign or change the distance between 
cells.

Notes

The following sections describe how to work with arrays:
• Adding an array
• Setting the number of cells
• Resizing arrays or cells
• Changing the distance between cells
• Cells misalignment
• Selecting/Deselecting one or more cells
• Creating the contents of individual cells
• Array and cells properties

Clicking a properties title in the Properties window and then 
pressing F1, opens a table with a description of those proper-
ties.
For further information on mouse operations, refer to section 
Using the mouse to select and manipulate objects.
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Adding an array
To add an array:

• Create a plane document to enable the insertion of the object (see Creat-
ing a document for plane engraving).

• Do one of the following:
• On the vertical toolbar click on the  Insert objects button and then, in 

the horizontal toolbar that is displayed, click on  Array.
• From the Laser Editor menu bar, choose Actions > Insert > Array.

• The Array is displayed in the work area. By default, the whole array is 
selected and contains 9 cells. Use the Properties window to set the array 
and cells parameters; use the mouse to resize or move the array, as well as 
to select individual cells. See the topics list here below to get more infor-
mation.

Notes
Clicking a properties title in the Properties window and then 
pressing F1, opens a table with a description of those proper-
ties.
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Setting the number of cells
The Columns and Rows properties of the Array object, allow you to set the 
number of row and columns that compose the array to obtain any number of 
cells.

To set the number of cells that compose an array:
• Click on the array to enable the Properties window.
• Under Array, select the boxes beside the Columns and/or Rows properties 

and enter the desired number.
• The array changes accordingly. You might need to resize both the array 

and the cells to fit the new settings. (See Resizing arrays or cells).

Resizing arrays or cells
The Dimensions and Cells size properties allow you to resize the objects as 
needed.

Notes

To resize the objects:
• Click on the array to enable the Properties window.
• To resize the array: Under Geometry > Dimensions, set the Width and 

Height properties as you want. (You can also use the mouse: with the 
object selected, drag the handles that surround it  to the 
desired position.)

• To resize the cells of the array: Under Array > Cell size, set the Width and 
Height properties as you want.

For information on other Array's general properties, select the 
Geometry title and press F1 to display the relevant Help topic.
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Changing the distance between cells
The Pitch and Extra Pitchs properties, allow you to increase or decrease the dis-
tance between rows, columns, individual cells and/or group of cells.

Notes

To change the distance between rows and/or columns:
• Under Array > Pitch, set the following properties:

• X - Sets the distance between columns.
• Y - Sets the distance between rows.

To change the distance between cells or groups of cells:
You can group cells and define additional distances between them, both hori-
zontally and vertically.

• Under Array, select the Extra Pitchs property and enter the number of 
instances, that is, the number of extra-distances you want create. The 
properties that allow setting the extra pitches are displayed below.

• Set the properties values as follows (see the example below, also):
• Group - Enter the number of cells that you want to include in the group 

to be moved.
• First - Enter the number of the first column you want to apply the extra 

pitch to.
• Pitch - Specify the size for the additional distance.
• Direction - Select the desired direction: Y direction will add the distance 

between rows, X direction will add the distance between columns.
The picture below shows how the array looks after setting the properties as fol-
lows:

• Repeat step 2 for any other extra pitch you want to add.

To enable the Properties window, click on the array object.
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Cells misalignment
The Interleave properties allow you to change the alignment of rows and/or 
columns.

To change the alignment of cells:
• Click the array to enable the Properties window.
• Under Array, select the Interleave > Offset property and enter the mis-

alignment measurement.
• From the Direction dropdown list select the desired direction:

• X - Sets the misalignment between rows.
• Y - Sets the misalignment between columns.

The picture below shows how the array looks after setting the properties as fol-
lows:
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Selecting/Deselecting one or more cells
You can operate on individual cells by unlocking the array and selecting the 
desired cell(s).

To select/deselect individual cells:
• Select the array and then click the pushpin-shaped handle  at the top 

left. The handle changes to  and the cells in the array becomes unlocked 
allowing you to select them:

• To select one or more cells, do one of the following:
• Click one or more cells. (You can select as many cells as you want).
• Right-click a cell to display a menu that allows to select/deselect all 

cells, or to invert the selection between selected and deselected cells.
• Click the rows or columns blue indicator to select/deselect the whole 

row or column.
• When a cell is selected and enabled, its colour changes to bright yellow. 

(To deselect a cell, click on it).
• Furthermore, in the Properties window, under Array, the new Cells group is 

displayed that allows you to:
• enable/disable one or more cells
• define custom offset settings and rotation
• link a document to the cell (see Creating the contents of individual cells).

Notes

• Click the  mouse handle to lock the cells and operate on the whole 
array. 

Notes

When a cell is disabled, its colour changes to light yellow.

For further information on mouse operations, please refer to 
Using the mouse to select and manipulate objects.
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Creating the contents of individual cells
You can enter any content into individual cells to compose your layout, as well 
as define custom offset settings and rotation. You can create a document with 
graphics or strings, and then link the document to a cell.

To create the contents of a cell:
• Click the array and then click the pushpin-shaped handle at the top left 

:
• Click to select the desired cell(s). The colour of the selected cell(s) changes 

to bright yellow. Note that all cells are named Plain 0.
• You might set a different Plain number: In the Properties window, under 

Array > Cells, select the Linked Plain property and enter a Plain ID. The 
Plain number of the selected cell changes accordingly:

• Double-click the cell. A new document representing the Plain, with the 
same ID number, opens. (By default, it would be 0, as the selected cell).

• Enter any object you need, as you would do in a plain document. (See Cre-
ating a document for plane engraving and About graphic objects).

• When your layout is done, from the Laser Editor menu bar, choose File > 
Save to save the plain as an .xlp file.

• Return to the array.
• Select the cell(s) to which you want to link the Plain you have just created. 

(You might select an entire row or an entire column by clicking on the blue 
indicator).

• In the Linked Plain property, enter the number of the Plain that you have 
created. (See step 3, above).

The cells will be dynamically filled with the contents of the linked plain when 
sending the array to laser engraving. (See Performing The Engraving Operation).



116 Lighter™ Suite

• You can set custom properties for a cell using the Cells properties. The 
settings appear on the cell, as illustrated below:

Note that, as the Rotation angle for the cell has been set to 160, the small black 
indicator has been moved accordingly, to indicate the rotation. (See Array and 
cells properties for more information).
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Array and cells properties
The Properties window supports context-sensitive Help: During layout editing, 
selecting a properties title (for example, Geometry), and then pressing F1, 
opens the context Help for those properties.

The following properties appear when an Array object is selected in the work 
area.

Notes
Refer to section Using Arrays for further information on how 
to use properties to perform specific operations on the object.

Array group Property Description

Columns Sets the number of columns for the array.

Rows Sets the number of rows for the array.

Cells size
Width Sets the width for all cells into the array.

Height Sets the height for all cells into the array.

Pitch
Width Specifies the distance between columns. You can increase or 

decrease the distance.

Height Specifies the distance between rows. You can increase or decrease 
the distance.

Interleave

Offset Sets a misalignment between rows or columns.

Direction
Specifies the direction for the misalignment:

• X - Sets the misalignment between rows.
• Y - Sets the misalignment between columns.

Extra Pitchs

Group Represents the number of cells to be considered for the extra pitch.

First Indicates the first column to which the extra pitch will be applied.

Pitch Sets the additional distance.

Direction
Sets the direction for the extra pitch:

• Y direction will add the distance between rows.
• X direction will add the distance between columns.

Increment 
Counter

Rows/Columns Determines whether the counter increase is done by rows or col-
umns direction.

Left to Right or 
Right to Left

Determines whether the counter increase is done by Left to Right or 
Right to Left direction.

Top to Bottom or 
Bottom to Top

Determines whether the counter increase is done by Top to Bottom 
or Bottom to Top direction.

On Disabled Cells Determines whether the counter increase is done even by Disabled 
Cells or not.
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Cells

This group of properties is displayed only after selecting one or more individual cells. (See 
also Creating the contents of individual cells).

Offset
Sets the marking offset for the selected cell(s):

• X - Sets the horizontal offset
• Y - Sets the vertical offset

Enabled Enables/disables the selected cell(s)

Rotation Applies a rotation angle to the selected cell(s).

Linked Plain

Allows linking a document with specific contents to the selected 
cell(s). Double-clicking the cell will result in a document opening with 
the same Plain ID as the selected cell. You can treat it as a document 
and then link it to as many cells of the array as you want. (For 
detailed instructions, see Creating the contents of individual cells).

Array group Property Description
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Importing graphic objects

By using the Imported toolbar buttons or the Actions menu, Laser Editor allows 
importing two dimensional graphics.

Supported file formats
Laser Editor allows importing and editing the following graphic formats:

• Vectorial:
• HPGL 1/2 (.PLT and .HPGL) - Vectorial formats were originally con-

ceived plotters treating, so they include plotter's specific features (such 
as, the line width), which the laser does not consider. Please note that 
there is not an automatic adjustment of the spot laser as the plotter's 
pen changes.

• AutoCad DXF - Two dimensional vectorial graphic exchange format that 
was originally developed by Autodesk, and then disclosed to the public. 
However, it is still maintained by Autodesk that periodically updates it.

• AutoDesk DWG - Vectorial graphic format licensed by Autodesk. It is a 
file format used for storing two and three dimensional design data and 
metadata. It is the native format for several CAD packages.

Notes

• Image files (bitmap):
• BMP, is the standard format for bitmap graphics. It can be generated 

with any graphic application, from digital cameras or scanners.
• GIF, is a format similar to BMP. It can be generated with any graphic 

application, from digital cameras or scanners.
• JPG, is one of the most common compressed bitmap formats. A BMP 

image converted into JPG has a much smaller (in bytes) dimension.
• PNG, is an extensible file format for the lossless, portable, well-com-

pressed storage of raster images, that is, PNG files are compressed bit-
maps.

• TIF, a common format for exchanging raster graphics (bitmap) images 
between application programs, including those used for scanner images.

• Laser documents (.XLP) - Engraving graphic layouts generated by Laser 
Editor.

For AutoCAD .DXF and .DWG graphic formats, new filter con-
figuration options have been added that allow selecting how 
to process the file. For further information, see Setting the Fil-
ter Options (.DWG and .DXF files).
For all vectorial objects, new advanced processing options 
have been added that allow the automated editing of vectors. 
For further information, see Using Advanced Processing 
options.
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You can use the Properties window, the toolbars tools, or the mouse to resize, 
move, rotate, and transform the imported graphic so as to fit the object to be 
engraved.

Notes

The following sections describe how to work with imported graphics:
• Raster graphics vs. Vectorial graphics
• Importing a file into Laser Editor
• Setting the Filter Options (.DWG and .DXF files)
• Using Advanced Processing options
• Imported graphics properties

For information on mouse operations, see Using the mouse to 
select and manipulate objects.
For information on how to operate on graphics, please refer to 
Common operations on objects.
Clicking a properties title in the Properties window and then 
pressing F1, opens a table with a description of those proper-
ties.
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Raster graphics vs. Vectorial graphics
Laser Editor allows editing and importing two dimensional vectorial graphics 
and also importing and editing bitmap graphics created with other applications.

About raster graphics
(.bmp, .gif, .jpg, .png, .tif)
Raster graphics describe images using coloured dots, called Pixels, located 
within a grid. The image is described by the specific position and colour of 
every pixel in the grid, and the creation process is very similar to that of a 
mosaic.
When you edit a raster graphic, the pixels are edited rather than the lines and 
curves. The raster graphics change with resolution, as the data which describes 
the image is fixed in a grid with specific dimensions. Editing raster graphics can 
change their quality. In particular, resizing may make the edges of the image 
irregular since the pixels within the grid are redistributed. In addition, display-
ing raster graphics on an output device with a lower resolution in relation to the 
image reduces the display quality.

About vectorial graphics
(.plt, .hpgl, .dxf, .dwg)
Vectorial graphics describe the images using lines and curves, called vectors, 
which all include properties related to color and position. The image is 
described by points through which lines pass, creating the form of the outline. 
(Note that laser engraving is monochromatic.)

Raster vs. Vectorial marking
Raster
The raster engraving technique allows marking a vectorial object as if it were a 
raster object. The image is split into rows and rows are marked sequentially, as 
the laser brushes the image across the surface in a back-and forth slowly-
advancing linear pattern that reminds one of an inkjet or similar printer.
The laser moves at a fixed speed and the level signal modules continuously 
according to the "darkness" of the pixel being drawn. This technique can be 
performed only on materials whose response changes deeply with the power of 
the investing beam; polycarbonate and PVC can behave this way with the use of 
proper additives, while metal cannot. In general, raster engraving on plastic 
cards produces best results.
In laser engraving, a raster graphic is slower in engraving and less defined in 
terms of outline lines and filling. It can be used, with appropriate conversions, 
for engraving digital photographs.
Vectorial
In vectorial marking, the laser follows the lines and curve of the pattern to be 
engraved, much like a pen-based plotter draws by constructing line segments 
from a description of the outlines of a pattern. It traces all vectors, regardless 
of how the object is being scaled.
In laser engraving a vectorial graphic is faster in engraving and more defined in 
terms of outline lines and filling. A vectorial graphic cannot be used for engrav-
ing digital photographs.
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Importing a file into Laser Editor
To import a file:

• Create or open a document to enable the insertion of objects (see Creating 
Graphic Layouts and Opening existing layouts).

• Do one of the following:
• In the horizontal toolbar, click on  Imported. (If this button is not visi-

ble, click the  Insert Objects button on the vertical toolbar).
• From the Laser Editor menu bar, choose Actions > Insert > Imported.

• The Choose a file to import window is displayed. From the Files of type 
dropdown list, choose the file you want. (See Supported file formatsfor 
more information).

• Select the file you want to import. The image is displayed in the work area.

Notes

• Using the Properties window, the mouse, and the toolbars, you can do the 
following:
• Move or resize the object (see Common operations on objects)
• Edit bitmaps properties (see Imported graphics properties)
• Link an imported file to the layout (see Linking the imported file)
• Fill it with filler lines (only if the lines of the imported object are closed) 

and perform other operations on graphics (see Common operations on 
objects)

• Use advanced processing functions to edit nodes of vectorial graphics 
(see Using Advanced Processing options)

Notes

Linking the imported file
The Linked property allows specifying the full path of the imported file. This 
way, at any document's loading, the program looks for the original file into the 
specified path and, if it does not find it, uses the internal copy that was created. 
If the original file has been changed, or updated, the document is also updated.

• Select an imported object in the work area.
• In Properties window, under Imported, set the Linked property to True.
• The Linked file property is displayed that shows the full path of the 

imported file. To change the path, use the browse button.

When you select the .DWG or .DXF file formats (AutoCAD 
files), the Filter Configuration window will be displayed for you 
to select how to process the file to import. See Setting the Fil-
ter Options (.DWG and .DXF files).

For a quick-reference on using toolbars in Laser Editor, see 
Using toolbars tools.
Clicking a properties title in the Properties window and then 
pressing F1, opens a table with a description of those proper-
ties.
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Setting the Filter Options (.DWG and .DXF files)
When you import a .DWG or .DXF file into the laser editor, that is, an AutoCAD 
file, the Filter Options window displays for you to select how to process the file.
Imported AutoCAD files can be strings that use specific and proprietary fonts, 
which might not be available in your system. Using these options you can fix 
this issue, as well as process the layers of the original file as groups of editable 
objects.

To set the filter options:
• Click the  Imported icon in the toolbar and then select AutoCAD DXF/

DWG files as the File Type.
• Select the file to import and click Open. The following window is displayed:

• Select the proper options, taking in mind that:

• Import string as vectors
If it is set to False (default) strings will be imported as strings. In this case, 
if the original font is not available, an error or a warning could be 
returned. To fix this problem, use the Default font option and specify a 
default font.
If it is set to True, strings will be imported as pure vectorial objects, that 
is, they will not be strings objects anymore.

• Default font - It allows selecting from the dropdown list the font that 
must be used if the original one is not available.

Notes

Review the import result for problems.
Import the object again setting Import as vectors to True.

If you imported the strings as strings (Import strings as vec-
tors = False), and set a Default font other than the original, the 
resulting layout might shows differences in terms of space or 
objects alignment. To fix this type of problem, do the follow-
ing.
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Compare the results and change the font properly, until achieving the 
desired result. If necessary, import the required font in your system (see 
Importing fonts).

• Process layers as groups - Typically, AutoCAD files are composed by 
more layers each containing different information. For example, in a 
mechanical drawing, the notes might be on a layer, while technical data 
might reside on other layers. If this option is set to True (default), the 
layers will be transformed into groups of objects, which will be grouped 
layer by layer. This allows managing and operating on layers, as well as 
adding specific properties.

• When finished, click OK. The object will appear on your document.
• To edit the vectors in an automated way, see Using Advanced Processing 

options.
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Using Advanced Processing options
The Advanced Processing options provide vectorial processing functions that 
allow editing vectors in an automated way. It is used if the original document 
does not satisfy your marking requirements, or if it shows graphic problems 
that result in marking imperfections.
You can make vectorial the imported object so as to check its polygons and 
then use these functions to fix problems such as not closed or double poly-
gons, before sending the document to mark.
These functions are available for vectorial objects (.PLT, .HPGL, .DXF, .DWG).

Step 1 - Make the object vectorial and check nodes:
• Select the imported object and then do one of the following:

• From the menu bar, choose Actions > Make vectorial.

• On the vertical toolbar, click  Object operations and either click  
Make vectorial or  Ungroup selection in the horizontal toolbar.

• 2.Double-click the object to display the vectors nodes, and then check if 
polygons are properly closed or if there are double lines that overlap each 
other. (For further information on how to open, view, and edit nodes, see 
To edit the nodes:).

The following shows an example of a .DXF imported file that shows these type 
of imperfections. On the left you see the object as it was imported, while on the 
right the same object has been made vectorial, as above described:
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At a first sight, it does not show problems. But if you open the nodes, by drag-
ging the small grey squares, problems will appear:

These problems will result in marking imperfections.

Notes

• In such a case, you can use the Advanced Processing functions to edit 
polygons automatically.

Step 2 - Automatically edit vectors to correct imperfections:
• Select the object and then do one of the following:

• From the Actions menu, select Advanced Processing.

• On the vertical toolbar, click  Object operations and then  
Advanced Processing.

The following will be displayed:

There are three options that you can use in association:
• Sort Edges & Close Polygons - It operates on areas: it tries to locate 

areas that are enclosed into polygons and then close them eliminating 
any double line.

• Join Open Polylines - It operates on the distance between nodes and it 
tries to close them at the maximum distance. That is, it tries to join 
polygons that are near enough and then close them.

 To exit the Edit nodes operating mode press ESC.
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• Split in Polygons - It allows dividing a vectorial object into individual 
polygons. This is particularly suitable in the case of an imported object 
that is made of more polygons, placed on different layers: using this 
option you can see how objects are grouped on each layer, ungroup 
them, and then operates on polygons separately.

Example of usage
Let's take our example of imported object above to describe how the Advanced 
Processing options can be used in association to fix all problems.

• Select the object and then from the Actions menu, select Advanced Pro-
cessing (or click  Object operations on the vertical toolbar, and then  
Advanced Processing).

• Apply the first option Sort Edges & Close Polygons, which, by operating on 
areas, should remove any double or not closed polygons.

However, the result is still not as expected as it shown in the following picture:

• Click  Undo, or press CTRL+Z, to cancel the operation.
• From the Actions menu, select Advanced Processing again and then apply 

the second option Join Open Polylines.
• Apply a filling: From the Filling properties dropdown list, select Single line:
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• It seems working, but let's check the nodes: Click  Undo to cancel the 
filling, make the object vectorial by double-clicking and check the nodes:

As you can see in the example above, there are still double polygons, which 
would result in marking problems if you apply, for example, the Islands filing, 
which requires perfectly closed and well prepared polygons.

• Try it: From the Filling properties select Islands and then select Mark Pre-
view from the File menu. This is how the marking would result:

• Press ESC to exit the Mark preview mode and then click  Undo to cancel 
the filling.

• From the Actions menu, select Advanced processing.
• Apply the first option again, Sort Edges & Close Polygons to remove all 

double lines.
• Make the object vectorial by double-clicking it and check the nodes again. 

All nodes will now be closed and double lines will not exist anymore.
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• To check the marking results, apply the fillings again and then select Mark 
preview from the File menu. The following pictures show the results of 
both fillings:

Marking result with Single line filling

Marking result with Pocketing filling
The object will now be marked as expected, showing closed and well-oriented 
polygons.
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Imported graphics properties
The Properties window supports context-sensitive Help: During layout editing, 
selecting a properties title (for example, Geometry), and then pressing F1, 
opens the context Help for those properties

Notes

Group Property Description

Image

Brightness It allows adjusting the brightness of a bitmap.

Contrast It allows adjusting the contrast of a bitmap.

Resolution It allows changing the resolution of the image, expressed in dots per 
inch.

Reverse

If it is set to True, specifies the reverse engraving for the imported 
bitmap:

Video Mode

Gray tones - Converts the image in dithering to gray tones. (Default)

Half tones - Converts a grayscale image to simulated halftone dots. 
Halftones varies the size of halftone dots to simulate shading.

Error diffusion - Converts a continuous tone image into a frequency 
modulated halftone.

Imported
Linked

If it is set to True, allows specifying the full path of the imported file; 
it is the path that the program will search whenever the document is 
loaded. (See Linking the imported file).

Linked file Shows the full path of the linked file. You might change the path.

Refer to section Common operations on objects for further 
information on how to use properties to perform specific 
operations on the object.
Refer to section Importing graphic objects for more informa-
tion on imported objects.
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Using the tiling function
Notes

The Tilable geometry property is used when marking indivisible objects on a 
rings separator, that is, on a cylindrical surface.
Typically, when marking on a ring document, the laser focuses on a ring por-
tion (sector) to mark.
In some applications the object to mark can be longer than the sector itself. For 
example, in jewellery you might need to mark the manufacturer logo, or the cli-
ent's name on a wedding ring. This might result in deformations.
By applying the tiling function:

• The object is separated into its constituting polygons.
• If a polygon its larger than the sector and it is closed (otherwise, the func-

tion won't work). it will be "sliced" into portions whose size is equal to the 
ring's sectors to be marked.

This way, the object will be marked as if it were an individual sector, thus 
resulting in high precision marking.
The Tilable property is used in association with the Sector size and Sector gap 
Advanced properties of the ring document, how it is described in the example 
in the following.

Example of tiling usage
The following example describes how the software operates when using the til-
ing function and how the ring's Sector size and Sector gap properties are to be 
set, accordingly to your specific needs.

• Open a Ring document by selecting File > New >  Ring document.
• Let's suppose that we must import the logo of a jeweller. So, click  and 

import the file.
• As the Text string property, type the date and then set the desired Font, 

Style, and Filling properties. Then, set to True the Tilable property under 
Geometry:

• Deselect the string and set the Sector Size and Sector Gap properties for 
the document in order to define the sectors properties:

• Set the properties according to your needs, keeping in mind that:

The Tilable property is only available when editing vectorial 
objects on ring documents. (For further information, see Cre-
ating a document for ring engraving)
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• The Sector Size property defines the width of the sector, that is, the por-
tion to be engraved within a single movement of the rotating axis. The 
object will be divided into sectors whose size is equal to the sector's 
maximum size, which it is based on the laser's depth of focus.
The 0 value (default) provides a high level of quality. A single movement 
will be made for each polygon and the polygon will be centered in its 
belonging sector.
With tilable objects, you might set a value smaller than 0 for high preci-
sion needs. Note that smaller value results in longer marking time.

• The Sector Gap property allows to further fine tune the tiling operation.
If it is set to 0 (default) only one cut will be used for both the left and 
right objects.
If the value is lower than 0, two cuts will be used, to either overlap the 
polygons (left and right borders), or to leave a space between them.
Note that this setting is based on the laser's depth of focus, as well as on 
the mechanical precision of the rotor.

• Save your layout.
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Understanding objects colour in the work area
The objects in the work area can take on different colours, depending on their 
status or characteristics, as illustrated in the picture:

Colour Meaning

Red The graphic object is NOT correctly placed within the graphic area. A red 
colored object will NOT be engraved correctly.

Blue

The graphic object is correctly placed within the graphic area and is enabled 
for engraving. Its engraving parameters are NOT the standard ones of the 
document; special laser engraving parameters have been set which are only 
relative to this object (see Custom Laser parameters for Objects). There can 
be various blue coloured objects within the graphic area; their laser param-
eters may differ from each other.

Grey
The graphic object is correctly placed within the graphic area but is NOT 
enabled for engraving and will NOT be engraved. (The Enable property in 
the property browser is set to False).

Black The object is correctly placed within the graphic area and is enabled for 
engraving. Its engraving parameters are the standard ones of the document.
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Using global variables
Notes

Purpose of the functionality
Global variables are strings or counters that are stored in a small database at 
the device level. You can then use special character sequences to access a 
global string or counter variable and share its content between more objects or 
documents. (See also Using special character sequences).
For example, you can use the same counter in as many strings as you need, or 
refer a global string variable in any number of document(s).
To summarize, this function offers the following main advantages:

• A counter is not only strictly associated to a string, anymore. You can cre-
ate a counter that is common to more strings and that is managed at the 
machine level.

• You do not longer need to create a specific program for each document to 
be engraved in order to increment a counter.

• A centralized database, managed by Laser Engine, is provided. You can 
use it to store, view, or edit global variables either remotely, via the Laser 
Editor user interface, or through a project, in order to update or edit them 
at runtime.

• Variable contents (for example the current number for a counter) are not 
yet strictly connected to a specific document file. As an example, counters 
are automatically updated after each use. Users do not need to take care of 
saving them anymore: You can turn off the machine, or edit the document 
and, the next time the machine is turned on, the counter will be incre-
mented accordingly to the value that was previously reached.

For further information on global variables management, see:
• Adding, viewing, or editing a global variable
• Using special character sequences to associate global variables to a string

In order to view and manage global variables, you must be 
connected to the laser device. For further information, see 
Connecting to the laser device.
This function is also accessible at the Laser Engine interface 
level. For further information, please see Laser Engine User 
Interface.
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Adding, viewing, or editing a global variable
Follow this procedure to add, view, or edit global variables. You will then be 
able to associate them to objects by using special character sequences.

• Be sure that you are connected to the laser device (see Connecting to the 
laser device).

• Do one of the following:
• From the Laser Editor menu bar, choose Laser > Edit device global vari-

ables.

• On the Laser Editor toolbar, click  Edit device global variables.
• The Device variables is displayed for you to add or manage variables 

remotely.

To add a global variable:
• In the Device variables window, do the following:

• Click on Add new counter to add a counter variable type.
• Click on Add new string to add a string variable type.

The new variable will be added in the table using the default parameters.
• To edit the parameters, select the variable and then double-click the field 

you want to change. Use the following table as a reference:

Table 3 Global Variables Parameters

Field Description

Counters

Variable The unique identifier for the counter. This is the name that is to be used 
into the special character sequence to refer the counter.

Value
The current value of the counter. This value will be displayed when the 
global variable is referenced into a string object through the appropriate 
special character sequence.

Start The minimum value for the counter.
Stop The maximum value for the counter.
Step The increment value (positive or negative).

Cycles The number of times the counter will be marked before it is incremented by 
one step.

Cycles Count

It allows keeping track of the number of markings that have been executed 
within the required Cycles number. This parameter is reset to 0 when the 
number of engravings has been reached and the Counter has been incre-
mented.
(It only applies if the Cycles parameter has been set to a value other than 1).

Digits The minimum number of digits to be displayed.



136 Lighter™ Suite

The figure below shows an example, where one counter and two strings vari-
ables have been added:

Figure Device Variables dialog

• When you are finished, click Apply and then OK to close the dialog and 
return to Laser Editor.

The global variable will be saved to the device and stored into the Laser Engine-
managed database. You will then be able to retrieve it from Laser Editor, in 
order to check or edit it.

Base

The numeral system that the Counter will use to represents the numbers. 
The following values are allowed:

• 2 - The marked number will be converted to binary form. Binary uses 
only 2 digits (0 and 1) and is also called base-2. The value 10 in base 2 
will be marked 1010.

• 8 - The marked number will be converted to octal form. Octal uses 8 
digits which are 0,1,2,3,4,5,6,7 and is also called base-8. The value 10 
in base 8 will be marked 012.

• 10 - The number will be marked in decimal form. Decimal has 10 digits 
which are 0,1,2,3,4,5,6,7,8,9 and is also called base-10. The value 10 
in base 10 will be marked 10.

• 16 - The number will be marked in hexadecimal form. Hexadecimal is 
made up of 2 parts which are hex(6) and decimal(10) which are 
0,1,2,3,4,5,6,7,8,9,A,B,C,D,E,F. It is also called base-16. The value 10 
in base 16 will be marked 0A.

Strings

Variable The unique identifier for the string. This is the name that is to be used into 
the special character sequence to refer the string.

Value The content of the variable, that is, the text string.

Field Description
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To view, edit, or delete an existing global variable:
You can use Laser Editor to display a global variable that has been saved to the 
device, so as to be able to check or edit the values.

• Be sure that you are connected to the laser device (see Connecting to the 
laser device).

• Press the  Edit device global variables button on the toolbar to make the 
Device variables dialog appearing that lists the variables that are currently 
stored on the device.

• Do one of the following:
• To edit the parameters, select the variable and then double-click the 

field you want to change. Use Table Global Variables Parameters as a 
reference.

• To delete a global variable from the Laser Engine database, select the 
variable and then click on Delete counter(s) or Delete string(s), depend-
ing on which variable type you are deleting. Click Yes to confirm your 
choice.

• When you are finished, click Apply and then OK to close the dialog and 
return to Laser Editor.
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Using special character sequences to associate global variables to a 
string

Follow this procedure to associate a global variable (string or counter) to one or 
more strings. You can associate the same variable to strings that belong to dif-
ferent documents. (See also Adding, viewing, or editing a global variable).

To associate a global variable to a string:
• Add a string to the document and then select it (see Adding a Text string).
• In the Properties window, under String, enter in the Text box the desired 

special character sequence, depending on which global variable you are 
using. It can be a string, a counter, or both (see the example here below):
• %v[stringname] or %V[stringname] - Where stringname is the name that 

you have assigned to the global variable string when you created it (that 
is, the Variable field of the Device variables dialog). V forces the upper-
case.

• %v[countername] - Where countername is the identifier that you have 
assigned to the global variable counter when you created it (that is, the 
Variable field of the Device variables dialog).

Notes

• Press Enter. The string changes to the specified format. When the string is 
sent to marking, the counter increments accordingly to the parameters 
that were specified when creating the variable.

Example
In the example shown below, we have associated the same counter with two 
different strings that are located into different documents. After sending to 
marking the two documents, at the laser device level the global counter has 
incremented.

• In the following figure, a string object has been associated with global 
variables string1 (value: Marking) and counter1 (see figure Device Vari-
ables dialog).

Note that the variablename value is case sensitive, so be sure 
that you type it exactly as you did in the Device variables dia-
log.
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• In the following figure, a second string object, which is located in a differ-
ent document, has been associated with global variable string2 (value: 
Laser Editor) and to the same global variable counter1.

• After sending the two documents to marking, the global counter has 
incremented, as you can see in the Device Variables dialog box here 
below:
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Common operations on objects
This section describes all the operations that you can execute on graphic 
objects either by using the mouse, or the Properties window, or the toolbars 
buttons.

Topic

Using the document's grid

Enabling/disabling objects

Using the mouse to select and manipulate objects

Copying, pasting, cutting, or removing objects

Aligning, flipping or spacing objects

Grouping, merging, or joining objects

Editing objects vectors

Zooming

Specifying the filling patterns

Setting the origin of an object

Optimizing the objects marking order

Calculating the marking time

Marking preview
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Using the document's grid
The document's grid is a series of traced lines which intersect. They can be 
used to precisely align and position objects in the drawing window.
The distance between lines in the grid can be set by specifying the spacing in 
the document property browser. (For further information on how to create doc-
uments, see About documents).

To customize the grid:
• Deselect any object in the work area to display the Properties window for 

the document. By default, under Geometry, the Grid property is set to 
True, meaning that the grid is enabled.

• To set the exact distance between lines, enter the desired value as the 
Step. By default, this value is set to 10,00. Enter a lower value to align and 
position objects with greater precision.

• To snap to grid objects, set the Snap to grid property's value to True. This 
way, objects will be moved and aligned to the closest grid line.

Enabling/disabling objects
In order to be marked, an object must be enabled in the layout. By default, each 
object that you add to a document is enabled.

To disable an object:
• Select the object in the graphic area to display its properties.
• In the Properties window, under Geometry, set the Enable value to False.
• The object is still displayed in the graphic area, but its colour changes to 

gray to indicate that it is disabled and it will not be marked.
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Using the mouse to select and manipulate objects
You can select and operate on objects by using the mouse.
Besides selecting objects, the mouse allows for quick, rough sizing and posi-
tioning.

Notes

What you can do with the mouse:
• Selecting object(s)
• Moving, resizing, or locking objects
• Skewing and rotating objects
• Editing nodes

Selecting object(s)
To select a single object:

• Click to select an object. When the object is selected, it appears as follows:

The  symbol represents the center of the selection and corresponds to 
the origin that has been set for the object (see Setting the origin of an 
object). Note that the Property browser lists the properties for the selected 
objects.

• You can use the handles that appear around the object to move or resize 
the object. (See below).

• To deselect an object, click on a blank area of the document.

To select multiple objects:
Do one of the following:

• Drag with the mouse to select multiple objects.
• Hold down CTRL while clicking on the desired objects.
• You can use the handles that appear around the selected objects as if it 

were a single object. (See below).

For extremely precise resizing, positioning, or skewing, use 
the objects Geometry properties in the Property browser. (See 
Geometry properties for Objects).
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Moving, resizing, or locking objects
When you have selected an object, you can use the mouse to change its posi-
tion in the document, as well as to resize it. You can also lock it so as to prevent 
any change.

To move an object:
• Select the object.
• When the mouse pointer changes to a cross , left-click and move the 

object to the desired position in the document. (Note that the Geometry 
properties of the object are affected).

To resize an object:
• Select the object.
• Position the pointer over a handle until the pointer changes to the same 

shape as the handle, then left-click and drag to resize the object.
• Use the following as a reference:

Object handle Mouse pointer You can

Drag to resize the object.

Drag down to change the height of the object.

Drag left or right to change the width of the object.

To lock/unlock an object:
• Select the object.
• Click the  handle. The moving and resizing handles disappear and the 

pushpin changes to the  shape. This prevents the object from being 
changed.

• To unlock the object, click the  handle.
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Skewing and rotating objects
You can double-click an object so as to enable the skewing and rotating han-
dles.

To rotate an object:
• Double-click the object(s). Note that the handles look as follows:

• Position the pointer over the  handle until the pointer changes to a 
cross, then left-click and drag up or down the handle to rotate the object.

To skew an object:
• Position the pointer over a handle until the pointer changes to the same 

shape as the handle, then drag to skew the object.
• Use the following as a reference:

Object handle Mouse pointer You can

Drag to resize the object.

Drag down to change the height of the object.

Editing nodes
You can use the mouse to edit the nodes of a vectorial object.

To edit nodes:
• Double-click a vectorial object. The object's outline becomes green-col-

ored and the  Edit nodes toolbar appears.
• Position the pointer over a polyline until the pointer changes to a cross, 

then click to display the nodes.

Please refer to section Editing objects vectors for further information.
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Copying, pasting, cutting, or removing objects

You can use either the standard toolbar buttons, the Edit menu, or the shortcut 
keys to copy, paste, or remove objects from the graphic area.

Notes

To copy and paste an object:
• Select the desired object(s) in the graphic area. Do one of the following:

• From the standard toolbar, click the  Copy button and then the  
Paste button.

• From the Laser Editor menu bar, choose Edit > Copy and then Edit > 
Paste.

• Press Ctrl+C and then Ctrl+V.
• The copy is pasted on top of the original object. Drag to move it.

To cut an object:
• Select the desired object(s) in the graphic area. Do one of the following:

• From the standard toolbar, click the  Cut button.
• From the Laser Editor menu bar, choose Edit > Cut.
• Press Ctrl+X.

• You can then paste the object.

To remove an object:
• Select the desired object(s) in the graphic area. Do one of the following:

• From the standard toolbar, click the  Remove button.
• From the Laser Editor menu bar, choose Actions > Remove object(s).

• The object is removed from the document.

Drag with the mouse to select multiple objects if you want to 
copy, paste, or remove them in a single operation.
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Aligning, flipping or spacing objects

You can use the Adjust objects toolbar or the Actions menu to quickly align, 
flip, space, and dimension graphic objects. Most of these functions are only 
enabled if more objects are selected in the graphic area. In particular, the spac-
ing tools are only enabled if at least three objects are selected.

To adjust graphic objects:
• On the vertical toolbar, click  to display the Adjust objects horizontal 

toolbar. (All commands are also available from the Actions menu).
• Use the following table as a reference:

Button Description

Align left - Select at least two objects, then click this button to align all objects to the leftmost 
one.

Align top - Select at least two objects, then click this button to align all objects to the top-
level one.

Align right - Select at least two objects, then click this button to align all objects to the right-
most one.

Align bottom - Select at least two objects, then click this button to align all objects to the low-
est one.

Align center X - Select at least two objects, then click this button to align all objects along the 
X axis.

Align center Y - Select at least two objects, then click this button to align all objects along the 
Y axis.

Flip horizontally - Select one or more objects, then click this button to flip the object(s) hori-
zontally. If you select more objects, they will be flipped both individually and in relation to 
each other.

Flip vertically - Select one or more objects, then click this button to flip the object(s) vertically. 
If you select more objects, they will be flipped both individually and in relation to each other.

Space horizontally - Select at least three objects, then click this button to space objects the 
same distance apart horizontally.

Space vertically - Select at least three objects, then click this button to space objects the 
same distance apart vertically.

Make same size - Select at least two objects, then click this button to make them the same 
size.

Make same width - Select at least two objects, then click this button to make them same 
width.

Make same height - Select at least two objects, then click this button to make them same 
height.

Restore transformations -Reverses any change you have made, that is, restores the selected 
object(s) to its original size or orientation.
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Grouping, merging, or joining objects

You can use the Objects operations toolbar or the Actions menu to assemble 
objects in the graphic area so as to form a single object, as well as to edit 
object nodes, either manually or using the advanced processing functions (see 
Editing objects vectors).
The assembling functions are only enabled if more than one object is selected 
in the graphic area.
These tools can be used on all objects. However it is not possible to merge or 
intersect bitmap pictures.

In particular:
• The Group and Merge tools allow assembling objects, either if they overlap 

or not, into a single object so they can be moved or transformed as a 
group. Single objects keep their properties. The Ungroup tool can be used 
to reverse the grouped object back to individual objects.

• The Union, Intersection, Difference, and Exclusion tools allow assembling 
vectorial objects so that their constituting polygons are merged into a new 
vectorial object. You can edit vectors. The Undo button can be used to 
reverse the operation. The filling properties of the resulting object is taken 
from the first selected one. If this filling can't be applied to all the objects 
in the selection, it is taken from the next one. If none of these fillings is 
possible, it will be the first one from the common filling list. Other options 
are disabled by the user interface.

To use the grouping tools:
• Select more objects in the graphic area.
• On the vertical toolbar, click  to display the Objects operations horizon-

tal toolbar.
• Select the desired toolbar button. (All commands are also available from 

the Actions menu). The following table shows examples of how tools are 
used:

Grouping tool Result

In this example, we have two overlapping objects. The 
black star is the first selected object.
We drag the mouse to select both objects.
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 Group selection
As a result, the two stars are assembled in a single object 
so that they can be moved or transformed as a group. The 
single objects keep their individual properties, as well as 
their custom laser and filling properties.
The outline of the overlapping area will be marked twice.

Use the  Ungroup selection button to disassemble the 
grouped object into individual objects so each can be 
moved or changed individually.

 Merge selection
As a result, the two stars are assembled in a single object 
so that they can be moved or transformed as a group. The 
single objects keep their individual properties, with the 
exception of the laser and filling properties.
This button can be disabled if the selection contains a ras-
ter object, an array or if the fillings of the objects have no 
common acceptable values. The merged object takes the 
filling and outline attributes according to these rules in 
this order:

• The filling and the outline of the first selected object 
(the black star) if all the selected objects allow such 
parameters.

• The filling and the outline of the first object in the list 
whose parameters are in the intersection parameter 
list of all objects.

• If none of the filling or the outline already set for the 
objects are in the intersection parameter list and this 
list is not empty, the first filling in the list is applied.

Vectorial data that compose the objects are merged into a 
single object. In this case, the common area will not be 
considered when engraving.

Use the  Ungroup selection button to disassemble the 
grouped object into individual objects so each can be 
moved or changed individually.

Grouping tool Result
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 Union Selection
As a result, the two vectorial objects are assembled into a 
single object, that is, their constituting polygons are 
merged into the new vectorial object. Individual objects 
loose their custom properties.
The new object is vectorial: double-click it to display the 
nodes and the Edit nodes toolbar that allows editing the 
vectors (see Starting nodes editing for further informa-
tion).

To disassemble the group, you must either use the  
Undo Union toolbar button or the Undo/Redo command 
list.

 Intersection Selection
As a result, the objects are assembled into a new single 
vectorial object whose vectors are different from those 
that compose the original objects.
Note that only the area that is common to the overlapping 
objects will be considered for the engraving.
The new object is vectorial: double-click it to display the 
nodes and the Edit nodes toolbar that allows editing the 
vectors (see Starting nodes editing for further informa-
tion).

To disassemble the group, you must either use the  
Undo Union toolbar button or the Undo/Redo command 
list.

 Difference Selection
As a result, the objects are assembled into a new single 
vectorial object whose vectors are different from those 
that compose the original objects.
Note that only the outline of the first selected object, 
minus the area that was shared with the second object, 
will be marked.
The new object is vectorial: double-click it to display the 
nodes and the Edit nodes toolbar that allows editing the 
vectors (see Starting nodes editing for further informa-
tion).

To disassemble the group, you must either use the  
Undo Union toolbar button or the Undo/Redo command 
list

Grouping tool Result
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 Exclusion Selection
As a result, the objects are assembled into a new single 
vectorial object, that is, their constituting polygons have 
been merged into the new vectorial object.
Note that the common area has been removed. The out-
lines of the two objects will be marked, minus the com-
mon area. From the engraving point of view, the result is 
the same as the Merge tool, but this object is vectorial: 
double-click it to display the nodes and the Edit nodes 
toolbar that allows editing the vectors (see Starting nodes 
editing for further information).

To disassemble the group, you must either use the  
Undo Union toolbar button or the Undo/Redo command 
list.

Grouping tool Result
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Editing objects vectors

In vectorial graphics the image is described by points through which lines pass, 
creating the form of the outline.
Besides resizing a vectorial shape using the handles (see Using the mouse to 
select and manipulate objects), you can enter the node editing mode and move 
control points or nodes around so as to make changes to the shapes. (See 
About nodes and control points).
Laser Editor allows adding simple vectorial objects to your layout (see Working 
with simple vectorial objects), and provides the Make vectorial function for you 
to make any string or code a pure vectorial object. This way, you can edit their 
shape by manipulating control points and nodes, either using the mouse or the 
Edit Nodes toolbar.
In laser engraving a vectorial graphic is faster in engraving and more defined in 
terms of outline lines and filling. A vectorial graphic cannot be used for engrav-
ing digital photographs.
See the sections that follow:

• About nodes and control points
• Making an object vectorial
• Starting nodes editing

Notes If you are working with elaborate objects (for example, 
imported drawings), consider using the Advanced Processing 

function (  button), also available from the Actions menu, 
which provides an automated way to edit vectors. See Using 
Advanced Processing options.
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About nodes and control points
When you double-click a vectorial object, nodes appear, as small boxes con-
nected by green lines. You can then drag the node, or edit the type of node 
using the Edit Nodes toolbar: for example, you can make a node symmetric or 
asymmetric (see Starting nodes editing). When you do this, a line with two small 
circles at the ends will appear over the node. These are called control points.
The figure below shows an example:

The type of node determines the behaviour of polylines before and after the 
node.
Note that the control point defines two points through which the polyline 
passes. The position of the control points in relation to the node defines which 
type of node you are working with (symmetric, asymmetric, or angular). You 
can drag the small circles to change the shape.
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Making an object vectorial
This function allows making vectorial a string or a code, so that you can enter 
the editing nodes mode and change or deform their shape as you need. Note 
that, when a string is made vectorial, it loses its specific string's properties to 
become a pure vectorial object.

To make an object vectorial:
• Select the object you want to make vectorial. (You can also operate on 

grouped objects.)
• Do one of the following:

• From the Laser Editor menu bar, choose Actions > Make vectorial.

• On the vertical toolbar, click  and then click  Make vectorial in the 
horizontal toolbar.

• To enable the edit nodes function, click the . Edit nodes button (or 
double-click the vectorial object). This will result in the Edit nodes hori-
zontal toolbar being displayed and in the color of the lines changing to 
green.

• Click the object to display a small square vertex handle at each vertex of 
the shape's boundary. These are the nodes that you can use to edit the 
shape:
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Starting nodes editing
To edit vector shapes, you must go into node editing mode. This is done in two 
ways:

• by double-clicking a vectorial object
• by selecting the vectorial object and then clicking the . Edit nodes but-

ton
You can use the mouse to drag the nodes or you can use the Edit nodes toolbar, 
as it is described below. For further information on how to make a string or a 
code vectorial, see section Making an object vectorial.

To edit the nodes:
• Click a node(s) to select it 

Select multiple nodes by holding down the Ctrl key while clicking the nodes you 
want to select.

Notes

• The following table provides several examples using the Edit nodes tool-
bar:

If you select multiple nodes, you can move them simultane-
ously.

Action Result

Click  Angular nodes to create an angular node so that 
you can manage separately the two control points.

Click  Asymmetric nodes to make a node that allows 
you to manage an individual control point. To change the 
shape, drag the control point.
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Click  Symmetric nodes to make a node that allows 
you to move simultaneously and symmetrically the two 
control points. To change the shape, move a control point.

Select multiple nodes and click  Join nodes to manage 
them as a single node. Click away from the shape to return 
to the original situation.

Click  Break path to take the selected node and break it 
in two at that point. Where one node was, there are now 
two unconnected nodes. The nodes can now be moved 
independently of one another.

Select two nodes and click  Delete path to delete the 
polyline between them.
Use the Join segment button to draw a polyline connecting 
two separated nodes.

Action Result
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• To add a node to a segment, point to the border of the segment until the 
pointer changes to a cross and then double-click-it:

• To remove a node, click the node and press the Delete key.
• Click on the  Insert objects button to close the Edit nodes operating 

mode.
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Zooming

By changing the zoom, it is possible to display the whole graphic area on the 
screen or a greatly enlarged detail of a particular part. The maximum zoom 
depends on the screen resolution and the dimensions of the graphic area.
To zoom objects, you can use the Zoom dynamic toolbar or the View menu of 
Laser Editor.

To zoom or reduce objects in the graphic area:
• On the vertical toolbar, click the  Zoom button. The horizontal zoom 

toolbar is displayed.
• Use the toolbar buttons to change the zoom as required:

• To gradually zoom the work area, use the  Zoom in button as many 
times as you want. Use the  Zoom out button to gradually reduce the 
zoom.

• To zoom a certain element, select the element and then click the  
Selection button. This button is unavailable if no object is selected in the 
graphic area.

• To revert to the standard view, click  Page.

• To zoom a specific area in the drawing, click the  Window button and 
then trace a rectangular window around the perimeter. Laser Editor sets 
the zoom level so that the specific rectangle fills the window.



158 Lighter™ Suite

Specifying the filling patterns
You can specify different filling patterns for objects, that is, filling the object 
with filler lines. To this purpose, the Filling properties in the objects Properties 
window are used. (See Filling properties for Objects).
The figure below shows some examples:

Notes

To set the filling properties:
• Select the object in the graphic area. The properties for the object are dis-

played in the Properties window.
• Select from the Filling property dropdown list the desired pattern. (By 

default, this value is set to None, meaning that no filling is set for the 
object).

• More properties are displayed below that allow customizing the filling pat-
tern. Refer to section Filling properties for Objects for a complete descrip-
tion of each property.

The Filling properties do not apply to Arrays or Imported Ras-
ter images.
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Setting the origin of an object
The origin is a point that defines the position of the object into the engraving 
area. This origin relates to the point of origin of the document's engraving area 
(see Geometry properties - Layer, Origin property).

The origin is represented by the cross symbol : By default, this symbol is 
placed in the centre of the object.
Laser Editor allows changing this property for any object to better fit your spe-
cial engraving requirements.

To set the origin of an object:
• Select the object in the work area for which you want to set a point of ori-

gin other than Center.
• In the Properties window, under Geometry, select the desired value from 

the Origin dropdown list.
• Note that the cross symbol moves accordingly. The following example 

shows an object whose origin has been set to Center Top in a document 
whose point of origin is set to Center:

• You can specify the object's position by setting the X and Y coordinates. 
(Refer to Geometry properties for Objects for a description of each prop-
erty).
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Optimizing the objects marking order
Laser Editor has a function that sets automatically the marking order of the 
objects that compose your layout for optimal performance.
In other words, the system orders the objects to be engraved so as to minimize 
the path of the spot laser between objects, resulting in a shorter marking time.

To optimize the objects engraving order:
• When your layout is composed and ready for engraving (see Creating 

Graphic Layouts), do one of the following.
• From the Laser Editor menu bar, choose Actions > Marking order.

• On the vertical toolbar, click  Adjust buttons and then click  Mark-
ing order in the horizontal toolbar.

• The Optimizing marker order window is displayed, showing the operation 
progress.

• When finished, note that the objects order in the Objects engraving order 
pane, has changed. See picture below:
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Calculating the marking time
Laser Editor allows you to calculate the marking time of your graphic layout, 
that is, how long the engraving operation will take.
The marking time is determined by the level of detail that you add to the 
objects that compose the layout. If you can't exceed a specific marking time, 
consider removing some details.

Notes

To calculate the marking time:
• Create your engraving layout (see Creating Graphic Layouts).
• There are two possible scenarios:

• If the marking time for the layout is less than 30 seconds, the Marking 
time button on the toolbar shows the expected time automatically. For 
example:

• If the marking time for the layout exceeds 30 seconds, in order to calcu-
late the estimated time, you must click the  button.

Keep in mind that this is an approximate value that is just 
intended to help you in calculating the time. The actual mark-
ing time depends also on the specific device you are using, as 
well as on its settings.
To view the final results of your marking, besides calculating 
the marking time, see Marking preview.
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Marking preview
The Mark preview function allows you to check the final result of the marking 
process of your layouts directly in Laser Editor.
When selecting this option, the Mark preview window shows both the lines that 
the laser will actually mark, according to the filling you specified, and the 
marking time. This way, you can precisely verify the time that the process will 
take and the result that you will obtain, such as, for example, if lines are placed 
equidistantly apart.
The drag and drop function allows you to move layout's objects around the 
work area.

Notes

To mark a preview:
• Create your layout. (See Creating Graphic Layouts).

The following shows an example of string object:

Note that the Cross lines Filling property is applied.
• Do one of the following:

• From the File menu, select Mark preview.

• From the Laser Editor standard toolbar, click the  Mark Preview but-
ton that is made available after opening or creating a document.

The following window is displayed:

The Mark preview windows shows exactly how the lines will be marked.
• Use the zooming bar the right side to further check the results, and the 

drag and drop function to move items.
• If needed, edit your layout so as to achieve the desired result.

An object: with functionality for mark preview is available at 
scripting level also. Programmers can create their own user 
interface including a preview of the document to be engraved. 
For further information, see the Project Editor online docu-
mentation, chapter "Language Reference"..
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Chapter 4
Performing The Engraving Operation

This chapter is divided into the following sections:

Topic

Setting custom laser parameters
• Using more engraving runs
• Using the wobble function to engrave with thicker lines

Displaying the limits

Simulating the marking operations

Connecting to the laser device

Send marking
• Auto Mode vs. Manual Mode
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Setting custom laser parameters
The engraving parameters must be set before engraving the graphic layout. 
Correct engraving parameters are essential to ensure engraving quality. When 
setting laser parameters you should consider the laser source you are using, 
the material to mark, and the required process.

Engraving parameters can be the same for all graphic objects: by default, each 
graphic object uses the laser parameters properties of the document. However, 
you can set different laser parameters for each object; this will result in the 
object's colour changing to blue.

To set laser properties for all objects:
• Create or open a document (see About documents). Be sure that no object 

is selected in the work area.
• In the Properties window, under Geometry, set the Laser properties as 

required. Please refer to section Laser properties for documents for infor-
mation on how to set the parameters.

To set laser properties for individual objects:
• Select the object(s) in the document. (See About graphic objects).
• In the Properties window, set to True the Custom Laser property.
• Set the properties that appear as required. Please refer to section Custom 

Laser parameters for Objects for information on how to set the parame-
ters.

Note that, after editing, the object's colour changes to blue.

For further information, see:
• Using more engraving runs
• Using the Wobble function to engrave with thicker lines
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Using more engraving runs
The Laser properties allow you to set the number of runs of the laser light on 
the object to engrave. You might set up to 3 passages, each with different laser 
parameters.

This option may be particularly useful to make several light engraving runs to 
clean the workpiece after a more incisive engraving process. 

Warnings

To set more passages:
• Click a blank area on a document (to set the parameters for all objects), or 

select an individual object (see To set laser properties for individual 
objects:).

• In the Properties window, under Laser (or Custom Laser for an object), 
select the number of Passages, that is, the number of runs of the laser 
light (1 to 3). The parameters for each passage will be displayed allowing 
you to set different parameters.

• Set the other parameters as required. Please refer to section Custom Laser 
parameters for Objects for information on how to set the parameters.

Be sure to select the best parameters according to the mate-
rial used and the required processing type. To carry out a good 
cleaning run, it is important that the speed is the same as an 
engraving run.
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Using the Wobble function to engrave with thicker lines
Wobble is a function integrated in Laser Editor that allows engraving the single 
lines of vectorial graphics, either True Type characters or imported figures, with 
thicker lines.
Normally, the line thickness corresponds to the dimension of the laser spot. If 
you need to increase this thickness, you can use the wobble function.
The two figures below represent the functioning principle of the wobble:
The figure on the left shows the result of a vector engraving with the wobble 
disabled, while the figure on the right shows the same vector but with the wob-
ble enabled:

The conversion of the vector into a dense spiral provides greater thickness of 
the engraved line.
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To enable the wobble function:

Notes

You can enable the wobble function either at a document or at object level. To 
do so, you can use the Laser (or Custom Laser) > Wobble property.

• To enable the wobble function, do one of the following:
• Create or open a document (see About documents), then, in the Proper-

ties window, under Laser, set to True the Wobble property. This will be 
the default setting for all objects that you add to the document.

• Select the object (see About graphic objects), then, in the Properties 
window, set to True the Custom Laser property and then the Wobble 
property.

• Specify a value for the Radius property, that is, the radius of the spiral 
curve to be used.

• Specify a value for the Speed property, that is, the frequency of spiral rep-
etition.

• Use the Simulator tool to verify the result of the Wobble function: from the 
Laser Editor menu bar, choose Laser > Simulator:

Note that the single line character has a much thicker outline. The same result 
would be obtained with real engraving.

The wobble function configuration parameters must be tested 
and checked in order to obtain the desired effect. Engraving 
times with the Wobble function are longer, only use the Wob-
ble function when absolutely necessary.
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Displaying the limits
This function refers to displaying the margins of the drawing on the work plain. 
Margins are displayed using a red laser pointer.
Limits function displays the bounding box of the object(s) that will be engraved: 
this result is obtained by driving head scanners to move along the box path at a 
fast speed.
In order to use this function you must be connected to the device and the Man-
ual Mode must be activated. In Auto Mode this function is not available (see 
Auto mode vs. Manual mode).

Notes

To display the limits:
• Be sure that you are connected to a device (see Connecting to the laser 

device) and that you have activated the Manual Mode (otherwise, the Limits 
buttons are unavailable). To activate it do one of the following:
• Select  Switch to Manual Mode on the toolbar.
• From the Laser Editor menu bar, choose Laser > Switch to Manual Mode.

Notes

• Do one of the following:
• To see the engraving limits for one or more specific objects, select the 

object(s) and click on  Limits on selection on the toolbar. (Alterna-
tively, choose Laser > Limits on selection from the menu bar).

• To see the engraving limits for the whole graphic area, click on  Lim-
its all on the toolbar. (Alternatively, choose Laser > Limits all from the 
menu bar).

• To see the engraving limits for the sectors that compose the object 
when engraving on a ring document, click on  Limits previous sec-
tor and Limits next sector buttons on the toolbar. The buttons become 
available (green coloured) after pressing either the Limits on selection or 
Limits all button. (Alternatively, choose Laser > Limits next sector and 
Limits previous sector from the menu bar)

For further information on the laser pointing parameters that 
are used to display engraving limits, see Setting custom laser 
parameters.
These functions are also accessible at the Laser Engine inter-

face level through the  Start limits and  Limits previous/
next sector menu buttons.
For further information, see Laser Engine User Interface.

This is a toggle button: if the Manual Mode is activated, the 
tooltip says Switch to Auto Mode, and vice versa.
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The example below shows how the limits for a sheared word (Editor) would 
appear.

Related topics:
• Setting custom laser parameters
• Simulating the marking operations
• Connecting to the laser device
• Send marking
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Simulating the marking operations
Laser Editor can be used to simulate the engraving results, that is, when you are 
finished creating the layout, you can test the engraving via a video graphic sim-
ulator before sending it to the device for marking.

Notes

If you are not connected to a device, pressing F5 or Send Marking (which would 
otherwise start the laser engraving), results in a graphic window being dis-
played, which simulates the engraving operation. The simulation maintains all 
the speed, filling, wobble or other parameters set in the document.

Notes

To verify the final result of your layout, as well as its marking 
time, you can use the Mark preview function (menu File > 
Mark preview). For further information, see Marking preview.

The simulation can only be done in Manual Mode. In Auto 
Mode the feature is not available and the laser engraving is 
managed automatically through the Laser Engine (see Auto 
mode vs. Manual mode). Note that, when in Auto Mode, the 
Simulator button is pressed meaning that the device is work-
ing in simulation.



Simulating the marking operations

User Guide                            171

To simulate the engraving:
• Be sure that you have activated the Manual Mode. To activate it do one of 

the following:
• Select  Switch to Manual Mode from the toolbar of Laser Editor.
• From the Laser Editor menu bar, choose Laser > Switch to Manual Mode.

Notes

• There are two possible scenarios:
• If you are not connected to a device, pressing F5 (or clicking  Send 

Marking) will automatically activate the simulator.

• If you are connected to a device, the  Simulator button is enabled and 
you must press it (or choose Laser > Simulator from the menu bar) to 
activate the graphic simulator.

The following picture shows an example:

• To interrupt the marking simulation, use the  Stop marking toolbar but-
ton (or choose Laser > Stop Marking form the menu bar).

Related topics:
• Setting custom laser parameters
• Displaying the limits
• Connecting to the laser device
• Marking preview
• Send marking

This is a toggle button: if the Manual Mode is activated, the 
tooltip says Switch to Auto Mode, and vice versa.
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Connecting to the laser device
Notes

In Laser Editor, the laser device that is used for marking graphic layouts is 
managed by the Laser Engine interface and can be either local, in the case of a 
stand-alone marking solution, or remote, in the case of an unattended marking 
solution, typically on a production line.
In particular, the connection mode (local or remote) depend upon your type of 
installation:

• If you have an unattended Supervisor installation of Laser Editor, you can use 
the procedure that is described here below to remotely connect to a Laser 
Engine, provided that the remote control has been enabled. (See Local/Remote 
control).

• If you have a Stand-alone installation (without remote control), you can only 
access the Laser Engine interface that controls your local device. The Connect 
to device buttons of Laser Editor that are described in the following procedure, 
are not available for this installation type.

For further information about using the Laser Engine interface, see chapter 
Laser Engine User Interface.

To set your Windows Firewall so as to enable remote connection:
This operation is required in order to enable remote communication between 
Laser Editor and Laser Engine. It involves setting your Windows Firewall prop-
erly:

• Click Start, click Control Panel, and then double-click Windows Firewall.
• Select the Exceptions tab, and then click Add Port.
• In the Port number box, type 4659 and then click OK.
• Repeat step 3, but type 4657 in order to open the port for files and binary data 

transfer.

To connect to the device:
• Do one of the following:

• From the Laser Editor menu bar, choose Laser > Connect to device.
• On the toolbar, click  Connect to device.

• In the Connect to device window that is displayed, select the device you want 
to connect to.
Note: that all the available devices are listed, both local and remote devices. In 
the case of a remote device, IP Address is also displayed.
It is only possible to connect to devices with IP Reachable property “true”.

• Click OK. 
Note: that the status bar of Laser Editor shows both the status of the connec-
tion and information on the connected device.

Related topics:
• Simulating the marking operations
• Send marking
• Launching Laser Engine

The following connection procedure only applies to users who 
have a Supervisor installation of Laser Editor. (For further 
information, see section Installation types and connection 
modes).
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Send marking
Laser Editor allows two ways for sending a graphic layout to marking:

• In Manual Mode - By pressing F5 (or choosing Laser > Send Marking) to 
send a layout. By pressing F9 or click on   (or choosing Laser > Send Mark-
ing on selection) to send a selected object. If you are operating on a 
stand-alone marking unit, and are interacting directly to the laser device, 
you can either use the simulator to test the layout, or send it to marking. 
(See Simulating the marking operations).

• In Auto Mode - By saving the graphic layouts to the device. The layouts will 
then be sent to marking based on the programs that have been created via 
Project Editor.

Notes
The functions described in this section are also accessible via 
the Laser Engine interface. For further information, see chap-
ter Launching Laser Engine.
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Auto mode vs. Manual mode
Lighter has different working modes:

• Auto mode
• Work mode
• Manual mode
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Auto mode
In Auto mode, a document or a project saved in the device is processed and 
sent to the laser control board, waiting for external I/O signals to start the 
marking process. 
When Laser Engine starts in Auto mode, the document or the project that is 
saved in the device and that is set as the default document is automatically 
processed and sent to the laser control board, waiting for external I/O signals 
to start the marking process.
The Auto mode is particularly useful in work environments where:

• no operator are assigned to the engraving station;
• the marking process is automate using external PLC;

Note that, in order to use Laser Editor for interactions with the laser device, that 
is, setting the laser configuration parameters or sending documents directly to 
marking, you must switch to the Manual mode.

Behavior
Typically, in this mode, you can do the following operations: 

• Select a project or document to be marked using Laser Engine.
• Press Auto Mode button  in Laser Engine.
• Use external I/O signals to start the marking process;
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Work mode
In Work mode, the document actually opened in Laser Editor is temporary saved 
in the device, processed and sent to the laser control board, waiting for exter-
nal I/O signals to start the marking process.
The Work mode is particularly useful in work environments where:

• an operator is assigned to the engraving station;
• Laser Editor is used to select and modify the documents;
• external I/O signals are used to start the marking process;

Note that, in order to use Laser Editor for interactions with the laser device, that 
is, setting the laser configuration parameters or sending documents directly to 
marking, you must switch to the Manual mode.

Behavior
Typically, in this mode, you can do the following operations:

• Open the project or document to be marked using Laser Editor.
• If needed, perform any editing or testing operation prior to mark.
• Press Work Mode button  in Laser Editor.
• Use external I/O signals to start the marking process;
• In work environments such as a production line, after selecting the docu-

ment, you can activate the Auto mode so as to enable external starts from 
the PLC.
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Manual mode
In Manual mode, the operator has full control of the marking process and no 
external I/O signals are accepted.
The Manual mode is particularly useful in work environments where:

• an operator is assigned to the engraving station;
• Laser Editor is used to select and modify the documents;
• no external I/O signals are used to manage the marking process;

Note that, you must activate the Manual mode in order to create and test a lay-
out before saving it on the device, or if you want to change the laser configura-
tion parameters. 
Engraving simulation and testing operations are only available in Manual mode.

Behavior
Typically, in this mode, you can do the following operations:

• Open the project or document to be marked using Laser Editor.
• If needed, perform any editing or testing operation prior to mark.
• Press Send Marking button  in Laser Editor.
• In work environments such as a production line, after selecting the docu-

ment, you can activate the Auto mode so as to enable external starts from 
the PLC.

To switch to Auto Mode if Manual mode has been activated:
• Choose the Laser > Switch to Auto Mode from the menu bar.

or
• Click on  Switch to Auto Mode on the toolbar.
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Sending the layout to marking
To send a layout directly to marking:

• Be sure that you are in Manual Mode. To switch to this mode, do one of the 
following:
• Choose Laser > Switch to Manual Mode from the Laser Editor menu bar.

• Click  Switch to Manual Mode on the toolbar.
• Press F5 or click on  Send Marking on the toolbar. (Alternatively, choose 

Laser > Send Marking from the menu bar).

Notes

• To interrupt the laser marking or the simulation, use the  Stop marking 
button on the toolbar (or choose Laser > Stop Marking form the menu 
bar).

To save a layout to the device for next marking:
• From the Laser Editor menu bar, choose File > Save to Device or press  

on the toolbar.
• In the Save document as window that is displayed, select from the Devices 

dropdown list the device you are sending the layout to.
• Enter a name for the document and click OK. This is the name that will be 

used in the Project Editor to write a program to upload the document send 
it to the engraver in an automated way.

Notes

If you are not connected to a laser device, the graphic simula-
tor will automatically be activated instead. (See Simulating 
the marking operations).

The Project Editor is a tool integrated into Laser Editor that 
allows creating customized programs. To access it, choose File 
> Project Editor. The tool has its own context-sensitive Help 
and it is used to automate marking procedures, or to update 
the layout contents at runtime. Default programs and easy-
to-use examples are provided with the tool.
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Chapter 5
Laser Engine User Interface

This chapter describes how to use Laser Engine, which is an application that is 
provided with Laser Editor and allows operating on the laser device.

The interface allows previewing how a document or project that was saved to 
the device will be marked, as well as performing many other fine-tuning opera-
tions before marking.

Laser Engine can be installed with Laser Editor or independently, and available 
buttons or functions may differ depending on the installation type that you 
have chosen when installing Laser Editor. For further information, refer to 
Installation types and connection modes.

For further information:

Topic

Launching Laser Engine

Laser Engine's User interface overview:
• Main window elements
• Menu buttons
• Shortcut menu commands

Managing users and access rights

Using global variables

Switching between working modes (Local/Remote or Auto/Manual)

Configuring the laser parameters

Configuring the Marking on the Fly function to mark objects in movement

Displaying the limits

Managing axis and executing the laser test

Correcting lens distortion

Sending documents to marking
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Viewing the Device Status

Statistics

Understanding the log file to fix problems that might arise

Testing the system

Photometric Adjustment

Quality Grade Training

Notes Laser Engine can now be integrated into customers' applica-
tions as an ActiveX server.
Developers can now write their ActiveX clients and build 
highly customized user interface for their clients, using Laser 
Engine to control the laser.
To this purpose, a new object has been created as entry point 
in the ActiveX server. (For further information, see the Project 
Editor online documentation, "Language Reference" chapter).
This feature must be licensed.

Topic
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Launching Laser Engine
To launch Laser Engine:

1. After you install Laser Editor, the Laser Engine icon appears on the appli-
cations toolbar, as it is shown below:

2. To display the Laser Engine user interface, do one of the following:
• Double-click the Laser Engine icon to display the application window.
• Right-click the Laser Engine icon, and then click Show.

3. To close the Laser Engine window, do one of the following:
• Click the Close button at the top right of the window.
• Right-click the Laser Engine icon, and then click Minimize. 

Notes

For further information on the elements that appear on the window, please 
refer to section User interface overview.

Starting from the release 5.3, you can also launch both Laser 
Engine and Laser Configuration from Laser Editor, by using 

the ad hoc toolbar buttons  or the Laser menu com-
mands.
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User interface overview
This section provides a quick reference to the graphical user interface of Laser 
Engine, both for the functions available in the main window and for the shortcut 
menu that you access by right-clicking the Laser Engine icon in the applications 
toolbar.

For further information:
• Main window elements
• Menu buttons
• Shortcut menu commands

Main window elements
The picture below shows the main window of Laser Engine when you access it.
In this example, a document is selected whose contents are displayed in the 
Preview area:

The numbered elements are described below:

Area Description

Menu buttons - The left side of the Laser Engine window contains the buttons that allow 
accessing the main functions. All buttons are toggle: move the pointer over a button to see 
the current selection. For more information on each button, see Menu buttons.
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Documents and projects saved to the laser - The Documents tab that is shown at the startup, 
lists all the project or documents that have been saved to the device and that you can send to 
marking (see Sending documents to marking):

• The  icon indicates a document (.xlp) created with Laser Editor

• The  icon indicates a project created with Project Editor

• The  icon indicates a sequence (.xse) created with Laser Editor
When you select an item, the Preview area displays the contents. If a sequence if selected, 
the first document in it is displayed.
Note that right-clicking a document or a project, results in a shortcut menu opening that 
allows you to delete the element or to set it as the default, that is, as the document or project 
that will be selected at Laser Engine startup:

Tabs - In this area, the following tabs can be displayed:
• Documents, that lists the project and documents, as it is explained here above. For fur-

ther information, see Sending documents to marking.
• Device Status, that shows information relating to the status of the laser device. It is a 

read-only tab. For further information, see Viewing the Device Status.
The availability of the following tabs depends upon the laser source you are using and how it 
is configured, that is, if axis are enabled. For further information, see Managing axis and exe-
cuting the laser test.

• X-Y Axis, that allows managing the horizontal and vertical axis prior to marking a plane 
document.

• Z Axis, that allows managing the Z axis prior to marking, as well as executing the laser 
test for focusing.

• Rotor Axis, that allows managing the R Axis prior to marking a ring document.
• Statistic, that shows statistic relating to marking processes and marking & verification 

processes (feature available with Marvis enabled; see the Marvis Application Note for 
more details).

Document's or project's preview - If you select a document (as in the example), this area 
shows how the graphic objects will be actually marked. If you select a project, it gives you 
information on the project.

Marking time - It previews the required marking time, based on the objects to be marked, 
showing also the progress.

Zoom function - In the case of a document, it allows zooming the objects to be marked.

Device status icon - It tells you the current status of the device: for example a green icon 
means Device is waiting for start, while a red icon means Device ready. For further informa-
tion on device statuses, see Viewing the Device Status.

Area Description
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Reader available icon - It tells you the current status of the reader: for example a green icon 
means Reader available for verification, while a red icon means Reader is working. For fur-
ther information on device statuses, see MARVIS configuration.

Laser Engine icon on the applications toolbar - Right-click this icon to open a shortcut menu 
that lists a number of commands. See Shortcut menu commands for further information.

Area Description
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Menu buttons
Notes

The following table provides a short description of all available menu buttons. 
A link to the relevant section in this chapter is provided.

Button Description

to Local/to Remote - It allows specifying the Laser Engine supervision level: it can be Local 
(Laser Editor and Laser Engine are on the same machine) or Remote (Laser Editor and Laser 
Engine are on different machines.) After setting the Remote control, operators who have a 
Supervisor installation type might control remotely the laser.
This button is only available if you have an Interactive installation with remote control 
allowed.
By setting the Remote control, all other buttons become unavailable.
For further information, see Local/Remote control.

to Auto/to Manual mode - It allows switching between working modes. This button is only 
available if the Local control has been activated.
When the Auto mode is activated, the engraving operations are executed automatically. The 
Manual mode is used for editing and testing graphic layouts.
You can set the default working mode via the shortcut menu. For further information, see 
Auto/Manual working mode.

Start - It allows sending a document to marking, or stopping the marking operation, respec-

tively. When pressed, this button changes to 
This button is only available if the Local control has been activated. For further information, 
see Sending documents to marking.

Start Limits - It allows displaying the margins of the graphic objects to be marked.
For further information, see Displaying the limits.

Limits previous sector / Limits next sector - These buttons allow displaying the margins of 
the sectors that compose the objects to mark, when engraving on ring documents. The but-
tons become active after clicking on Start Limits.

If users access control has been enabled and you do not have 
proper rights to use the buttons, you will be prompted for a 
password with rights. (For further information, see Managing 
users and access rights).
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Shortcut menu commands
Right-clicking the Laser Engine icon on the Windows application toolbar, 
results in a shortcut menu opening:

The commands available on the shortcut menu are shortly described below. A 
link to the relevant section in this chapter is provided.

Menu command Description

Minimize/Show Allows minimizing or displaying the Laser Engine user interface.
Always on top Allows keeping always visible the Laser Engine window.

User Management
Allows accessing the user management function. You must have the 
appropriate privileges to manage users. See Managing users and 
access rights for further information.

Global variables

Allows accessing and managing the global variables; these are 
strings or counters that are stored in a small database at the device 
level. If users management has been enabled and access to this 
function has been limited, you will be prompted for a password with 
proper rights. See Using global variables for further information.

Troubleshooting Allows checking errors and tracking system events.

System test Displays the dialog that allows checking your hardware and cables 
connections. See Testing the system for further information.

Laser configuration Allows accessing the parameters for configuring the laser. See Con-
figuring the laser parameters for further information.

Start in auto mode
Start in remote mode

Allows specifying the working mode that must be activated at 
startup. See Auto/Manual working mode for further information.

Quit Exits the Laser Engine interface. Use this command if you need to 
restart Laser Engine.
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Managing users and access rights

The User management function allows you to set and manage the users' rights 
on the system.
By default, Laser Editor does not request any login and any user can access and 
manage all system's functions.
To change this setting, you must first enable the Users management function 
by entering a unique password that gives you administrator privileges; then, 
you can specify the rights on the system's functions for specific classes of 
users.

Notes

To enable the users management and to set the access rights:
• Right-click the Laser Engine icon on the Windows applications bar.
• On the shortcut menu that appears, click User management.
• The dialog box for typing the password is displayed:

• Type a unique password of your choice.

Notes

This function is also accessible and usable at the Laser Editor 

level by clicking the  Manage device users button on the 
toolbar or by choosing Manage device users from the Laser 
menu.

If the password you specify is not unique in the system, an 
error message will be displayed.



188 Lighter™ Suite

• Specify whether and how long the system must remember your password: 
You can specify either a specific time interval in minutes, or the entire pro-
gram's session. Once the specified time is elapsed, the password will be 
requested to enter the function. 

Notes

• Click OK. The User management window will be displayed.

The left side of the grid lists the available types of users, while in the upper part 
the functions you can limit the access to are listed. An asterisk (*) indicates that 
the access control is currently disabled for those users because no password 
has been set, and a selected checkbox indicates that the user has rights to the 
function.
Available users are:

• The Administrator has full rights on the system's functions and can man-
age the users' rights; you cannot edit this user.

• The Everyone user is the default user, who has all rights except the users 
management function; it is editable and you can use it as a basis for set-
ting the other users' rights.

• Three additional types of users are provided: Operator, Designer, and 
Developer. These represent the typical operators of a laser system for 
whom you might limit the access rights to the functions.

The functions you can limit the access to are:

Function name Allowed operations

Manage users This function allows managing users' access rights to the system.

Auto/Manual This function allows switching between manual and auto working 
mode. See Auto mode vs. Manual mode.

Manage layouts This functions allows creating a layout and sending it to marking. See 
Creating Graphic Layouts.

Programming
This function allows implementing a project with Project Editor and 
then sending it to marking. (See the Project Editor's online help that 
is integrated into the Laser Editor help system.)

Laser configuration This function allows accessing and configuring the laser configura-
tion parameters. See Configuring the laser parameters.

Global variables
This function allows creating global variables that you can access 
both from Laser Editor or from the Laser Engine interface. See Using 
global variables.

To change the administrator password, or to disable the users 
access control, see Disabling users' access control.
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• To enable the access control for the Operator, Designer, or Developer 
user, in the User management window click Set passwords. The Change 
passwords window is displayed.

• Click the User arrow to display the list of users and then select the desired 
user, for example Designer.

Notes

• Type a unique password of your choice, and then confirm it.
• Do one of the following:

• Click OK to return to the User management window.
• Click Apply to clear the fields if you want to disable access control for 

the user, or if you want to change the password.
• Note that the Designer user inherited all Everyone's rights, that is, has 

access to all functions, but the checkboxes are still unavailable and you 
cannot clear them.

• To limit the access rights to a specific function for the Designer user:
• Clear the corresponding checkbox for the Everyone user.
• The checkbox becomes available for the Designer user also; clear it to 

limit the access to the function for this type of user, as shown in the 
example below:

• Click OK to save your settings. The next time users try to access the Laser 
configuration function, the system will prompt them to enter a password 
with the appropriate privileges.

Notes

Select Administrator to change the current password, or to 
disable the users access control by entering an empty pass-
word.

Some functions are dependent to each other. For example, a 
user who has access rights to Programming must also have 
access rights to Manage layouts and Auto/Manual, so the 
system will prevent you from disabling them.
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Disabling users' access control

To disable the access control for a type of user or for all users:
• Access the user management function using the Administrator password.
• In the User management window click Set passwords.
• Click the User arrow to display the list of users and then do one of the fol-

lowing:
• Select Administrator to disable access control for all users. This way, all 

users will have access rights to all functions.
• Select the type of user you want to disable from the User list.

• Leave the Passwords fields empty and then click OK if you want to close 
the Change password window, or click Apply to keep it open.

• In the message window that is displayed, click Yes.

To re-assign the access to a function for a type of user:
• Access the user management function using the Administrator password.
• In the User management window, select the checkbox corresponding to 

the function you want re-assign.
• Click OK.
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Switching between working modes
In this section:

• Local/Remote control
• Auto/Manual working mode

Local/Remote control
Notes

The Remote/to Local button of the Laser Engine left menu, allows specifying 
who is supervising the Laser Engine, that is, who is controlling and can actually 
send commands to Laser Engine.
The button is toggle: Move the pointer over it to see the current selection. In 
the figure below, the Local control is activated:

Local control
The Local control is used when Laser Editor and Laser Engine are both installed 
on your PC, that is, if you are locally connected and directly controlling the laser 
source.
In this case, Laser Engine will accept commands from you, but not from other 
operators on the network.

Behaviour when resuming Local control from Remote control
If the Remote control has been activated and you need to make changes at run-
time, such as displaying limits or testing a layout, do the following:

• Click the to Local button in the left Menu of Laser Engine to resume the 
Local control.

• You will be notified if other operators are remotely connected and remote 
connections will be terminated.

Remote control
The Remote control can be used for two purpose: 

• Establish a network connection between Laser Editor and Laser Engine 
installed on different machines. Laser Editor must have a Supervisor 
installation and Laser Engine must be set in Remote mode. Laser Engine 
will accept commands from the first Laser Editor who connects. Only oper-
ators in the network who have a Supervisor installation of Laser Editor can 

The Remote/Local button is only available if your installation 
is Interactive with remote control allowed (For further infor-
mation, see Installation types and connection modes).
By default, at the startup, the local control is enabled. This 
way, only authorized operators can activate the remote con-
trol so allowing remote connections from other operators in 
the network.
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remotely connect to Laser Engine. (For further information see Installation 
types and connection modes).

• Control the laser marker using TCP / IP protocol embedded in Lighter 
(Lighter 6.3.0 and later). Laser Engine will accept TCP / IP commands from 
the first who connects.

Behaviour:
Establish a network connection between Laser Editor who have a Supervisor 
installation and a laser marker with Laser Engine set in Remote mode: 

• Click the to Remote button in the left Menu of Laser Engine to set the 
Remote control.

• The laser source connected to Laser Engine will appear on the list of avail-
able laser sources for remote connection.

• From Laser Editor clicks the Connect to device button and then selects the 
laser source from the list that is displayed. (See Connecting to the laser 
device).

Control the laser marker using TCP / IP protocol embedded in Lighter (Lighter 
6.3.0 and later):

• Specify the port number of the TCP / IP Protocol used by Laser Engine in a 
remote mode environment. (For further information see Setting the Net-
work parameters).

• Click the to Remote button in the left Menu of Laser Engine to set the 
Remote control.

To set the Remote mode as the default working mode:
• Right-click the Laser Engine icon on the Windows applications bar.
• On the shortcut menu that appears, click Start in Remote mode to set it as 

the default mode. Note that the menu command is now checked:

• Lighter will ask you to confirm your choice. Press Yes to continue:

• To deselect the Start in Remote mode selection, click again on it.
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Auto/Manual working mode 
Notes

The Auto/Manual button of the Laser Engine left Menu, allows switching 
between working modes. The button is toggle: Move the pointer over it to see 
the current selection. In the figure below, the Manual mode is activated:

For further information, please see chapter “Performing the engraving opera-
tions”, section Auto mode vs. Manual mode.
You can set the Auto mode as the default working mode, that is, as the mode 
that will be used at Laser Engine startup.

To set the Auto mode as the default working mode:
• Right-click the Laser Engine icon on the Windows applications bar.
• On the shortcut menu that appears, click Start in auto mode to set it as the 

default mode. Note that the menu command is now checked:

• To deselect the default mode, click it.

This button is only available if the Local control has been acti-
vated (see Local/Remote control).
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Configuring the laser parameters

This chapter describes the laser configuration parameters that you can set to 
configure the laser devices for optimal engraving performance.

To access the Laser configuration window:
• Right-click the Laser Engine icon on the Windows applications bar.
• On the shortcut menu that appears, click Laser configuration.

Notes

• The Laser configuration window is displayed, allowing you to set all the 
properties for the laser devices you are connected to.

• To set parameters, use the following tables as a reference:
• Setting the General parameters
• Setting the head Scanner parameters
• Setting the Laser parameters
• Configuring the Field Orientation
• Setting the Correction parameters
• Setting the Aiming parameters
• Setting Input/Output parameters
• Setting the X, Y, Z, and Rotor Axes parameters
• Configuring the Marking on the Fly function
• Setting the Network parameters
• MARVIS configuration
• Distance Sensor configuration
• Service

If users management has been enabled and access to this 
function has been limited (see Managing users and access 
rights), you will be prompted for a password with proper 
rights.
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Setting the General parameters
This window allows you to specify the user interface language, the linear mea-
surement unit and the maximum disk space for log files.

Group box Parameter Description

Language

It lists the available languages for the user interface. Select the lan-
guage you want to use.
Note that by default, the language is set to Autodetect, meaning that 
it depends upon the language of your operating system.

Units
Linear Sets the linear measurement unit. Available options are mm or 

inches.

Decimals Sets the number of decimals to be used. Admitted values are 0 to 5.

Logging

Max log space (KB) The log file is compiled at the Laser Engine level and lists all actions 
that have occurred allowing you to correct any problem that might 
occur.
For further information on how to use and manage the log file, please 
see Understanding the log file.

Max log file number

Trouble-
shooting

Database
Max Size [MB]

It specifies the maximum disk space for troubleshooting's database. 
Admitted value are 1 to 500 MB.

Level
Max Level Tracing

Set the level of events to track and save on the device.

ERRORS Tracks only system errors.

WARNINGS Tracks system warnings and errors.

INFO Tracks system information, warnings and 
errors.

Trace

Enable the events you want to track.

LIGHTER It tracks the events related to the communica-
tion between laser editor and laser engine

ETHERNET_IP
It tracks the events related to the Ethernet_IP 
communication between laser marker and client 
device

AXIS It tracks the events related to axes movement

INPUTS_OUTPUTS It tracks the events related to the I/O

READER It tracks the events related to the communica-
tions with the reader

TCP-SERVER It tracks the events related to the TCP- SERVER 
protocol communications
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Setting the head Scanner parameters
The Scanner page of the Laser configuration window, is used to set the scanner 
speed and the waiting times for adjusting the engraving quality with respect to 
running times.

Properties 
Group Property Description

Scan

Jump Speed [Kpts/s] Speed the scanners use when moving between polygons (that is, 
when not marking).

Scan Ramp [ms]

Passive q-switched laser sources `oscillate' at start up, resulting 
in first line(s) being progressively thicker. The Scan Ramp param-
eter sets a time (expressed in millisecond), for the scanner to 
accelerate from zero to maximum speed: this allows to reduce 
the flaw. This parameter needs only to be set for passive q-
switched laser sources.

Scan Threshold [ms]

Acceleration needs to happen only at start up to allow emission 
stabilization. The Scan Threshold is the amount of time that 
must elapse (after the laser has been switched off) for the accel-
eration ramp (see Scan Ramp) to be repeated.

Standby Position

The position the scanner moves to when standing-by, that is, at 
the end of the marking operation. If the emission cannot be com-
pletely stopped, this parameter allows moving the scanner so as 
to prevent damages. Possible values are:

• Center, moves the scanner to the origin. This is the manda-
tory setting if you are using the Marking on the Fly function 
(for further information, see Configuring the Marking on the 
Fly function).

• Corner, moves the scanner to the bottom left corner. If this 
option is selected, the Corner Position fields are displayed 
below, indicating the exact position in points. By default, 
this position is the farther from the origin.

• Dynamic, moves the scanner dynamically back to the centre 
after elapsing a certain amount of time.

Corner Position [pts] X Indicates the position of the corner along the X coordinate.

Corner Position [pts] Y Indicates the position of the corner along the Y coordinate.
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Polygon 
Delays

Refers to the waiting times required for high quality engraving. K and C are two variables, 
where K is the proportional coefficient for speed and C is constant. The system calculates 
the waiting times for the movement of the laser according to these parameters. Waiting 
times are all expressed in microseconds [μs]. (For further information, see Calculating 
waiting times).

K first [μs]

• First = First point of a vector. (That is, waiting time before 
proceeding with the first movement.)

• Next = Conjunction point between two vectors
• Last = The last point of a vector

C first [μs]

K next [μs]

C next [μs]

K last [μs]

C last [μs]

Edit advanced param-
eters button

This button enables more parameters that allow configuring the 
laser source, so as to suit your needs. This function is intended 
for specialized technicians who will be provided with an ad hoc 
password.

Raster 
Delays

The following parameters are editable after activating the Edit advanced parameter func-
tion.

C on [μs] The time that the laser spends to mark an individual pixel.

C off [μs] The waiting time before the laser marks the next pixel. The higher 
this time, more powerful the next pulse.

C line [μs] The waiting time between lines, that is, before the laser marks 
the next line.

Laser 
Delays

The following parameters are editable after activating the Edit advanced parameter func-
tion.

C draw [μs]
The time that elapses before the system actually start emitting.
The laser system can have a sort of inertia, that is, a response 
delay between the "emission" signal and the actual emission.

C jump [μs]

The time that elapses before the system extinguish the laser 
emission.
This phenomenon is complementary to the one originating the 
Cdraw delay.

Properties 
Group Property Description
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Calculating waiting times
The engraving process is achieved by means of a laser beam deflection device 
controlled by two retroactive electrical drives (PID) which angular position is 
proportional to the control voltage provided. Due to the very nature of the sys-
tem, the reaction time (phase) of the drives is not negligible. If this reaction 
delay wasn't taken into account, poor results would be obtained: the solution is 
that the control system waits the mirror for correct positioning before proceed-
ing.
The waiting times required for high quality engraving are illustrated below. 
Waiting times are linear functions (linear phase) of the engraving speed; this is 
why they are parameterized by two variables: K, proportional coefficient for 
speed and C, constant. The system computes the waiting time according to 
these two parameters with the following formula:

T = C + K.
Speed

Max speed

The speeds indicated in the formula are expressed in thousands of coordinates 
per second and the maximum reference speed mentioned in the formula is 
equal to 1000 [Kcoord/s], which corresponds to the following speeds 
expressed in [mm/s] according to the lens:

• f100 = 1133.3 mm/s
• f160 = 1822.2 mm/s
• f254 = 2900.2 mm/s

Notes

The following example shows how to engrave the word "LASER". Thick lines 
indicates actual marking, thin ones a jump of the mirrors (that is, a movement 
of the mirrors between marked vectors):

The following examples will better illustrate how incorrect technical waiting 
time setting can affect the result.

Waiting times are all expressed in microseconds [μs]..
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TFirst [μs]
Waiting time for the scanner to actually reach the required position before 
switching the laser on.

• If the delay is lower than the optimal value, notice how the first 
vector of each polygon is distorted and longer than the correct 
length.

• If the delay is higher than the optimal value, the engraving pro-
cess will be slower but no effects will be visible.

TNext [μs]
Waiting time for the scanner to reach the correct position before tracing the 
vector after the first with the exception of the last. This waiting time is accord-
ing to the engraving speed and depends on the angle between the two consec-
utive vectors. If the angle is equal to 180°, the waiting time will be equal to 
zero, while the waiting time will increase as the angle decreases, the time being 
maximum when the angle is equal to zero degrees.

• If the delay is lower than the optimal value notice how the poly-
gon vectors are rounded and not sharp

• If the delay is higher than the optimal value, notice how the 
polygon vectors are more marked and deeper than they should 
be.

TLast [μs]
Waiting time for the scanner to reach the correct position before switching the 
laser off (scanning the last vector of a polygon).

• If the delay is lower than the optimal value, notice how the last 
polygon vectors are shorter and incomplete.

• If the delay is higher than the optimal value, notice how the 
vector end points are more marked.
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TDraw (Diode Laser) [μs]
Time the system takes to actually start emitting. Even if low, the system can 
have a sort of inertia, that is, a response delay between the "emission" signal 
and the actual emission.
This time does not depend on speed (only constant component in the formula 
is required).

• If the delay is lower than the optimal value, notice how the first 
vector of each polygon is shorter.

• If the delay is higher than the optimal value, notice how the ini-
tial vector points are deeper.

Notes

TJump (Diode Laser) [μs]
Time the system takes to extinguish the laser emission. This is the comple-
mentary phenomenon to the one originating Tdraw,
This time does not depend on speed (only constant component in the formula 
is required).

• If the delay is lower than the optimal value, notice the blurring 
between the polygons.

• If the delay is higher than the optimal value, the engraving pro-
cess will be slower but no effects will be visible.

Tdraw is usually smaller than Tfirst. Since they both deal with 
the starting point of the first vector, the first is usually 
neglected.
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Setting the Laser parameters
The Laser page of the Laser configuration window, contains the following 
parameters:

Notes The Laser source is set to the default parameter that has been 
set for Laser Editor. For further information, see Click OK to 
implement your settings.. You can still set a source type other 
than the default one.
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Properties 
Group Property Description

Laser

Source Type This is the currently selected laser source.

Edit advanced parameters button. This button enables more parameters that allow config-
uring the laser source, so as to suit your needs. This function is intended for specialized 
technicians who will be provided with an ad hoc password.

Description
This parameter is displayed after activating the Edit advanced 
parameter function.
It allows entering a description of the laser source.

Power Change Type

This parameter is displayed after activating the Edit advanced 
parameter function.
Some systems (especially lamp ones) have high `optical inertia': 
they take time to stabilize laser emission after power supply has 
changed. Diode sources behave this way only if the level ramp 
starts below emission threshold. This parameter can have two 
values (do not change settings in laser.ini file):

• Once: Power Change time (see Delays parameters) is 
applied only on the first engraving pen down (diode 
sources)

• Always: Power Change Time is applied to every level varia-
tion (lamp sources)

Enable continuous 
emission

If this property is set to True, you will then be able to set to 0 the 
Frequency parameter. The Frequency parameter is used to 
adjust the laser output frequency by directly operating on the Q-
switch; it can be set at documents or objects level (see Laser 
properties for documents).
The Q-switch is an electro-optical system which controls the 
opacity of a lens making it possible to change the laser beam fre-
quency. Setting to 0 the Frequency parameter prevents the 
emission from being discontinuous.

Aiming Beam Type

OFF The aiming beam is turned OFF

Smart

The aiming beam is ON when:
•the limits of a layout or an object are per-
formed and the system is in STANDBY SHUTTER 
CLOSE or READY state
•the marking process start and the system is in 
STANDBY SHUTTER CLOSE state

Automatic The aiming beam is ON when the system is in 
STANDBY SHUTTER CLOSED state

Aiming Beam Stand By 
Time

The time during which the Aiming beam remain ON is called Aim-
ing Beam Standby Time. If the Aiming Beam Standby Time expire 
and no changes in system status occurred during this time, the 
Aiming beam is automatically turned OFF by the system. The 
Aiming beam is automatically turned ON (compatibly with the 
system status) as soon as the system detect a system status 
change. The Aiming Beam Standby Time is configurable from 10 
to 60 minutes.
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Laser

Focus Beam Type
OFF The focusing beam is turned OFF

Automatic The focusing beam is ON when the system is in 
STANDBY SHUTTER CLOSED state

Focus Beam Stand By 
Time

The time during which the Focus beam remain ON is called Focus 
Beam Standby Time. If the Focus Beam Standby Time expire and 
no changes in system status occurred during this time, the Focus 
beam is automatically turned OFF by the system. The Focus 
beam is automatically turned ON (compatibly with the system 
status) as soon as the system detect a system status change. 
The Focus Beam Standby Time is configurable from 10 to 60 min-
utes. The default value in Laser.inz is 10 minutes

LaserLink diagnostic
It allows enabling/disabling the communication with the exter-
nal device so as to check its state before marking. If it is set to 
False the check is not performed.

Levels

Power level signal controls the electrical current fed to the laser diode: the higher the cur-
rent, the higher the power emitted. It is expressed as a percentage of the maximum.

Min. Level [%] Minimum allowed power level signal. This is the value the soft-
ware uses when the user sets to 0% the laser power.

Thermal Level [%] Level signal the laser moves to when standing-by.

Max. Level [%] Maximum allowed level signal. This is the value the software 
uses when the user sets 100% laser power.

Ramp Time [ms] Time, expressed in milliseconds, for effecting the ramp used to 
pass from the minimum level to maximum level.

Delays

Power Change [ms]
Thermal standby, expressed in ms, it is the standby time 
between the end of the level ramp and start of engraving. This 
standby serves for the laser to stabilize before starting to work.

Stand by [s]

Expressed in seconds, this is the standby time between the end 
of engraving and the level ramp which resets the minimum value 
(of standby). This standby lets the laser remain stable between 
two close engraving with consequent saving of work time.

Properties 
Group Property Description
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Parame-
ters

The following parameters are editable after activating the Edit advanced parameter func-
tion.

Shot Time [μs]

Duration of the laser shot pulse i.e. the time the Q-switch is open 
(or, better, transparent). Crystal unwinding time is always order 
of magnitude faster than shot time therefore this parameter 
affects shot energy only indirectly as it can be used to tune crys-
tal re-populating time (it begins only when Q-switch is closed).

Shot/Base Frequency 
[Hz]

This parameter sets default Q-switch frequency. Frequency is 
inversely proportional to laser beam power, that is, if the fre-
quency is too high, the power may not be sufficient for the 
engraving process. Frequency can be changed trough the user 
interface and be customized for each object but raster engraving 
with LEVEL technique uses this parameter as Pixel Rate, that is, 
the rate at which pixel are generated (and therefore scanner 
moved). In this case the `Shot Frequency' parameter is used to 
control Q-Switch modulation. Setting it to zero (0)causes Q-
Switch modulation to be synchronous with scanners movement 
(that is, one pulse per pixel).

First Pulse 
Killer

The following parameters are editable after activating the Edit advanced parameter func-
tion.

FPK: When operating on a steady Q-switch frequency, the power of the pulses emitted 
depends upon the frequency itself (as this is the time the crystal take to repopulate), and 
the level of the optic pump (the diode). However, the very first pulse is different because 
crystal population increased a lot during the stand-by time: energy of the first pulse can be 
times bigger than the following pulses. The FPK is a technique to avoid the first pulse.

FPK Delay [μs] Time the level or pen down signal is low to suppress First Pulse 
Killer (FPK).

FPK Level [%] Level of the first pulse killer.

Frequency 
Rule

The following parameters are displayed after activating the Edit advanced parameter func-
tion.

Min Frequency [Hz] Defines minimum and maximum frequencies [Hz] allowed 
(comma separated).Max Frequency [Hz]

Speed Rule

The following parameters are displayed after activating the Edit advanced parameter func-
tion.

Min Speed [Kpts/s] Defines minimum and maximum marking speed [mm/s] allowed 
(comma separated).Max Speed [Kpts/s]

Properties 
Group Property Description
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Power Rule

The following parameters are displayed after activating the Edit advanced parameter func-
tion.

Min Power [%] This ruse is used to control the beam peak energy does not over-
take damage limits. Low frequencies correspond to high single 
shot energy. Scanning mirrors can be damaged by single high 
energy shots.
Power rule consists of a list of five parameters.
The first two parameters indicate the absolute minimum and 
maximum power level allowed. 
Third and fourth parameters are used to calculate maximum 
power related to selected frequency according to this formula 
Pmax = C + K * F where Pmax is the maximum power allowed, C 
(Constant Power Correction) and K (Gain Power Correction) are 
the numbers in the rule and F is the current frequency. 
Fifth parameter is used to set the Power Offset.  In certain types 
of laser (fiber laser) the relation between the power level and the 
power output is such that, at a power level of zero, the laser 
emits already a significant amount of output power. Offset 
Power Correction parameter represents the percentage of power 
level that is emitted when the laser is set to the minimum power 
level.

Max Power [%]

Constant Power Cor-
rection [%]

Gain Power Correction 
[%/Hz]

Offset Power Correc-
tion [%]

Delay Rule

The following parameters are displayed after activating the Edit advanced parameter func-
tion.

Min Delay [ms] Defines minimum and maximum dot delay [ms] allowed (comma 
separated). Dot delay is used in vectorial marking and it is the 
time used to mark the "dot" entity.Max Delay [ms]

Pulse Pro-
file

The following parameters are displayed after activating the Edit advanced parameter func-
tion.

This parameter is only available for MOPA laser source. MOPA laser source allows to select 
the laser pulse duration between a selected range of values. These values are called Pulse 
Profiles

Profile Selection List of available Pulse profiles

Properties 
Group Property Description



206 Lighter™ Suite

Pulse Pro-
file proper-
ties

The following parameters are displayed after activating the Edit advanced parameter func-
tion.

This parameter is only available for MOPA laser source. MOPA laser source allows to select 
the laser pulse duration between a selected range of values. These values are called Pulse 
Profiles

Description
Custom name assigned to the selected pulse profile. This name 
will be visualized in Laser Editor Property Browser pulse profile 
list

Duration Laser Pulse duration of the selected pulse profile

Min Frequency [Hz] Minimum frequency allowed by the selected pulse profile

Max Frequency [Hz] Maximum frequency allowed by the selected pulse profile

Enable

Enable / disable the selected pulse profile. If disabled, the 
selected pulse profile will not be visible in Laser Editor Property 
Browser pulse profile list. If a document uses a pulse profile that 
is currently disabled, the pulse profile will be replaced with near-
est one

Properties 
Group Property Description



Configuring the laser parameters

User Guide                            207

Configuring the Field Orientation
In the Field Orientation window, you can select the Scanhead orientation and 
the Layout Marking orientation by selecting the desired image to simulate the 
work environment.



208 Lighter™ Suite

Setting the Correction parameters
The Correction page of the Laser configuration window is used to set the opti-
cal correction required to recover the distortion of mirrors and lens.

Properties 
Group Property Description

Lens

Focal Length [mm] It contains a list of available optical lenses that you can install on 
the scanner head of the laser device.

Duplicate lens
This button allows duplicating a lens to be used as a template for 
creating a new one. You can then set the Lens parameters to suit 
your needs.

Delete Lens This button allows deleting a lens created by the user.

Import lens
This button allows importing a lens using another configuration 
file (laser.inz). This way, you can use a configuration of a custom 
lens that was executed on a different device.

Optical 
Correction

Parameters in this area allow the user to set his own optical corrections (for example, if 
scan head is not properly aligned with the marking filed).

Use correction file If it is set to True, allows you to specify the path of a custom file 
to be used for Field Correction.

Offset X [pts] It allows aligning horizontally the field.

Offset Y [pts] It allows aligning vertically the field.

Scale X [%]
Scale factors used to correct magnification.

Scale Y [%]

Theta X [deg]
Theta angles used to calculate optical correction.

Theta Y [deg]

Horizontal sides ratio 
[top/bottom]

These parameters correct an error introduced when scan head is 
not properly aligned with the marking field.
This produces a deformation of the field from a square into a tra-
pezium. To fix the problem, use the Diagonals ratio parameter.

Vertical sides ratio 
[right/left]

Field rotation angle 
[deg]

Rotates the optical field to align it to the physical field. Since this 
operation introduces errors near the field borders, only values 
lower than 1° are accepted.

Diagonals ratio
The ratio between top and bottom sides (Horizontal sides ratio), 
right and left sides (Vertical sides ratio) that a user can use to fix 
a deformation adjusting the optical correction.
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Lens 
parameters

These parameters allows configuring your own lens. They are used together with the 
Duplicate - Delete and Import lens buttons. (See above)

Description A string describing the lens.

Focus Depth Range along the Z axis the beam is focused.

Nominal Focal Length 
[mm] These parameters determine the size of the marking area and 

other properties of the system.Real Focal Length 
[mm]

Field Width [mm] Marking field dimensions. The optical field is always a square, but 
physical can have different measures in actual application.Field Height [mm]

Mechanical Field Side 
[mm]

Side of the marking field square.
This value is used to perform conversion between points and mil-
limeters.Logical Field Side [pt]

Properties 
Group Property Description
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Setting the Aiming parameters
The Aiming page of the Laser configuration window, is used to correct the 
pointer limits in relation to engraving so as to obtain perfect overlaying, since 
the power laser and the pointer laser wavelengths are different.
Resonator can contain a red light diode. This is used to highlight marking area 
to the operator usually in industrial applications. Not every laser has a red 
diode.
The different wavelength of the visible red diode with respect to laser light 
causes a different refraction inside the objective lens. As a consequence the 
coordinate generated when displaying layout limits must be corrected to match 
layout engraving.
This page allows some tuning on limits placement; if the result appears still 
wrong, please contact the technical support team.

Properties 
Group Property Description

Scanner Scan Speed [Kpts/s] Scanners speed used when tracking limits, expressed in Kspots/s.

Correction

Offset X [pts]
Alignment offset expressed in points, applied to X coordinate when 
tracking limits. This value is limited to ±1% of the coordinates 
range.

Offset Y [pts]
Alignment offset expressed in points, applied to Y coordinate when 
tracking limits. This value is limited to ±1% of the coordinates 
range.

Scale X [%] Scale applied to X coordinate when tracking limits. This value is 
limited to ±5% (95÷105%).

Scale Y [%] Scale applied to Y coordinate when tracking limits. This value is 
limited to ±5% (95÷105%).
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Setting Input/Output parameters
The Input / Output page of the Laser configuration window is used to set dura-
tions and delays of laser Input signals in relation to engraving.

Properties 
Group Property Description

Inputs

Start time [ms] Sets the minimum duration, in ms, of the start engraving signal.

Start delay [ms or 
mm]

Sets the delay, in ms, between acceptance of the start engraving 
signal and actual start of engraving.

Stop time [ms] Sets the minimum duration, in ms, of the stop engraving signal.

Outputs

Busy advance [ms]
Delay between the work in progress (Laser Busy) signal and actual 
laser emission. This parameter may be useful if this signal is used 
to open an electromechanical shutter.

Busy delay [ms] Delay between the end of actual laser emission and the end of 
Laser Busy signal.

End time [ms] Duration of the end engraving signal (Laser End) after Laser Busy 
signal ends.

SW Ready Mode

Standard

The SW_READY output signal is ON when all these 
events are true:

• a document or a sequence is running in 
AUTO MODE or WORK MODE

• the system is in READY state

Compatibility

The SW_READY output signal is ON when a docu-
ment or a sequence is running in AUTO MODE or 
WORK MODE independently from the system sta-
tus

Ready To 
Mark

The SW_READY output signal is ON when all these 
events are true:

• a document or a sequence is running in 
AUTO MODE or WORK MODE

• the system is in READY state
• the system is ready to start a new 

marking process
 The SW_READY output signal is OFF during the 
marking process and during spooler processing 
and loading
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Green Spot
Green Spot Type

OFF The green spot indicator is not active (always OFF)

System 
Ready To 
Mark

The green spot is steady ON only when all these 
events are verified:
• the system is in READY state
• a document is in AUTO MODE or WORK MODE
The green spot indicator is steady OFF during the 
marking process

Marking 
Confirmation

The green spot turns ON when all these events are 
verified:
• the system is in READY state
• a document is in AUTO MODE or WORK MODE
• the marking process was correctly executed (no 
errors, no stop marking, no status changing)
The green spot indicator turns ON at the end of the 
marking process and remain active for a configu-
rable period of time from 0.1 s to 5 s. This time is 
called Indicator Time and it is expressed in ms.
If a new marking process is started while the green 
spot is still active, the green spot will be automati-
cally turned OFF

MARVIS™ 
Verification

The green spot turns ON when all these events are 
verified:
• the system is in READY state
• a document is in AUTO MODE or WORK MODE
• the marking process was correctly executed (no 
errors, no stop marking, no status changing)
• the MARVIS™ verification process was successful
The green spot indicator turns ON at the end of the 
marking process and remain active for a configu-
rable period of time from 0.1 s to 5 s. This time is 
called Indicator Time and it is expressed in ms.
If a new marking process is started while the green 
spot is still active, the green spot will be automati-
cally turned OFF

Indicator Time [ms] The period of time the green spot indicator turns on in Marking 
Confirmation mode and MARVIS™ Verification

Properties 
Group Property Description
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Setting the X, Y, Z, and Rotor Axes parameters
The pages Y Axis, X Axis, Z Axis, and Rotor Axes are used to set the parameters 
related to the three mechanical axes whose movement are controlled by step 
motors.
In particular:

• Z axis is the mechanical axis. It allows focusing on different levels.
• X, Y, and Rotor axis are the mechanical axes used to position objects 

under the laser via step motor control.
Axis management and settings depend on the board controlling their move-
ment. These parameters are typically used by who installs and sets the step 
motor for axis management. (For further information, see Mechanical axis 
management).

Properties 
Group Property Description

Conversion

These two parameters set the conversion between motor steps and axis movement.

Steps [steps] The number of steps to move the motor to the distance given a the 
Units value.

Units [mm, inch, deg...]

The distance to move the axis when the motor moves the specified 
number of steps. The units value depends on the axis you are man-
aging: if this is a rotary axis, the value is in degrees (e.g., the number 
of steps to rotate of 360°); if this is a linear axis, the value is 
expressed in a linear unit of measure, which is the one you have set 
for the application.
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Parameters

Enable axis If set to True, enables the axis management. The relevant tab will 
appear in the Laser Engine window.

Free Brake Output If set to True, disable the Brake output of the corresponding axis 
keep it free as general output

Free Disable Input If set to True, disable the Disable input of the corresponding axis 
keep it free as general input

Dedicated I/Os

It only applies to the rotor axis (R Axis). It allows managing up to 4 
axis, totally independent of each other. To this purpose, a new out-
puts set can be managed.
If set to True, check the I/Os documentation related to your control 
board and then connect the R Axis to the dedicated outputs set.
If set to False, check the I/Os documentation related to your control 
board and then connect the R Axis to the outputs set used by the X 
Axis.

The following parameters allow the user to set a speed that best fits the mechanical charac-
teristics of the motor in use, so as to prevent the motor from sliding. You can use either steps 
or units as the unit of measure.

Start speed [steps/s]
The motor speed at the beginning of the acceleration ramp.

Start speed [units/s]

Speed [steps/s]
The motor speed at the end of the acceleration ramp.

Speed [units/s]

Ramp time [ms] The time used by the acceleration ramp to go from minimum speed 
(Start speed) to working speed (Speed).

Properties 
Group Property Description
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Autofocus Search 
Speed [step/s]

The motor speed used by AUTO FOCUS SEARCH procedure during 
the accurate search phase. It is important that this parameter is set 
to a significantly lower value than the Z axis Speed to obtain a reli-
able focus search.

Autofocus Search 
Speed [unit/s]

Reset at same speed

If set to True, the same speed that you have set above will be used 
for axis reset (home search).
If set to False, some properties will appear below allowing you to 
enter a different speed for the home search.

Reset start speed 
[steps/s] The motor speed at the beginning of the acceleration ramp during 

reset operation. (These parameters are displayed if the Reset at 
same speed value is set to False).Reset start speed 

[units/s]

Reset speed [steps/s] The motor speed at the end of the acceleration ramp during reset 
operation. (These parameters are displayed if the Reset at same 
speed value is set to False).Reset speed [units/s]

Reset ramp time [ms]

The time used to accelerate from minimum speed (Reset Start 
Speed) to working speed (Reset Speed). Axis reset is performed at a 
different speed to seek for maximum precision. (These parameters 
are displayed if the Reset at same speed value is set to False).

Brake release [ms]
Electromechanical brake release time. This is the time that elapses 
between the brake release signal activation and the start of 
mechanical movement.

After move delay [ms]

Settlement time between the end of the axis movement and the 
marking start. After the motor (especially rotating ones) reaches the 
position, a time must elapse to stop vibrations; this time depends on 
system inertia.

Home search direction

The direction of home search. It can be set to Auto, Decreasing motor 
steps, or Increasing motor steps.
In particular, the Auto option allows to directly search the home in 
the correct direction, based on the current position of the axis.

Reset on Startup If it is set to True, the axis will be moved in Home position at Laser 
Engine startup.

Limits

The following parameters refer to the minimum and maximum limits (in steps) that the 
axis can reach.

Minimum [steps]
Minimum motor position limit

Minimum [units]

Maximum [steps]
Maximum motor position limit

Maximum [units]

Zero [steps] Position of the logic zero in relation to the mechanical zero. Each 
movement of the axis is considered in relation to the logic zero. 
Conversely, home search locates the mechanical zero (home sen-
sor).

Zero [units]

Properties 
Group Property Description
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Ring Offset [steps] Logical zero offset of axis Z in the revolution center. This param-
eter enable the possibility of using two zero logical reference, the 
logical zero for layer documents and 'Ring Offset' added to logical 
zero for Ring documents.

Ring Offset [units]

Reverse axis
The True value sets the reverse of axis logic. It can be used when 
axis orientation is reverted, so that the mechanical zero is placed 
where the operator expects.

Commands

The following parameters can be used to test the settings during setup phase.

Home search It enables the search of the home sensor (mechanical zero) at the 
speed that has been specified for the Reset parameters. 

Move to [steps]
These parameter allows moving the axis in the desired position

Move to [units]

The following parameters are read-only and depend upon the three parameters above.

Home flag If checked indicates that the home position (mechanical zero) has 
been reached.

Current position 
[steps] It shows the last position the axis has reached (steps or units) 

accordingly to the Move to parameters.Current position 
[units]

Properties 
Group Property Description
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Configuring the Marking on the Fly function
Notes

When this option is enabled all objects are automatically ordered so that they 
will be marked in the opposite direction of the roller. In this way we take advan-
tage of the movement to extend the marking field.
This feature is typically used on a production line where a conveyor roller is 
connected to the laser system, and both are controlled by a PCI control board.
You might connect an encoder to the system for best performances or set the 
Continuous marking mode to mark repeatedly the same content.
A Wizard is provided that you can access from the Marking on the Fly configu-
ration window, which helps you to properly configure and use this function.

When using an Encoder
When high quality or high precision is required, for example, in the case of very 
small laser markings, an encoder allows for best performances.
The encoder counts the roller movements and instantly determines its speed. 
This allows to obtain the correct position of the moving target and to ensure 
high marking precision.
When the target is detected by the sensor and the start is given, the encoder 
calculates the target's position by giving a specific amount of pulse counts for a 
specific distance.
Time for calculation is allowed by the Start Delay property.

Notes

When using the Continuous marking mode
The Continuous marking mode allows setting the laser so that the same mark-
ing will be repeated at predefined distances or intervals.
Typically, it is used when you need to mark repeatedly a continuous tube at a 
specified distance.
When you set this mode, the sensor detects the target and the start is given 
only once; then, the marking is repeated every time the specified distance is 
reached.
If an encoder is being used, the distance value for repetitions must be set in 
mm, while if no encoder is being used, the value is set in ms.

The Marking on the Fly function is only available on iMark 
control boards.

If you are not using an encoder (e.g., if the target moving 
speed is known or no high marking precision is required), you 
can simulate it by enabling the Simulation parameter, and 
then specifying an average speed.
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Setting the configuration parameters
Notes

By clicking Marking on the Fly in the Laser Configuration window, the following 
configuration window opens.

Note that a Wizard is provided that guides you through the correct setup of 
hardware connections and parameters that control this function. (See Parame-
ters description for a description of all parameters).
The following describes how the Wizard is to be used.

Prerequisite:
In order for the Marking on the Fly function to work properly, it 
is mandatory that you set the following parameter:
Laser Configuration > Scan parameters > Standby Position = 
Center.
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Using the Wizard
• In the Marking on the fly configuration window, click Wizard. The first win-

dow displays that allows checking the hardware and cable connections.

• Follow the instructions as described in the Wizard to check that everything 
is connected and working properly and that the photocell is correctly 
mounted:
• If you have an encoder, after powering on the transport belt, ensure that 

the blue gear in the window animates.
• If you do not have an encoder connected to your system, select Simulate 

Encoder Signal.
• After activating the external start signal, ensure that the Start Signal led 

in the window turns green.
Input 0 to15 turn green to indicate currently active input signals, if any; other-
wise, they are grey (if not in use or inactive).

Notes

• Click Next. The Scan Head Position window is displayed that allows defin-
ing the origin of the object to mark relative to the marking field in order to 
determine the correct marking direction:

If you only need to check hardware and cables connections, 
you might close the Wizard.
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• Follow the instructions and complete the test as described in the window 
until the arrow points correctly.

• Click Next. The Speed conversion window is displayed that allows calculat-
ing the Scale Factor that defines the speed of the transport belt. This way 
you do not need to use specific instruments to calculate this value:

• Follow the instructions as described in the window.
The value that is displayed in the Speed box after completing the test is 
the value that is to be used to calculate the Scale Factor that must be 
entered in the Marking on Fly Configuration window (counts/mm if you 
have an encoder, mm/sec. if you are using the simulation). The speed cor-
responds to the number of pulses that elapse between the objects to 
mark.

• Click Next. The Start Delay window is displayed that allows calculating the 
distance between the start sensor, which detects the object to mark, and 
the center of the marking field. This test does not actually mark; rather, it 
allows checking that the distance is correctly set:

• Follow the instructions as described in the window.
After pressing Run, ensure that the small circle that the laser tracks is 
pointing the target when this arrives in the marking field. If not, verify the 
Start delay distance, and then repeat the test. If the Start delay is correctly 
set, you must recalculate the computed speed (Wizard window Speed Con-
version).

• Click Next. The Fine Tuning window will displays that allows fine tuning 
the parameters and verifying that the speed of the transport belt (Scale 
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Factor) has been correctly calculated. The test will actually execute a 
marking while the belt is moving.

• Follow the instructions as described in the window. Note that by repeating 
the test and selecting the desired circle, the speed changes until the circle 
is marked correctly.

• You might also change the Power, Frequency, and Scan speed values to 
suit your specific needs, based on the material on which you are marking.

• When finished click on Finish.
• Complete the parameters in the Marking on the Fly Configuration window, 

as needed. See the table in the following for a description.
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Parameters description
The table here below describes the parameters that appear in the Marking on 
the Fly window:

Property 
Group Parameter Description

Enable the Marking 
on the Fly

Select the checkbox to enable the feature.
(For best practices in setting this feature so as to follow your 
needs, see When using the Continuous marking mode.)

Encoder

Simulation If this option is selected, Encoder is simulated by the iMark control 
board, that is, the laser will chase the target at the given speed.

Scale factor

The conveyor roller (or the target moving) speed. There are two 
possible scenarios:

• If an encoder is being used, this value corresponds to the 
number or pulses for millimeter, as measured by the 
encoder.

• If you are using the simulation, you must specify a value that 
corresponds to the average roller speed based on the time (in 
mm/sec.).

Use the Speed conversion window of the Wizard to calculate this 
value.

Reverse encoder It allows reverting the signal to the encoder so reverting the mark-
ing direction

Direction

Position

The axis along which the targets are marked on the conveyor roller, 
relative to the head scanner.
Use the Scan Head Position window of the Wizard to correctly 
determine the direction.

Offset [mm]

An additional offset that can be used to fine-tune the marking 
operation. Negative offsets will move the layout in the direction 
that the target is coming from. Use this parameter to adjust layout 
position and take full advantage of target movement to extend 
marking field. The following picture shows how this parameter 
affects the marking operation:

Reverse polygon 
ordering

It sets the ordering of the polygons, based on both the scan head 
configuration (X / Y Axis) and the direction of the object to mark.
Use the Scan Head Position window of the Wizard to set this 
parameter.
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Settings

Unit [mm] or [ms] Measure unit, either in [mm] or [ms], for the Start Delay parameter.

Start delay [mm] or 
[ms]

Distance in [mm] or delay in [ms] between the center of the mark-
ing field and the Proximity sensor.
Use the Start Delay window of the Wizard to calculate this value.

Start queue delay 
[mm] or [ms]

The START QUEUE DELAY parameter is used to implement a 
START_MARKING queue environment.
When the START QUEUE DELAY is set to a value >0 ms, the 
START_MARKING events that occur from a START_MARKING event 
and the duration of START QUEUE DELAY, are not lost, but 
deferred.
This allows to position the sensor that manages the 
START_MARKING, at a distance from the scanhead, greater than 
the distance that separates the pieces to be marked.
The START QUEUE DELAY parameter shall be used both in STATIC 
that in Marking on the Fly mode.

Continuous marking

Select this option if you want to mark the same layout repeatedly 
at a specific distance.
If an encoder is being used, this value is in [mm]. If you are using 
the simulation, this value is in [ms].

Distance [mm] The distance in [mm] between markings when the Continuous 
marking mode is enabled.

Property 
Group Parameter Description
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Setting the Network parameters
The network configuration window contains the following parameters:

Properties 
Group Property Description

Network Device Network 
Name 

Specify the name of the device used by Lighter in a remote mode 
environment. It is useful when many laser are connected to the 
same network and you need to recognize them.

TCP Server Port Number Specify the port number of the TCP Server Protocol used by Laser 
Engine in a remote mode environment.

Ethernet/IP Network Adapter Specify the network adapter on which to enable the Ethernet_IP 
connection.

Local area 
connection

DHCP Settings

If Use DHCP is set, the IP address is assigned automatically (check 
if your network support this capability).
If Specify IP address manually is set, you have to ask your network 
administrator for the appropriate IP settings.

IP Address IP Address of device

Subnet Mask Subnet Mask

Default Gateway Default Gateway

Preferred DNS 
Server Preferred DNS Server

Alternate DNS 
Server Alternate DNS Server
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MARVIS configuration
The MARVIS configuration window is used to set the following parameters.

Properties 
Group Property Description

Connection

Device Firmware 
Upgrade This button allows upgrading the reader's firmware.

Device Discovery This button allows discovering one or more readers connected 
to the network.

Device IP Address IP address of the reader connected to the laser marker.

Device Model Model of the reader connected to the laser marker.

Device Name Name of the reader connected to the laser marker.

Device Serial Serial number of the reader connected to the laser marker.

Manage Device This button allows to set the parameters of reader connected to 
the laser marker.

Timeout (ms)
Timeout determines the length of time for the waiting of 
response from the reader before giving an error. Admitted val-
ues are 5000 to 30000 ms.

Device Test This button performs a connection test between the laser 
marker and the reader.

Validation

Parameters in this area allow the programming of generic input/outputs to be used in 
automatic applications.
Note: the Matrix reader inputs/outputs are not used in MARVIS applications.

MARVIS GOOD/BAD 
signal General purpose output signal of GOOD/BAD validation.

MARVIS End Signal General purpose output signal of validation End.

MARVIS Error Signal General purpose output signal of generic error occurred during 
the validation time.

Acquisition Trigger This field allow to select the acquisition trigger mode to use for 
the validation.

Good String User defined strings shown in MARVIS statistics image. See 
MARVIS Application Note for more information.Bad String

External Illuminator If set to True, the laser marker use the external illuminator.
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Images

Parameters in this area allow to set the desired preferences for saving the images 
acquired during the validation time.

Image Saving This field allows to choose which images to save.

Max Images Space 
[MB]

This parameter sets the maximum space reserved for saving 
the images. Admitted values are 1 to 1000 MB.

Current Saving Path: This field shows the saving path for images.

Image Saving Path This button allows to choose the saving path.

Image format This field allows to choose in which format to save images.

Database
These parameters in this area allows the setting of the space reserved for validation sta-
tistics information.

Max Size [MB] Admitted values are 1 to 500 Mb.

Properties 
Group Property Description
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Distance Sensor configuration
The Distance Sensor is used together with the Z Axis, to automatically adjust the focus 
distance between the F-Theta scan lens and the object to be marked.
The AUTOFOCUS SEARCH procedure perform the following steps to find the right focal 
distance:
1) Search direction way of the Z axis: this step is executed only if the search direction 
way is still not defined
2) The Z Axis moves in the right direction to roughly approach the FOCUS DISTANCE 
REFERENCE 
This step is executed only if the difference between the distance read by the distance 
sensor and the FOCUS DISTANCE REFERENCE is higher than the ACCURATE SEARCH DIS-
TANCE.
The Z Axis movement is executed at relative high speed (Z Axis Speed parameter)
If at the end of this step the distance measured by the distance sensor is the FOCUS 
DISTANCE REFERENCE ± TOLERANCE the procedure complete successfully and the next 
step is not executed
3) The Z Axis moves at relative low speed (Z Axis Autofocus Search Speed parameter) to 
obtain a more precise positioning.

Properties Group Property Description

Focal Distance 
Sensor

Sensor Type Disabled or M_OADM13T645S35A

Tolerance [μm]

This property define the tolerance value used by AUTO FOCUS 
SEARCH procedure. The AUTO FOCUS SEARCH procedure is 
completed with success when, at the end of the procedure, the 
reading distance from the sensor is the FOCUS DISTANCE REF-
ERENCE value ± the tolerance value

Edit advanced parameters 
button

This button enables more parameters that allow configuring 
the distance sensor, so as to suit your needs. This function is 
intended for specialized technicians who will be provided with 
an ad hoc password

Direction Calibration Dis-
tance [μm]

This property is used by the AUTO FOCUS SEARCH procedure to 
automatically define the search direction way

Accurate Search Distance 
[μm]

This property is used by AUTO FOCUS SEARCH procedure to 
define the distance below which only the accurate search pro-
cedure is performed

Enable sensor check

This button start the communication with the distance sensor 
and the real-time distance reading.
The red laser beam of the distance sensor is ON while the aim-
ing and focusing beam of the system are OFF

Reading Distance [mm] Show the real-time distance in mm

Sensor Status

Sensor Available
Shown when the distance sensor com-
municate correctly with the system and 
it is working in the range

Sensor out of 
range

Shown when the distance communicate 
correctly with the system but it is work-
ing out of the range

Sensor not avail-
able

Shown when the distance sensor is not 
ready 
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Service
In the Service page are displayed system informations.

Properties 
Group Property Description

System Info

Serial Number System serial number

FW revision Shows the laser control board FW and HW revision separated by dot

System Working 
Hours System working hours expressed in hours and minutes

CPU Temperature Shows the CPU internal temperature of the laser control board.

BOARD#1 Tempera-
ture [°C]

Shows the temperature of the laser control board sensor near the 
switching power supply unit

BOARD#2 Tempera-
ture [°C]

Shows the temperature of the laser control board sensor near the rear 
panel connectors

Scanhead Tempera-
ture [°C] Shows the temperature of the internal sensor inside the scan head

Rack Temperature 
Error [events]

This counter is incremented every time the system temperature is out 
of the operating temperature range

Scanhead Tempera-
ture Error [events]

This counter is incremented every time the scan head temperature is 
out of the operating temperature range.

Service Interface 
Error [events]

This counter is incremented every time the service interface failed due 
to MMC error

Safety Info Safety Relay Switch-
ing [events]

Counter of the SAFETY FUNCTIONS events. The SAFETY FUNCTIONS 
events counter is incremented every time the INTERLOCK or 
LASER_STOP safety function are activated

Laser Source 
Info

Serial Number Source serial number

Source Working 
Hours Source working hours expressed in hours and minutes

Diode Working 
Hours Diode working hours expressed in hours and minutes

Temperature Error This counter is incremented every time the Laser source temperature 
is out of the operating temperature range

Power Supply Error This counter is incremented every time the External supply voltage of 
the laser source is out of the specified range

Back Reflection 
Error

This counter is incremented every time the laser source detect an high 
optical power reflected back to the laser

Generic Alarm This counter is incremented every time the laser source detects an 
internal failure

Backup and Restore Service Data Activate the Edit advanced parameter function to enable Set, Reset, 
Backup, Restore and Reset All buttons
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Managing axis and executing the laser test
Notes

Laser Engine provides you with a graphical user interface for directly manage 
axes movements, which are controlled by step motors.
You can move an axis either by setting axis parameters, or by using the arrow 
keys on your keyboard.
For further information:

Topic Contents

Mechanical axis management A brief technical description of how the software 
manages axis.

Using the X-Y or Rotor Axis tabs for axis man-
agement

How to manage the linear or rotary mechanical axis 
of your device.

Using the Z Axis tab for axis management and 
laser test

How to manage the mechanical axis that allows 
focusing on different levels and how to execute the 
laser test.

The X-Y Axis, Z-Axis and Rotor Axis tabs of the Laser Engine 
interface are only available if the laser is compliant and prop-
erly configured, that is, if axis have enabled at the laser con-
figuration level (see Setting the X, Y, Z, and Rotor Axes 
parameters).
In particular, the Rotor Axis tab, is only available if a rings sep-
arator is installed on your device.
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Mechanical axis management
Description of the settings related to axis requires a brief description of the way 
the software manages axis.

Axes reference
The figure below shows axis logical (blue) and mechanical (black) references. 
These can be different as logical representation is built upon what the operator 
expects while mechanical representation depends on design choices or needs. 
In the figure, Z axis shows this difference: orientation is reversed and logical 
zero is placed on a totally different quote than mechanical zero (where the zero 
sensor is placed).
Step motors drive axis movement. Axis can be either linear or rotary. Devices 
that drive axis movement obviously have Minimum and Maximum, that is, 
quotes than cannot be outgone; this is true for rotary axis as well: even though 
rotation could continue, limits are set so that reference cannot exceed them.

Linear vs. rotary axis
The software drives axis in the same way, be they linear or rotary.
The main setting is the conversion between motor step and axis movement. In 
linear axis this is the number of steps to move the motor of 1mm (or any other 
reference: 1meter, 1inch, etc.); in rotary axis this is the number of steps to 
rotate of 360° (or any other angle measure).
Inversion indicates rotation direction in rotary axis.
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Using the X-Y or Rotor Axis tabs for axis management
Notes

X, Y, and Rotor axis are the linear and rotary mechanical axes used to position 
objects under the laser via step motor control. (See Mechanical axis manage-
ment for further information).
By using these tabs, you can control axes movements and objects position on 
the working plane.

To manage axes:
The example below describes how to use the X-Y Axis tab to check and manage 
the linear mechanical axes. Using the Home Search command button, results in 
the axis motor moving so as to reach the proximity sensor. The meaning of the 
fields on the Rotor Axis tab is identical.

• Select the X-Y or Rotor Axis tab of Laser Engine, depending on which axis 
you are moving.

• The example above represents a working plane with two linear axes that 
move the object in the X and Y directions; it shows you the position of the 
laser spot on the plane.

• Click Home Search. If the Home Flag is not checked, that is, if the zero has 
not been reached, the motor starts moving towards the proximity sensor, 
until the sensor is reached. The motors will not move if the Home Flag is 
already checked.

These tabs are only available if axes are enabled at the laser 
configuration level (see Setting the X, Y, Z, and Rotor Axes 
parameters).
Fields on the tabs are only available if the Local control and 
the Manual mode are activated. (See Switching between 
working modes).
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• The parameters underneath means the following:
• Home Flag - This checkbox is selected if the zero has been reached, that 

is if the 0 sensor is activated.
• Minimum position - The minimum motor position that the axis can 

reach.
• Maximum position - The maximum motor position that the axis can 

reach.
• Current position - It shows the last position the axis has reached.
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Using the Z Axis tab for axis management and laser test
Notes

The Z Axis is used to focus the laser on different levels. (See Axes reference for 
further information).
By using the Z Axis tab you can also perform the laser test for focus. (See EExe-
cuting the laser test for focus).
Managing the Z Axis
The example below describes how to use the Z Axis tab to check and manage 
the axis. Using the Home Search command button, results in the axis motor 
moving so as to reach the proximity sensor.

• Select the Z Axis tab of Laser Engine.

• Please, refer to the previous section To manage axes: for further informa-
tion on the Home Search button and parameters underneath.

Executing the laser test for focus
This function allows searching the focal plane.
For optimal performance, when engraving the laser head must be at the correct 
focus distance from the item to be engraved.
The laser test allows engraving a geometric shape with predefined parameters 
and position the axis at the same time.

The Z Axis tab is only available if the axis is enabled at the 
laser configuration level (see Setting the X, Y, Z, and Rotor 
Axes parameters).
Fields on the tab are only available if the Local control and the 
Manual mode are activated. (See Switching between working 
modes).
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To execute the test:
• Select the Z Axis tab of Laser Engine.
• Under Laser Test, set the following parameters:

• From the Type dropdown list, select the required geometrical shape for 
the test (Square, Line, Circle, or Dot).

• Specify the Size for the shape and the laser output Power (expressed in 
percentage), according to your device's maximum power.

• Specify the laser output Frequency. This parameter is used to adjust the 
laser output frequency by directly operating on the Q-switch.

• Specify if the Continuous Emission should be used. This parameter is 
used only by DPSS laser source.

• Specify the Pulse Profile. This parameter is used only by MOPA laser 
source.

• Click  to launch the test. A greater interaction of the laser with 
the material under examination indicates that the optimal focus has been 
obtained.

Notes

Executing the Autofocus Search (if available)
The distance sensor is used togheter with the Z Axis, to automatically adjust 
the focus distance between the scan head and the object to be marked, without 
using manual tools 

Set the focus position:
• Select the Z Axis tab of Laser Engine.
• Press the Home Search button
• Move the Z Axis in the Focus position
• Press Set Focus Distance Reference

To execute  the Autofocus search
• Press Autofocus button

The correct position can be identified as the engraving point in 
which the laser generated noise and luminosity are at the 
maximum.
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Correcting lens distortion
In laser marking, lens and mirrors that are used to deflect the laser light, pro-
duce distortions whose correction is critical to an accurate marking operation.
The Lens Correction function provides a way to easily correct this phenomenon.
Related topics:

• Setting the Correction parameters
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Sending documents to marking
Notes

By using the Laser Engine interface, you can send to marking any document 
that has been saved to the device. (See Saving a layout to a device).
To send a document to marking

• Be sure that you are in Manual working mode. (To check the current work-
ing mode, move the pointer over the  button.)

• In the Name area of the Documents tab, select the.xlp document you 
want to mark.

• Click  to send the document to marking. To stop the marking click .
Note that, as the laser marks, in the lower part of the Preview pane, the prog-
ress bar moves and the marking time decreases.

Notes

This button is only available if the Local control is activated. 
(See Switching between working modes).
To select a document, or to perform testing operations, as well 
as to make any other change, you must activate the Manual 
Mode (see Auto/Manual working mode).

The Laser Editor's Mark preview function (see Marking pre-
view), that allows previewing how lines will be marked by the 
laser and verifying the marking time, has been implemented 
as a scripting object. Programmers can add the object to their 
user interface to allow operators to check the layout being 
engraved.
(For further information, see the Project Editor's online docu-
mentation, "Language reference" section.).
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Viewing the Device Status
The Device Status tab of the Laser Engine interface is a read-only window that 
shows the device status information. It is available only if you are using 
ULYXE™, VLase™, Arex™ 20MW or AREX™ 400 devices.
The coloured icon at the right-bottom of the window shows the device status 
(see table Icons representing the device status).
In addition to provide status information, this feature helps you to diagnose or 
correct errors that might arise.

The status icon on the right-bottom of the window changes accordingly to the 
device status. The meaning of each icon is described in the following table:
Icons representing the device status

Icon Device Status Meaning

OFF The laser is OFF or disconnected.

WARNING

This status means that the VLASE is connected, no error is detected, 
but it cannot be used. Possible reasons are:

• key sequence is incorrect
• emergency has been activated
• the laser is warming-up

Tip: For a detailed description, as well as for troubleshooting warnings, please refer to the manual 
provided by your laser source's manufacturer.

WAIT The laser is waiting for input.

STAND-BY or READY The laser is in stand-by or it is ready, and the shutter is closed.
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READY The laser is ready to be used.

BUSY The laser is currently marking.

ERROR
The laser device is in an error status.
When the error status is detected, neither documents nor projects can 
be sent to marking.

Tip: For a detailed description, as well as for troubleshooting error conditions, please refer to the 
manual provided by your laser source's manufacturer.

Icon Device Status Meaning
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Statistics
Shows the statistics about the marking processes and marking & validation 
processes.

Statistics on marking processes are available in the Layouts section. The follow-
ing statistics are displayed:

• OK: marking processes correctly performed
• ERROR: errors in marking processes
• STOPPED: marking processes stopped by an external command

Statistics on validation are available in the Validation section (feature available 
with Marvis enabled; see the Marvis Application Note for more details). The fol-
lowing statistics are displayed:

• MATCH: to match what is marked
• GRADE TRESHOLD: for good/bad match and good/bad grade

Image section (feature available with Marvis enabled; see the Marvis Application 
Note for more details). When the Display last acquired image property is 
checked the last acquired image from the reader is shown.
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History: press this button to access the results history detail.

In the history window it is necessary to select the desired time period:
• Start: set the starting time
• End: set the end time
• Clear: this button deletes all the information of the selected period 

(including database and images).
When the images space and DB used space are full, the oldest data are auto-
matically overwritten. To delete the data manually, use the clear button.

Show Match Details: this button shows the match detail (to enable this button 
select the marking in the time period filed)

Update: press this button to update the time period field (for it works, the end 
of the time period must be set forward of the current time
Export Data: press this button to export the data to a .cvs file. It is also set an 
automatic export from the drop down menu.
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Understanding the log file

The View log shortcut menu command of the Laser Engine interface lists all 
actions that have occurred so allowing to correct any problem that might occur. 
The default size for the log file is set both in Laser Editor and Laser Engine.
In Laser Editor is set via the General page of the Laser Editor Configuration win-
dow, Max Log Space. For information on accessing this window, see Setting 
language, measurement unit and graphical effects (General page).

In Laser Engine is set via the General page of the Laser Engine Configuration 
window, Max Log Space. For information on accessing this window, see Setting 
the General parameters.

In particular:
• the Max log space parameter defines the disk space for log files. When the 

system date change, the application check if this space has been 
exceeded, and if true, oldest files are deleted.

• the Max log file number parameter defines how many files the log space 
should be divided into.
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To access the Log:
• In your Windows application bar, right-click the Laser Engine icon to dis-

play the shortcut menu.
• Click View log to display the log file.

To increase the maximum log level, see To increase the log level here below. 

To understand the log file
The information on the log file is color-coded to help you understand if action 
is required: 

• Black colour - Informational message. No action is required.
• Blue colour - Warning messages. Action might be required.
• Red colour - Error messages. Action is required.

To increase the log level
To increase the log level, that is, the level of detail for the log file, you must fol-
low this procedure: 

• Close Laser Engine
• Open Laser Editor and click Help > Open Data Folder 

• Go to folder Data\Config.
• Double click on LaserEngine.ini.
• Change the log level value of the component whose log level you want to 

increase or decrease:
• LogLevel: general log information about Laser Engine
• LogLevelComPort: specific log information about COM port managed by 

Laser Engine
• LogLevelxLaser: specific log information about low level funcitions man-

aged by Laser Engine
• LogLevelTcpIp: specific log information about TCP / IP protocol man-

aged by Laser Engine
• LogLevelCan: specific log information about CAN messages managed by 

Laser Engine
• Note: the default value is 4 that corresponds to the lowest level of detail. 

Lower the value, higher the log level, that is, set this value to 0 for the 
maximum level of detail.

• Note: to obtain a detailed log file set LogLevel=0 and LogLevelxLaser=0
• Save LaserEngine.ini
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Testing the system

The System test shortcut menu command of the Laser Engine interface allows 
accessing the dialog where you can check your system's connections.
In particular, besides testing the Laser, you can test all Inputs and Outputs, as 
well as the external Start and Stop signals.

To test the system's connections:
• In your Windows application bar, right-click the Laser Engine icon to dis-

play the shortcut menu.
• Click System test to display the dialog:
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To test the Laser:
• Under Laser Test set the following parameters:

• From the Type dropdown list, select the required geometrical shape for 
the test (Square, Line, Circle, or Dot).

• Specify the Size for the shape and the laser output Power (expressed in 
percentage), according to your device's maximum power.

• Specify the laser output Frequency. This parameter is used to adjust the 
laser output frequency by directly operating on the Q-switch.

• Specify if the Continuous Emission should be used. This parameter is 
used only by DPSS laser source.

• Specify the Pulse Profile. This parameter is used only by MOPA laser 
source.

• Click the button launch the test.

To test the inputs:
The inputs are activated/deactivated via the external Start and Stop commands. 
If the inputs do not become green (activated) something is wrong in your con-
nections:

• When the external Start is pressed, the Start led becomes green. Check 
that the Input leds become green.

• When the external Stop is pressed, the Stop led becomes green.

To test the outputs:
To test the outputs connections you must manually activate them, either one by 
one or all at once:

• To check the outputs one by one, click the relevant button.
• To check all outputs at once, click Change all outputs.

If the Output button changes to green, it indicates that it is activated and 
that all connections are set correctly. If the output button is still grey, 
something is wrong in your connections.

• When the Ready button is green and activated, it indicates that the device 
is ready for the marking operation.



Photometric Adjustment

User Guide                            245

Photometric Adjustment

This chapter describes how to configure the photometric parameters of the 
reader.
Click the Auto Setup button to automatically configure the photometric param-
eters
If the Auto setup is completed correctly the decoding is successful:

Notes Auto Setup estimates the exposure time and gain parameters 
based on the luminosity and contrast observed in the cap-
tured image but it doesn't always correspond to the optimum 
results for Quality Grading. We recommend therefore to con-
sider the Auto Setup results as a starting point to obtain the 
optimum working conditions. If you don't obtain the expected 
grading results from your reference samples, you should 
adjust the photometry parameters manually and observe the 
statistical behavior of the grading until the desired results are 
obtained.
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The Manual Setting configuration window is used to set the following parameters:

Properties 
Group Property Description

Settings

Exposure Time

It defines the time during which all pixels of the CMOS image sen-
sor synchronously capture the frame. This parameter must be set 
according to the environmental conditions (external lighting, code 
contrast etc.). In general, a longer time corresponds to a lighter 
image but is susceptible to blurring due to the code movement. A 
shorter exposure time corresponds to a darker image.
NOTE: The range of values and step of this parameter change 
according to the Internal Lighting Mode parameter setting, there-
fore, after changes to Internal Lighting Mode, recheck Exposure 
Time.

Gain Amplifies or reduces the pixel gray level effectively increasing or 
decreasing the contrast of the image.

Gain Multiplier Multiplies the defined Gain from x2 to x10 times. If set to x1, the 
defined Gain is left unchanged.

Internal Lighting

Sets the operating mode of the internal lighting system. Possible 
values are:
Disabled: the built-in LED array is turned off all the time. This 
option can be useful if using an external lighting system;
Always On: the built-in LED array is turned on all the time at the 
lowest power level. This option is useful if the LED-array blinking 
(produced by -Power Strobed lighting modes and rapidly occurring 
reading phases) disturbs the operator.
- Power Strobed: the built-in LED array is on only during the image 
exposure time. Different Power Strobed lighting levels can be set.
NOTE: To avoid LED array overheating, for Power Strobed settings, 
the program automatically limits the range of allowed values for 
the Exposure Time parameter. It is strongly recommended to use 
high lighting values for short exposure times.

LED Group

This parameter enables one of the two possible internal lighting 
system LED groups: internal or external. The internal LED Group 
provides Bright Field illumination for dark absorbing backgrounds. 
The external LED Group provides low angle Dark Field illumination 
for DPM applications or highly reflective backgrounds.

Sectors This parameter allows selecting which quadrants of the selected 
LED group will be enabled.

Reading Distance
For Liquid Lens models, this parameter sets the reading distance 
(measured in mm) defined as the distance from the reading win-
dow to the code surface.

Results

Result Table In the Result Table Tab the values of the reading are displayed.

Console
In the Console Tab the readings of the parameters defined by the 
user are displayed. The parameters to be displayed can be selected 
by pressing the button Console Configuration.

Click Try to decode to perform a decoding test.
Click Still or Live to enable the desired viewing mode.
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Quality Grade Training
Accordingly with ISO /IEC TR 29158 that includes the AIM DPM-1-2006, seven 
quality parameters or Metrics have been defined. The knowledge of the mean-
ing of each quality parameter may be helpful in laser marking process tuning. 
Each quality parameter is classified into grades from A to F, and OVERALL is 
defined as the lowest result among all the parameters or metrics.
Type the acquisition number to be executed and start the learning by pressing 
Start Training button. At the end of the learning the percentages/numbers and 
degree of reading quality will be displayed in the Grade Profile column.
It is possible to suspend the training iteration process by pressing the Pause/
Continue button. This allows, for example, to change one or more samples 
during the training process.
Click Stop Training button to stop the verification process before the end.

Click Still or Live to enable the desired viewing mode.
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